Upstream information

CVE-2020-11987 at MITRE

Description

Apache Batik 1.13 is vulnerable to server-side request forgery, caused by improper input validation by the NodePickerPanel. By using a specially-crafted argument, an attacker could exploit this vulnerability to cause the underlying server to make arbitrary GET requests.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.4
Vector AV:N/AC:L/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.2 5.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Changed
Confidentiality Impact High Low
Integrity Impact Low None
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1182748 [NEW]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • xmlgraphics-batik >= 1.15-2.1
  • xmlgraphics-batik-css >= 1.15-2.1
  • xmlgraphics-batik-demo >= 1.15-2.1
  • xmlgraphics-batik-javadoc >= 1.15-2.1
  • xmlgraphics-batik-rasterizer >= 1.15-2.1
  • xmlgraphics-batik-slideshow >= 1.15-2.1
  • xmlgraphics-batik-squiggle >= 1.15-2.1
  • xmlgraphics-batik-svgpp >= 1.15-2.1
  • xmlgraphics-batik-ttf2svg >= 1.15-2.1
Patchnames:
openSUSE Tumbleweed GA xmlgraphics-batik-1.15-2.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 xmlgraphics-batik Affected
SUSE Enterprise Storage 7.1 xmlgraphics-batik Affected
SUSE Linux Enterprise Desktop 15 SP4 xmlgraphics-batik Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 xmlgraphics-batik Affected
SUSE Linux Enterprise Module for Development Tools 15 SP4 xmlgraphics-batik Affected
SUSE Linux Enterprise Real Time 15 SP3 xmlgraphics-batik Affected
SUSE Linux Enterprise Server 15 SP4 xmlgraphics-batik Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 xmlgraphics-batik Affected
SUSE Manager Proxy 4.2 xmlgraphics-batik Affected
SUSE Manager Proxy 4.3 xmlgraphics-batik Affected
SUSE Manager Retail Branch Server 4.2 xmlgraphics-batik Affected
SUSE Manager Retail Branch Server 4.3 xmlgraphics-batik Affected
SUSE Manager Server 4.2 xmlgraphics-batik Affected
SUSE Manager Server 4.3 xmlgraphics-batik Affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP2 xmlgraphics-batik Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS xmlgraphics-batik Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS xmlgraphics-batik Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 xmlgraphics-batik Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS xmlgraphics-batik Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS xmlgraphics-batik Affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 xmlgraphics-batik Affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 xmlgraphics-batik Affected
SUSE Linux Enterprise Server 15 SP2 xmlgraphics-batik Affected
SUSE Linux Enterprise Server 15 SP2-LTSS xmlgraphics-batik Affected
SUSE Linux Enterprise Server 15 SP3 xmlgraphics-batik Affected
SUSE Linux Enterprise Server 15 SP3-LTSS xmlgraphics-batik Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 xmlgraphics-batik Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 xmlgraphics-batik Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 xmlgraphics-batik Affected
Products past their end of life and not receiving proactive updates anymore.
SUSE CaaS Platform 4.5 xmlgraphics-batik Affected
SUSE Linux Enterprise Desktop 15 SP2 xmlgraphics-batik Affected
SUSE Linux Enterprise Desktop 15 SP3 xmlgraphics-batik Affected
SUSE Linux Enterprise Real Time 15 SP2 xmlgraphics-batik Affected
SUSE Linux Enterprise Server 15 SP2-BCL xmlgraphics-batik Affected
SUSE Linux Enterprise Server 15 SP3-BCL xmlgraphics-batik Affected
SUSE Manager Proxy 4.1 xmlgraphics-batik Affected
SUSE Manager Retail Branch Server 4.1 xmlgraphics-batik Affected
SUSE Manager Server 4.1 xmlgraphics-batik Affected


SUSE Timeline for this CVE

CVE page created: Wed Feb 24 16:59:51 2021
CVE page last modified: Fri Jan 20 15:22:24 2023