Upstream information

CVE-2019-13207 at MITRE

Description

nsd-checkzone in NLnet Labs NSD 4.2.0 has a Stack-based Buffer Overflow in the dname_concatenate() function in dname.c.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 6.5
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High None
Availability Impact High Low
CVSSv3 Version 3 3.1
SUSE Bugzilla entry: 1182952 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 12
  • nsd >= 4.3.4-8.1
Patchnames:
openSUSE-2020-2222
SUSE Package Hub 15 SP1
  • nsd >= 4.1.27-bp151.3.3.1
Patchnames:
openSUSE-2020-2222
SUSE Package Hub 15 SP2
  • nsd >= 4.3.4-bp152.2.3.1
Patchnames:
openSUSE-2020-2222
openSUSE Leap 15.1
  • nsd >= 4.1.27-lp151.2.3.1
Patchnames:
openSUSE-2020-2222
openSUSE Leap 15.2
  • nsd >= 4.3.4-lp152.2.3.1
Patchnames:
openSUSE-2020-2222
openSUSE Tumbleweed
  • nsd >= 4.3.7-1.2
Patchnames:
openSUSE Tumbleweed GA nsd-4.3.7-1.2