Upstream information

CVE-2019-10173 at MITRE

Description

It was found that xstream API version 1.4.10 before 1.4.11 introduced a regression for a previous deserialization flaw. If the security framework has not been initialized, it may allow a remote attacker to run arbitrary shell commands when unmarshalling XML or any supported format. e.g. JSON. (regression of CVE-2013-7285)

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 7.3
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High Low
CVSSv3 Version 3.1 3
SUSE Bugzilla entry: 1142383 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 xstream Already fixed
SUSE Linux Enterprise Desktop 15 SP5 xstream Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP5 xstream Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP5 xstream Already fixed
SUSE Linux Enterprise Real Time 15 SP3 xstream Already fixed
SUSE Linux Enterprise Server 15 SP5 xstream Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP4 xstream Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP5 xstream Already fixed
SUSE Manager Proxy 4.3 xstream Already fixed
SUSE Manager Retail Branch Server 4.3 xstream Already fixed
SUSE Manager Server 4.3 xstream Already fixed
SUSE Manager Server Module 4.3 xstream Already fixed
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 xstream Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 xstream Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS xstream Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS xstream Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3 xstream Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS xstream Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS xstream Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4 xstream Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS xstream Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS xstream Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP2 xstream Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP3 xstream Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP4 xstream Already fixed
SUSE Linux Enterprise Server 15 SP2 xstream Already fixed
SUSE Linux Enterprise Server 15 SP2-LTSS xstream Already fixed
SUSE Linux Enterprise Server 15 SP3 xstream Already fixed
SUSE Linux Enterprise Server 15 SP3-LTSS xstream Already fixed
SUSE Linux Enterprise Server 15 SP4 xstream Already fixed
SUSE Linux Enterprise Server 15 SP4-LTSS xstream Already fixed
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 xstream Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP2 xstream Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP3 xstream Already fixed
Products past their end of life and not receiving proactive updates anymore.
SUSE CaaS Platform 4.5 xstream Already fixed
SUSE Enterprise Storage 7 xstream Already fixed
SUSE Linux Enterprise Desktop 15 SP2 xstream Already fixed
SUSE Linux Enterprise Desktop 15 SP3 xstream Already fixed
SUSE Linux Enterprise Real Time 15 SP2 xstream Already fixed
SUSE Linux Enterprise Real Time 15 SP4 xstream Already fixed
SUSE Linux Enterprise Server 15 SP2-BCL xstream Already fixed
SUSE Linux Enterprise Server 15 SP3-BCL xstream Already fixed
SUSE Manager Proxy 4.1 xstream Already fixed
SUSE Manager Proxy 4.2 xstream Already fixed
SUSE Manager Retail Branch Server 4.1 xstream Already fixed
SUSE Manager Retail Branch Server 4.2 xstream Already fixed
SUSE Manager Server 3.1 xstream Not affected
SUSE Manager Server 3.2 xstream Unsupported
SUSE Manager Server 4.1 xstream Already fixed
SUSE Manager Server 4.2 xstream Already fixed
SUSE Manager Server Module 4.0 xstream Unsupported
SUSE Manager Server Module 4.1 xstream Already fixed
SUSE Manager Server Module 4.2 xstream Already fixed
Products at an unknown state of their lifecycle.
SUSE Linux Enterprise Desktop 15 SP4-LTSS xstream Already fixed


SUSE Timeline for this CVE

CVE page created: Mon Jul 22 17:08:14 2019
CVE page last modified: Tue Jan 2 15:14:09 2024