Upstream information

CVE-2018-20532 at MITRE

Description

There is a NULL pointer dereference at ext/testcase.c (function testcase_read) in libsolvext.a in libsolv through 0.7.2 that will cause a denial of service.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 1120629 [NEW]

No SUSE Security Announcements cross referenced.

List of packages in QA

Product(s) Package(s)
SUSE CaaS Platform 3.0
  • libsolv >= 0.6.36-2.16.1
  • libsolv-debugsource >= 0.6.36-2.16.1
  • libsolv-tools >= 0.6.36-2.16.1
  • libsolv-tools-debuginfo >= 0.6.36-2.16.1
  • libzypp >= 16.20.0-2.39.3
  • libzypp-debuginfo >= 16.20.0-2.39.3
  • libzypp-debugsource >= 16.20.0-2.39.3
  • zypper >= 1.13.51-21.26.3
  • zypper-debuginfo >= 1.13.51-21.26.3
  • zypper-debugsource >= 1.13.51-21.26.3
SUSE Enterprise Storage 5
  • libsolv >= 0.6.36-2.16.1
  • libsolv-debugsource >= 0.6.36-2.16.1
  • libsolv-tools >= 0.6.36-2.16.1
  • libsolv-tools-debuginfo >= 0.6.36-2.16.1
  • libzypp >= 16.20.0-2.39.3
  • libzypp-debuginfo >= 16.20.0-2.39.3
  • libzypp-debugsource >= 16.20.0-2.39.3
  • perl-solv >= 0.6.36-2.16.1
  • perl-solv-debuginfo >= 0.6.36-2.16.1
  • python-solv >= 0.6.36-2.16.1
  • python-solv-debuginfo >= 0.6.36-2.16.1
  • zypper >= 1.13.51-21.26.3
  • zypper-debuginfo >= 1.13.51-21.26.3
  • zypper-debugsource >= 1.13.51-21.26.3
  • zypper-log >= 1.13.51-21.26.3
SUSE Linux Enterprise Desktop 12 SP4
  • libsolv >= 0.6.36-2.16.1
  • libsolv-debugsource >= 0.6.36-2.16.1
  • libsolv-tools >= 0.6.36-2.16.1
  • libsolv-tools-debuginfo >= 0.6.36-2.16.1
  • libzypp >= 16.20.0-2.39.3
  • libzypp-debuginfo >= 16.20.0-2.39.3
  • libzypp-debugsource >= 16.20.0-2.39.3
  • python-solv >= 0.6.36-2.16.1
  • python-solv-debuginfo >= 0.6.36-2.16.1
  • zypper >= 1.13.51-21.26.3
  • zypper-debuginfo >= 1.13.51-21.26.3
  • zypper-debugsource >= 1.13.51-21.26.3
  • zypper-log >= 1.13.51-21.26.3
SUSE Linux Enterprise Installer Updates 15
  • libsolv >= 0.7.5-3.12.2
  • libsolv-tools >= 0.7.5-3.12.2
  • libyui-ncurses-pkg >= 2.48.5.2-3.5.2
  • libyui-ncurses-pkg8 >= 2.48.5.2-3.5.2
  • libyui-qt-pkg >= 2.45.15.2-3.5.3
  • libyui-qt-pkg8 >= 2.45.15.2-3.5.3
  • libzypp >= 17.12.0-3.23.6
  • yast2-pkg-bindings >= 4.0.13-3.7.2
  • zypper >= 1.14.28-3.18.6
SUSE Linux Enterprise Module for Basesystem 15
  • libsolv >= 0.7.5-3.12.2
  • libsolv-debuginfo >= 0.7.5-3.12.2
  • libsolv-debugsource >= 0.7.5-3.12.2
  • libsolv-devel >= 0.7.5-3.12.2
  • libsolv-devel-debuginfo >= 0.7.5-3.12.2
  • libsolv-tools >= 0.7.5-3.12.2
  • libsolv-tools-debuginfo >= 0.7.5-3.12.2
  • libyui-ncurses-pkg >= 2.48.5.2-3.5.2
  • libyui-ncurses-pkg-debugsource >= 2.48.5.2-3.5.2
  • libyui-ncurses-pkg-devel >= 2.48.5.2-3.5.2
  • libyui-ncurses-pkg-doc >= 2.48.5.2-3.5.3
  • libyui-ncurses-pkg8 >= 2.48.5.2-3.5.2
  • libyui-ncurses-pkg8-debuginfo >= 2.48.5.2-3.5.2
  • libyui-qt-pkg >= 2.45.15.2-3.5.3
  • libyui-qt-pkg-debugsource >= 2.45.15.2-3.5.3
  • libyui-qt-pkg-doc >= 2.45.15.2-3.5.3
  • libyui-qt-pkg8 >= 2.45.15.2-3.5.3
  • libyui-qt-pkg8-debuginfo >= 2.45.15.2-3.5.3
  • libzypp >= 17.12.0-3.23.6
  • libzypp-debuginfo >= 17.12.0-3.23.6
  • libzypp-debugsource >= 17.12.0-3.23.6
  • libzypp-devel >= 17.12.0-3.23.6
  • python-solv >= 0.7.5-3.12.2
  • python-solv-debuginfo >= 0.7.5-3.12.2
  • yast2-pkg-bindings >= 4.0.13-3.7.2
  • yast2-pkg-bindings-debuginfo >= 4.0.13-3.7.2
  • yast2-pkg-bindings-debugsource >= 4.0.13-3.7.2
  • zypper >= 1.14.28-3.18.6
  • zypper-debuginfo >= 1.14.28-3.18.6
  • zypper-debugsource >= 1.14.28-3.18.6
  • zypper-log >= 1.14.28-3.18.6
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libsolv >= 0.7.5-3.7.6
  • libsolv-debuginfo >= 0.7.5-3.7.6
  • libsolv-debugsource >= 0.7.5-3.7.6
  • libsolv-devel >= 0.7.5-3.7.6
  • libsolv-devel-debuginfo >= 0.7.5-3.7.6
  • libsolv-tools >= 0.7.5-3.7.6
  • libsolv-tools-debuginfo >= 0.7.5-3.7.6
  • libzypp >= 17.12.0-3.3.13
  • libzypp-debuginfo >= 17.12.0-3.3.13
  • libzypp-debugsource >= 17.12.0-3.3.13
  • libzypp-devel >= 17.12.0-3.3.13
  • python3-solv >= 0.7.5-3.7.6
  • python3-solv-debuginfo >= 0.7.5-3.7.6
  • zypper >= 1.14.28-3.3.13
  • zypper-debuginfo >= 1.14.28-3.3.13
  • zypper-debugsource >= 1.14.28-3.3.13
  • zypper-log >= 1.14.28-3.3.13
  • zypper-needs-restarting >= 1.14.28-3.3.13
SUSE Linux Enterprise Module for Desktop Applications 15
  • PackageKit >= 1.1.10-4.10.4
  • PackageKit-backend-zypp >= 1.1.10-4.10.4
  • PackageKit-backend-zypp-debuginfo >= 1.1.10-4.10.4
  • PackageKit-debuginfo >= 1.1.10-4.10.4
  • PackageKit-debugsource >= 1.1.10-4.10.4
  • PackageKit-devel >= 1.1.10-4.10.4
  • PackageKit-devel-debuginfo >= 1.1.10-4.10.4
  • PackageKit-lang >= 1.1.10-4.10.4
  • libpackagekit-glib2-18 >= 1.1.10-4.10.4
  • libpackagekit-glib2-18-debuginfo >= 1.1.10-4.10.4
  • libpackagekit-glib2-devel >= 1.1.10-4.10.4
  • libyui-qt-pkg >= 2.45.15.2-3.5.3
  • libyui-qt-pkg-debugsource >= 2.45.15.2-3.5.3
  • libyui-qt-pkg-devel >= 2.45.15.2-3.5.3
  • typelib-1_0-PackageKitGlib-1_0 >= 1.1.10-4.10.4
SUSE Linux Enterprise Module for Development Tools 15
  • libsolv >= 0.7.5-3.12.2
  • libsolv-debuginfo >= 0.7.5-3.12.2
  • libsolv-debugsource >= 0.7.5-3.12.2
  • perl-solv >= 0.7.5-3.12.2
  • perl-solv-debuginfo >= 0.7.5-3.12.2
  • python3-solv >= 0.7.5-3.12.2
  • python3-solv-debuginfo >= 0.7.5-3.12.2
  • ruby-solv >= 0.7.5-3.12.2
  • ruby-solv-debuginfo >= 0.7.5-3.12.2
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • libsolv >= 0.7.5-3.7.6
  • libsolv-debuginfo >= 0.7.5-3.7.6
  • libsolv-debugsource >= 0.7.5-3.7.6
  • perl-solv >= 0.7.5-3.7.6
  • perl-solv-debuginfo >= 0.7.5-3.7.6
  • ruby-solv >= 0.7.5-3.7.6
  • ruby-solv-debuginfo >= 0.7.5-3.7.6
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • PackageKit >= 1.1.10-4.10.4
  • PackageKit-branding-upstream >= 1.1.10-4.10.4
  • libsolv >= 0.7.5-3.12.2
  • libsolv-debuginfo >= 0.7.5-3.12.2
  • libsolv-debugsource >= 0.7.5-3.12.2
  • libsolv-demo >= 0.7.5-3.12.2
  • libsolv-demo-debuginfo >= 0.7.5-3.12.2
  • libzypp >= 17.12.0-3.23.6
  • libzypp-debuginfo >= 17.12.0-3.23.6
  • libzypp-debugsource >= 17.12.0-3.23.6
  • libzypp-devel-doc >= 17.12.0-3.23.6
  • yast2-pkg-bindings-devel-doc >= 4.0.13-3.7.2
  • zypper >= 1.14.28-3.18.6
  • zypper-aptitude >= 1.14.28-3.18.6
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • libsolv >= 0.7.5-3.7.6
  • libsolv-debuginfo >= 0.7.5-3.7.6
  • libsolv-debugsource >= 0.7.5-3.7.6
  • libsolv-demo >= 0.7.5-3.7.6
  • libsolv-demo-debuginfo >= 0.7.5-3.7.6
  • libyui-ncurses-pkg >= 2.48.5.2-3.5.2
  • libyui-ncurses-pkg-debugsource >= 2.48.5.2-3.5.2
  • libyui-ncurses-pkg8 >= 2.48.5.2-3.5.2
  • libyui-ncurses-pkg8-debuginfo >= 2.48.5.2-3.5.2
  • libyui-qt-pkg >= 2.45.15.2-3.5.3
  • libyui-qt-pkg-debugsource >= 2.45.15.2-3.5.3
  • libyui-qt-pkg8 >= 2.45.15.2-3.5.3
  • libyui-qt-pkg8-debuginfo >= 2.45.15.2-3.5.3
  • libzypp >= 17.12.0-3.3.13
  • libzypp-debuginfo >= 17.12.0-3.3.13
  • libzypp-debugsource >= 17.12.0-3.3.13
  • libzypp-devel-doc >= 17.12.0-3.3.13
  • python-solv >= 0.7.5-3.7.6
  • python-solv-debuginfo >= 0.7.5-3.7.6
  • zypper >= 1.14.28-3.3.13
  • zypper-aptitude >= 1.14.28-3.3.13
SUSE Linux Enterprise Server 12 SP3-LTSS
  • libsolv >= 0.6.36-2.16.1
  • libsolv-debugsource >= 0.6.36-2.16.1
  • libsolv-tools >= 0.6.36-2.16.1
  • libsolv-tools-debuginfo >= 0.6.36-2.16.1
  • libzypp >= 16.20.0-2.39.3
  • libzypp-debuginfo >= 16.20.0-2.39.3
  • libzypp-debugsource >= 16.20.0-2.39.3
  • perl-solv >= 0.6.36-2.16.1
  • perl-solv-debuginfo >= 0.6.36-2.16.1
  • python-solv >= 0.6.36-2.16.1
  • python-solv-debuginfo >= 0.6.36-2.16.1
  • zypper >= 1.13.51-21.26.3
  • zypper-debuginfo >= 1.13.51-21.26.3
  • zypper-debugsource >= 1.13.51-21.26.3
  • zypper-log >= 1.13.51-21.26.3
SUSE Linux Enterprise Server 12 SP4
  • libsolv >= 0.6.36-2.16.1
  • libsolv-debugsource >= 0.6.36-2.16.1
  • libsolv-tools >= 0.6.36-2.16.1
  • libsolv-tools-debuginfo >= 0.6.36-2.16.1
  • libzypp >= 16.20.0-2.39.3
  • libzypp-debuginfo >= 16.20.0-2.39.3
  • libzypp-debugsource >= 16.20.0-2.39.3
  • perl-solv >= 0.6.36-2.16.1
  • perl-solv-debuginfo >= 0.6.36-2.16.1
  • python-solv >= 0.6.36-2.16.1
  • python-solv-debuginfo >= 0.6.36-2.16.1
  • zypper >= 1.13.51-21.26.3
  • zypper-debuginfo >= 1.13.51-21.26.3
  • zypper-debugsource >= 1.13.51-21.26.3
  • zypper-log >= 1.13.51-21.26.3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libsolv >= 0.6.36-2.16.1
  • libsolv-debugsource >= 0.6.36-2.16.1
  • libsolv-tools >= 0.6.36-2.16.1
  • libsolv-tools-debuginfo >= 0.6.36-2.16.1
  • libzypp >= 16.20.0-2.39.3
  • libzypp-debuginfo >= 16.20.0-2.39.3
  • libzypp-debugsource >= 16.20.0-2.39.3
  • perl-solv >= 0.6.36-2.16.1
  • perl-solv-debuginfo >= 0.6.36-2.16.1
  • python-solv >= 0.6.36-2.16.1
  • python-solv-debuginfo >= 0.6.36-2.16.1
  • zypper >= 1.13.51-21.26.3
  • zypper-debuginfo >= 1.13.51-21.26.3
  • zypper-debugsource >= 1.13.51-21.26.3
  • zypper-log >= 1.13.51-21.26.3
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • libsolv >= 0.6.36-2.16.1
  • libsolv-debugsource >= 0.6.36-2.16.1
  • libsolv-tools >= 0.6.36-2.16.1
  • libsolv-tools-debuginfo >= 0.6.36-2.16.1
  • libzypp >= 16.20.0-2.39.3
  • libzypp-debuginfo >= 16.20.0-2.39.3
  • libzypp-debugsource >= 16.20.0-2.39.3
  • perl-solv >= 0.6.36-2.16.1
  • perl-solv-debuginfo >= 0.6.36-2.16.1
  • python-solv >= 0.6.36-2.16.1
  • python-solv-debuginfo >= 0.6.36-2.16.1
  • zypper >= 1.13.51-21.26.3
  • zypper-debuginfo >= 1.13.51-21.26.3
  • zypper-debugsource >= 1.13.51-21.26.3
  • zypper-log >= 1.13.51-21.26.3
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libsolv >= 0.6.36-2.16.1
  • libsolv-debugsource >= 0.6.36-2.16.1
  • libsolv-tools >= 0.6.36-2.16.1
  • libsolv-tools-debuginfo >= 0.6.36-2.16.1
  • libzypp >= 16.20.0-2.39.3
  • libzypp-debuginfo >= 16.20.0-2.39.3
  • libzypp-debugsource >= 16.20.0-2.39.3
  • perl-solv >= 0.6.36-2.16.1
  • perl-solv-debuginfo >= 0.6.36-2.16.1
  • python-solv >= 0.6.36-2.16.1
  • python-solv-debuginfo >= 0.6.36-2.16.1
  • zypper >= 1.13.51-21.26.3
  • zypper-debuginfo >= 1.13.51-21.26.3
  • zypper-debugsource >= 1.13.51-21.26.3
  • zypper-log >= 1.13.51-21.26.3
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libsolv >= 0.6.36-2.16.1
  • libsolv-debugsource >= 0.6.36-2.16.1
  • libsolv-devel >= 0.6.36-2.16.1
  • libsolv-devel-debuginfo >= 0.6.36-2.16.1
  • libzypp >= 16.20.0-2.39.3
  • libzypp-debuginfo >= 16.20.0-2.39.3
  • libzypp-debugsource >= 16.20.0-2.39.3
  • libzypp-devel >= 16.20.0-2.39.3
  • libzypp-devel-doc >= 16.20.0-2.39.3
  • perl-solv >= 0.6.36-2.16.1
  • perl-solv-debuginfo >= 0.6.36-2.16.1
SUSE Linux Enterprise Workstation Extension 15
  • PackageKit >= 1.1.10-4.10.4
  • PackageKit-debuginfo >= 1.1.10-4.10.4
  • PackageKit-debugsource >= 1.1.10-4.10.4
  • PackageKit-gstreamer-plugin >= 1.1.10-4.10.4
  • PackageKit-gstreamer-plugin-debuginfo >= 1.1.10-4.10.4
  • PackageKit-gtk3-module >= 1.1.10-4.10.4
  • PackageKit-gtk3-module-debuginfo >= 1.1.10-4.10.4
SUSE OpenStack Cloud 8
  • libsolv >= 0.6.36-2.16.1
  • libsolv-debugsource >= 0.6.36-2.16.1
  • libsolv-tools >= 0.6.36-2.16.1
  • libsolv-tools-debuginfo >= 0.6.36-2.16.1
  • libzypp >= 16.20.0-2.39.3
  • libzypp-debuginfo >= 16.20.0-2.39.3
  • libzypp-debugsource >= 16.20.0-2.39.3
  • perl-solv >= 0.6.36-2.16.1
  • perl-solv-debuginfo >= 0.6.36-2.16.1
  • python-solv >= 0.6.36-2.16.1
  • python-solv-debuginfo >= 0.6.36-2.16.1
  • zypper >= 1.13.51-21.26.3
  • zypper-debuginfo >= 1.13.51-21.26.3
  • zypper-debugsource >= 1.13.51-21.26.3
  • zypper-log >= 1.13.51-21.26.3


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 libsolv Not affected
CaaS Platform 3.0 libsolv In progress
OpenStack Cloud Magnum Orchestration 7.0 libsolv Not affected
SUSE Linux Enterprise Desktop 12 SP3 libsolv Not affected
SUSE Linux Enterprise Desktop 12 SP4 libsolv In progress
SUSE Linux Enterprise High Performance Computing 12 libsolv In progress
SUSE Linux Enterprise Module for Basesystem 15 GA libsolv In progress
SUSE Linux Enterprise Module for Basesystem 15 SP1 libsolv In progress
SUSE Linux Enterprise Module for Development Tools 15 GA libsolv In progress
SUSE Linux Enterprise Module for Development Tools 15 SP1 libsolv In progress
SUSE Linux Enterprise SDK 12 SP3 libsolv Not affected
SUSE Linux Enterprise SDK 12 SP4 libsolv In progress
SUSE Linux Enterprise Server 12 GA LTSS libsolv Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS libsolv In progress
SUSE Linux Enterprise Server 12 SP3 libsolv Not affected
SUSE Linux Enterprise Server 12 SP4 libsolv In progress
SUSE Linux Enterprise Server for SAP Applications 12 GA libsolv Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libsolv In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libsolv In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libsolv In progress