Upstream information

CVE-2018-16382 at MITRE

Description

Netwide Assembler (NASM) 2.14rc15 has a buffer over-read in x86/regflags.c.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.5
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Attack Vector Local
Attack Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1106878 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 6
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Module for Development Tools 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • nasm >= 2.14.02-3.4.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP1-2020-1843
SUSE Enterprise Storage 7
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Development Tools 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • nasm >= 2.14.02-3.4.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP2-2020-1843
openSUSE Leap 15.1
  • nasm >= 2.14.02-lp151.3.3.1
Patchnames:
openSUSE-2020-952
openSUSE Leap 15.2
  • nasm >= 2.14.02-lp152.4.3.1
Patchnames:
openSUSE-2020-954


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 nasm Affected
SUSE Enterprise Storage 6 nasm Released
SUSE Enterprise Storage 7 nasm Released
SUSE Enterprise Storage 7.1 nasm Affected
SUSE Linux Enterprise Desktop 11 SP4 nasm Not affected
SUSE Linux Enterprise Desktop 12 nasm Not affected
SUSE Linux Enterprise Desktop 12 SP1 nasm Not affected
SUSE Linux Enterprise Desktop 12 SP2 nasm Not affected
SUSE Linux Enterprise Desktop 12 SP3 nasm Not affected
SUSE Linux Enterprise Desktop 12 SP4 nasm Not affected
SUSE Linux Enterprise Desktop 15 nasm Not affected
SUSE Linux Enterprise Desktop 15 SP1 nasm Released
SUSE Linux Enterprise Desktop 15 SP2 nasm Released
SUSE Linux Enterprise Desktop 15 SP3 nasm Affected
SUSE Linux Enterprise Desktop 15 SP4 nasm Affected
SUSE Linux Enterprise High Performance Computing 15 nasm Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 nasm Released
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS nasm Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS nasm Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 nasm Released
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS nasm Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS nasm Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 nasm Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 nasm Affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS nasm Affected
SUSE Linux Enterprise High Performance Computing 15-LTSS nasm Affected
SUSE Linux Enterprise Module for Development Tools 15 nasm Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP1 nasm Released
SUSE Linux Enterprise Module for Development Tools 15 SP2 nasm Released
SUSE Linux Enterprise Module for Development Tools 15 SP3 nasm Affected
SUSE Linux Enterprise Module for Development Tools 15 SP4 nasm Affected
SUSE Linux Enterprise Real Time 15 SP2 nasm Affected
SUSE Linux Enterprise Real Time 15 SP3 nasm Affected
SUSE Linux Enterprise Server 11 SP4 nasm Not affected
SUSE Linux Enterprise Server 12 nasm Not affected
SUSE Linux Enterprise Server 12 SP1 nasm Not affected
SUSE Linux Enterprise Server 12 SP2 nasm Not affected
SUSE Linux Enterprise Server 12 SP3 nasm Not affected
SUSE Linux Enterprise Server 12 SP4 nasm Not affected
SUSE Linux Enterprise Server 12 SP5 nasm Not affected
SUSE Linux Enterprise Server 15 nasm Not affected
SUSE Linux Enterprise Server 15 SP1 nasm Released
SUSE Linux Enterprise Server 15 SP1-BCL nasm Affected
SUSE Linux Enterprise Server 15 SP1-LTSS nasm Affected
SUSE Linux Enterprise Server 15 SP2 nasm Released
SUSE Linux Enterprise Server 15 SP2-BCL nasm Affected
SUSE Linux Enterprise Server 15 SP2-LTSS nasm Affected
SUSE Linux Enterprise Server 15 SP3 nasm Affected
SUSE Linux Enterprise Server 15 SP4 nasm Affected
SUSE Linux Enterprise Server 15-LTSS nasm Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 nasm Not affected
SUSE Linux Enterprise Server for SAP Applications 12 nasm Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 nasm Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 nasm Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 nasm Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 nasm Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 nasm Not affected
SUSE Linux Enterprise Server for SAP Applications 15 nasm Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 nasm Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 nasm Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 nasm Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 nasm Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 nasm Not affected
SUSE Linux Enterprise Software Development Kit 12 nasm Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 nasm Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 nasm Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 nasm Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 nasm Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 nasm Not affected
SUSE Manager Proxy 4.0 nasm Released
SUSE Manager Proxy 4.1 nasm Released
SUSE Manager Proxy 4.2 nasm Affected
SUSE Manager Proxy 4.3 nasm Affected
SUSE Manager Retail Branch Server 4.0 nasm Released
SUSE Manager Retail Branch Server 4.1 nasm Released
SUSE Manager Retail Branch Server 4.2 nasm Affected
SUSE Manager Retail Branch Server 4.3 nasm Affected
SUSE Manager Server 4.0 nasm Released
SUSE Manager Server 4.1 nasm Released
SUSE Manager Server 4.2 nasm Affected
SUSE Manager Server 4.3 nasm Affected


SUSE Timeline for this CVE

CVE page created: Mon Sep 3 09:55:05 2018
CVE page last modified: Wed Nov 30 22:58:32 2022