Upstream information

CVE-2017-7960 at MITRE

Description

The cr_input_new_from_uri function in cr-input.c in libcroco 0.6.11 and 0.6.12 allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted CSS file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 5.8
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:P/I:N/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact None Partial
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 4
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Attack Vector Local Local
Attack Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High Low
CVSSv3 Version 3 3.1
SUSE Bugzilla entry: 1034481 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES12-SP4-Azure-BYOS
Image SLES12-SP4-EC2-HVM-BYOS
Image SLES12-SP4-GCE-BYOS
Image SLES12-SP4-OCI-BYOS
Image SLES12-SP4-SAP-Azure
Image SLES12-SP4-SAP-Azure-BYOS
Image SLES12-SP4-SAP-Azure-LI-BYOS-Production
Image SLES12-SP4-SAP-Azure-VLI-BYOS-Production
Image SLES12-SP4-SAP-EC2-HVM
Image SLES12-SP4-SAP-EC2-HVM-BYOS
Image SLES12-SP4-SAP-GCE
Image SLES12-SP4-SAP-GCE-BYOS
Image SLES12-SP4-SAP-OCI-BYOS
Image SLES12-SP5-Azure-BYOS
Image SLES12-SP5-Azure-Basic-On-Demand
Image SLES12-SP5-Azure-HPC-BYOS
Image SLES12-SP5-Azure-HPC-On-Demand
Image SLES12-SP5-Azure-SAP-BYOS
Image SLES12-SP5-Azure-SAP-On-Demand
Image SLES12-SP5-Azure-Standard-On-Demand
Image SLES12-SP5-EC2-BYOS
Image SLES12-SP5-EC2-ECS-On-Demand
Image SLES12-SP5-EC2-On-Demand
Image SLES12-SP5-EC2-SAP-BYOS
Image SLES12-SP5-EC2-SAP-On-Demand
Image SLES12-SP5-GCE-BYOS
Image SLES12-SP5-GCE-On-Demand
Image SLES12-SP5-GCE-SAP-BYOS
Image SLES12-SP5-GCE-SAP-On-Demand
Image SLES12-SP5-OCI-BYOS-BYOS
Image SLES12-SP5-OCI-BYOS-SAP-BYOS
Image SLES12-SP5-SAP-Azure-LI-BYOS-Production
Image SLES12-SP5-SAP-Azure-VLI-BYOS-Production
  • libcroco-0_6-3 >= 0.6.11-12.3.1
SUSE CaaS Platform 3.0
  • libcroco-0_6-3 >= 0.6.11-12.3.1
Patchnames:
SUSE-CAASP-3.0-2019-1468
SUSE Enterprise Storage 6
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Module for Basesystem 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • libcroco >= 0.6.12-2.38
  • libcroco-0_6-3 >= 0.6.12-2.38
  • libcroco-0_6-3-32bit >= 0.6.12-2.38
  • libcroco-devel >= 0.6.12-2.38
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libcroco-0.6.12-2.38
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Basesystem 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • libcroco >= 0.6.13-1.26
  • libcroco-0_6-3 >= 0.6.13-1.26
  • libcroco-devel >= 0.6.13-1.26
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA libcroco-0.6.13-1.26
SUSE Enterprise Storage 7
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • libcroco >= 0.6.13-1.26
  • libcroco-0_6-3 >= 0.6.13-1.26
  • libcroco-0_6-3-32bit >= 0.6.13-1.26
  • libcroco-devel >= 0.6.13-1.26
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA libcroco-0.6.13-1.26
SUSE Linux Enterprise Desktop 12 SP3
  • libcroco >= 0.6.11-12.3.1
  • libcroco-0_6-3 >= 0.6.11-12.3.1
  • libcroco-0_6-3-32bit >= 0.6.11-12.3.1
  • libcroco-devel >= 0.6.11-12.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2019-1468
SUSE-SLE-SDK-12-SP3-2019-1468
SUSE Linux Enterprise Desktop 12 SP4
  • libcroco >= 0.6.11-12.3.1
  • libcroco-0_6-3 >= 0.6.11-12.3.1
  • libcroco-0_6-3-32bit >= 0.6.11-12.3.1
  • libcroco-devel >= 0.6.11-12.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-1468
SUSE-SLE-SDK-12-SP4-2019-1468
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libcroco >= 0.6.13-150400.9.5
  • libcroco-0_6-3 >= 0.6.13-150400.9.5
  • libcroco-devel >= 0.6.13-150400.9.5
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA libcroco-0.6.13-150400.9.5
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • libcroco >= 0.6.12-2.38
  • libcroco-0_6-3 >= 0.6.12-2.38
  • libcroco-0_6-3-32bit >= 0.6.12-2.38
  • libcroco-devel >= 0.6.12-2.38
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libcroco-0.6.12-2.38
SUSE Linux Enterprise High Performance Computing 12 SP5
  • libcroco-0_6-3 >= 0.6.11-12.3.1
  • libcroco-0_6-3-32bit >= 0.6.11-12.3.1
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA libcroco-0_6-3-0.6.11-12.3.1
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libcroco >= 0.6.11-12.3.1
  • libcroco-0_6-3 >= 0.6.11-12.3.1
  • libcroco-0_6-3-32bit >= 0.6.11-12.3.1
  • libcroco-devel >= 0.6.11-12.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2019-1468
SUSE-SLE-SERVER-12-SP3-2019-1468
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libcroco >= 0.6.11-12.3.1
  • libcroco-0_6-3 >= 0.6.11-12.3.1
  • libcroco-0_6-3-32bit >= 0.6.11-12.3.1
  • libcroco-devel >= 0.6.11-12.3.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-1468
SUSE-SLE-SERVER-12-SP4-2019-1468
SUSE Linux Enterprise Server 12 SP5
  • libcroco >= 0.6.11-12.3.1
  • libcroco-0_6-3 >= 0.6.11-12.3.1
  • libcroco-0_6-3-32bit >= 0.6.11-12.3.1
  • libcroco-devel >= 0.6.11-12.3.1
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA libcroco-0_6-3-0.6.11-12.3.1
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libcroco-0.6.11-12.3.1
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libcroco >= 0.6.11-12.3.1
  • libcroco-devel >= 0.6.11-12.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libcroco-0.6.11-12.3.1
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libcroco >= 0.6.11-12.3.1
  • libcroco-devel >= 0.6.11-12.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2019-1468
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libcroco >= 0.6.11-12.3.1
  • libcroco-devel >= 0.6.11-12.3.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-1468
openSUSE Leap 15.0
  • libcroco-0_6-3 >= 0.6.12-lp150.2.13
  • libcroco-0_6-3-32bit >= 0.6.12-lp150.2.13
Patchnames:
openSUSE Leap 15.0 GA libcroco-0_6-3-0.6.12-lp150.2.13
openSUSE Leap 15.2
  • libcroco-0_6-3 >= 0.6.13-lp152.1.21
  • libcroco-0_6-3-32bit >= 0.6.13-lp152.1.114
Patchnames:
openSUSE Leap 15.2 GA libcroco-0_6-3-0.6.13-lp152.1.1
openSUSE Leap 15.3
  • libcroco-0_6-3 >= 0.6.13-1.26
Patchnames:
openSUSE Leap 15.3 GA libcroco-0_6-3-0.6.13-1.26
openSUSE Tumbleweed
  • libcroco >= 0.6.13-3.2
  • libcroco-0_6-3 >= 0.6.13-3.2
  • libcroco-0_6-3-32bit >= 0.6.13-3.2
  • libcroco-devel >= 0.6.13-3.2
Patchnames:
openSUSE Tumbleweed GA libcroco-0.6.13-3.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 libcroco Released
Magnum Orchestration libcroco Released
SUSE CaaS Platform 3.0 libcroco Released
SUSE Container as a Service Platform 2.0 libcroco Released
SUSE Enterprise Storage 5 libcroco Released
SUSE Enterprise Storage 7 libcroco Already fixed
SUSE Linux Enterprise Desktop 11 SP4 libcroco Affected
SUSE Linux Enterprise Desktop 12 SP1 libcroco Ignore
SUSE Linux Enterprise Desktop 12 SP2 libcroco Affected
SUSE Linux Enterprise Desktop 12 SP3 libcroco Released
SUSE Linux Enterprise Desktop 12 SP4 libcroco Released
SUSE Linux Enterprise Desktop 15 SP2 libcroco Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP4 libcroco Released
SUSE Linux Enterprise High Performance Computing 12 SP5 libcroco Released
SUSE Linux Enterprise High Performance Computing 15 SP2 libcroco Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP2 libcroco Already fixed
SUSE Linux Enterprise Point of Service 11 SP3 libcroco In progress
SUSE Linux Enterprise Point of Service Image Server 12 SP2 libcroco Released
SUSE Linux Enterprise Server 11 SP3 LTSS libcroco Affected
SUSE Linux Enterprise Server 11 SP4 libcroco Affected
SUSE Linux Enterprise Server 11 SP4 LTSS libcroco In progress
SUSE Linux Enterprise Server 11 SP4-LTSS libcroco Affected
SUSE Linux Enterprise Server 12 SP1 libcroco Ignore
SUSE Linux Enterprise Server 12 SP2 libcroco Affected
SUSE Linux Enterprise Server 12 SP2-BCL libcroco Released
SUSE Linux Enterprise Server 12 SP2-ESPOS libcroco Released
SUSE Linux Enterprise Server 12 SP2-LTSS libcroco Released
SUSE Linux Enterprise Server 12 SP3 libcroco Released
SUSE Linux Enterprise Server 12 SP3-BCL libcroco Released
SUSE Linux Enterprise Server 12 SP3-ESPOS libcroco Released
SUSE Linux Enterprise Server 12 SP3-LTSS libcroco Released
SUSE Linux Enterprise Server 12 SP4 libcroco Released
SUSE Linux Enterprise Server 12 SP4-ESPOS libcroco Released
SUSE Linux Enterprise Server 12 SP4-LTSS libcroco Released
SUSE Linux Enterprise Server 12 SP5 libcroco Released
SUSE Linux Enterprise Server 12-LTSS libcroco Ignore
SUSE Linux Enterprise Server 15 SP2 libcroco Already fixed
SUSE Linux Enterprise Server for SAP Applications 11 SP4 libcroco Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 libcroco Ignore
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libcroco Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libcroco Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libcroco Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libcroco Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libcroco Already fixed
SUSE Linux Enterprise Software Development Kit 11 SP4 libcroco Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 libcroco Ignore
SUSE Linux Enterprise Software Development Kit 12 SP2 libcroco Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 libcroco Released
SUSE Linux Enterprise Software Development Kit 12 SP4 libcroco Released
SUSE Linux Enterprise Software Development Kit 12 SP5 libcroco Released
SUSE Manager Proxy 4.1 libcroco Already fixed
SUSE Manager Retail Branch Server 4.1 libcroco Already fixed
SUSE Manager Server 4.1 libcroco Already fixed
SUSE OpenStack Cloud 7 libcroco Released
SUSE OpenStack Cloud 8 libcroco Released
SUSE OpenStack Cloud 9 libcroco Released
SUSE OpenStack Cloud Crowbar 8 libcroco Released
SUSE OpenStack Cloud Crowbar 9 libcroco Released


SUSE Timeline for this CVE

CVE page created: Mon Apr 17 21:30:30 2017
CVE page last modified: Fri Nov 25 17:44:27 2022