Upstream information

CVE-2017-5847 at MITRE

Description

The gst_asf_demux_process_ext_content_desc function in gst/asfdemux/gstasfdemux.c in gst-plugins-ugly in GStreamer allows remote attackers to cause a denial of service (out-of-bounds heap read) via vectors involving extended content descriptors.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1023259 [RESOLVED / MOVED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Basesystem 15 SP1
SUSE Linux Enterprise Module for Desktop Applications 15
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
SUSE Linux Enterprise Workstation Extension 15
SUSE Linux Enterprise Workstation Extension 15 SP1
openSUSE Leap 15.0
  • gstreamer >= 1.12.5-lp150.1.1
  • gstreamer-lang >= 1.12.5-lp150.1.1
  • gstreamer-plugins-bad >= 1.12.5-lp150.1.3
  • gstreamer-plugins-bad-lang >= 1.12.5-lp150.1.3
  • gstreamer-plugins-ugly >= 1.12.5-lp150.1.1
  • gstreamer-plugins-ugly-lang >= 1.12.5-lp150.1.1
  • gstreamer-utils >= 1.12.5-lp150.1.1
  • libgstadaptivedemux-1_0-0 >= 1.12.5-lp150.1.3
  • libgstbadaudio-1_0-0 >= 1.12.5-lp150.1.3
  • libgstbadbase-1_0-0 >= 1.12.5-lp150.1.3
  • libgstbadvideo-1_0-0 >= 1.12.5-lp150.1.3
  • libgstbasecamerabinsrc-1_0-0 >= 1.12.5-lp150.1.3
  • libgstcodecparsers-1_0-0 >= 1.12.5-lp150.1.3
  • libgstgl-1_0-0 >= 1.12.5-lp150.1.3
  • libgstmpegts-1_0-0 >= 1.12.5-lp150.1.3
  • libgstphotography-1_0-0 >= 1.12.5-lp150.1.3
  • libgstreamer-1_0-0 >= 1.12.5-lp150.1.1
  • libgsturidownloader-1_0-0 >= 1.12.5-lp150.1.3
  • libgstwayland-1_0-0 >= 1.12.5-lp150.1.3
  • typelib-1_0-Gst-1_0 >= 1.12.5-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA gstreamer
openSUSE Leap 15.0 GA gstreamer-plugins-bad
openSUSE Leap 15.0 GA gstreamer-plugins-ugly