Upstream information

CVE-2017-3652 at MITRE

Description

Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: DDL). Supported versions that are affected are 5.5.56 and earlier, 5.6.36 and earlier and 5.7.18 and earlier. Difficult to exploit vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of MySQL Server accessible data as well as unauthorized read access to a subset of MySQL Server accessible data. CVSS 3.0 Base Score 4.2 (Confidentiality and Integrity impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N).

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.9 3.6
Vector AV:N/AC:M/Au:S/C:P/I:P/A:N AV:N/AC:H/Au:S/C:P/I:P/A:N
Access Vector Network Network
Access Complexity Medium High
Authentication Single Single
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 4.2 4.2
Vector CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
Attack Vector Network Network
Attack Complexity High High
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact Low Low
Integrity Impact Low Low
Availability Impact None None
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1049416 [RESOLVED / FIXED], 1049422 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libmysql55client_r18-32bit >= 5.5.57-0.39.3.1
  • libmysql55client_r18-x86 >= 5.5.57-0.39.3.1
Patchnames:
sdksp4-mysql-13252
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libmysql55client18 >= 5.5.57-0.39.3.1
  • libmysql55client18-32bit >= 5.5.57-0.39.3.1
  • libmysql55client18-x86 >= 5.5.57-0.39.3.1
  • libmysql55client_r18 >= 5.5.57-0.39.3.1
  • libmysql55client_r18-32bit >= 5.5.57-0.39.3.1
  • libmysql55client_r18-x86 >= 5.5.57-0.39.3.1
  • mysql >= 5.5.57-0.39.3.1
  • mysql-client >= 5.5.57-0.39.3.1
  • mysql-tools >= 5.5.57-0.39.3.1
Patchnames:
sdksp4-mysql-13252
slessp4-mysql-13252


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 mariadb Affected
SUSE Enterprise Storage 7.1 mariadb Already fixed
SUSE Linux Enterprise Desktop 11 SP4 mysql Released
SUSE Linux Enterprise Desktop 12 SP1 mariadb Unsupported
SUSE Linux Enterprise Desktop 12 SP2 mariadb Unsupported
SUSE Linux Enterprise Desktop 12 SP3 mariadb Unsupported
SUSE Linux Enterprise Desktop 12 SP4 mariadb-100 Already fixed
SUSE Linux Enterprise Desktop 12 SP5 mariadb-100 Already fixed
SUSE Linux Enterprise Desktop 15 SP3 mariadb Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP5 mariadb-100 Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3 mariadb Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4 mariadb Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP3 mariadb Already fixed
SUSE Linux Enterprise Module for Server Applications 15 SP3 mariadb Already fixed
SUSE Linux Enterprise Module for Server Applications 15 SP4 mariadb Not affected
SUSE Linux Enterprise Point of Service 11 SP3 mysql Affected
SUSE Linux Enterprise Real Time 15 SP3 mariadb Already fixed
SUSE Linux Enterprise Server 11 SP3 mysql Affected
SUSE Linux Enterprise Server 11 SP3 LTSS mysql Ignore
SUSE Linux Enterprise Server 11 SP3-LTSS mysql Affected
SUSE Linux Enterprise Server 11 SP4 mysql Released
SUSE Linux Enterprise Server 11 SP4 LTSS mysql Released
SUSE Linux Enterprise Server 11 SP4-LTSS mysql Released
SUSE Linux Enterprise Server 12 SP1 mariadb Unsupported
SUSE Linux Enterprise Server 12 SP1-LTSS mariadb Unsupported
SUSE Linux Enterprise Server 12 SP2 mariadb Unsupported
SUSE Linux Enterprise Server 12 SP2-BCL mariadb Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS mariadb Unsupported
SUSE Linux Enterprise Server 12 SP2-LTSS mariadb Unsupported
SUSE Linux Enterprise Server 12 SP3 mariadb Unsupported
SUSE Linux Enterprise Server 12 SP3-BCL mariadb Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS mariadb Affected
SUSE Linux Enterprise Server 12 SP3-LTSS mariadb Affected
SUSE Linux Enterprise Server 12 SP4 mariadb-100 Already fixed
SUSE Linux Enterprise Server 12 SP4-ESPOS mariadb-100 Already fixed
SUSE Linux Enterprise Server 12 SP4-LTSS mariadb-100 Already fixed
SUSE Linux Enterprise Server 12 SP5 mariadb-100 Already fixed
SUSE Linux Enterprise Server 15 SP3 mariadb Already fixed
SUSE Linux Enterprise Server 15 SP4 mariadb Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 mariadb Unsupported
SUSE Linux Enterprise Server for SAP Applications 11 SP4 mysql Released
SUSE Linux Enterprise Server for SAP Applications 12 SP1 mariadb Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP2 mariadb Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 mariadb Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 mariadb-100 Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 mariadb-100 Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP3 mariadb Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP4 mariadb Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 mysql Released
SUSE Linux Enterprise Software Development Kit 12 SP1 mariadb Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP2 mariadb Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP3 mariadb Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP4 mariadb-100 Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP5 mariadb-100 Already fixed
SUSE Linux Enterprise Workstation Extension 12 SP1 mariadb Unsupported
SUSE Linux Enterprise Workstation Extension 12 SP2 mariadb Unsupported
SUSE Linux Enterprise Workstation Extension 12 SP3 mariadb Unsupported
SUSE Linux Enterprise Workstation Extension 12 SP4 mariadb-100 Already fixed
SUSE Linux Enterprise Workstation Extension 12 SP5 mariadb-100 Already fixed
SUSE Manager Proxy 4.2 mariadb Already fixed
SUSE Manager Proxy 4.3 mariadb Not affected
SUSE Manager Retail Branch Server 4.2 mariadb Already fixed
SUSE Manager Retail Branch Server 4.3 mariadb Not affected
SUSE Manager Server 4.2 mariadb Already fixed
SUSE Manager Server 4.3 mariadb Not affected
SUSE OpenStack Cloud 7 mariadb Affected
SUSE OpenStack Cloud 8 mariadb Affected
SUSE OpenStack Cloud 9 mariadb-100 Already fixed
SUSE OpenStack Cloud Crowbar 8 mariadb Affected
SUSE OpenStack Cloud Crowbar 9 mariadb-100 Already fixed
suse/rmt-mariadb mariadbAlready fixed
suse/rmt-mariadb:10.6 mariadbNot affected


SUSE Timeline for this CVE

CVE page created: Wed Jul 19 12:15:27 2017
CVE page last modified: Wed Dec 7 16:14:29 2022