Upstream information

CVE-2017-11109 at MITRE

Description

Vim 8.0 allows attackers to cause a denial of service (invalid free) or possibly have unspecified other impact via a crafted source (aka -S) file. NOTE: there might be a limited number of scenarios in which this has security relevance.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 7.6
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:N/AC:H/Au:N/C:C/I:C/A:C
Access Vector Network Network
Access Complexity Medium High
Authentication None None
Confidentiality Impact Partial Complete
Integrity Impact Partial Complete
Availability Impact Partial Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 8.8
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack Vector Local Network
Attack Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1047959 [RESOLVED / WONTFIX]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Server 12 SP5 vim Ignore
SUSE Linux Enterprise Server 12-LTSS vim Ignore
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Server 12 SP2-BCL vim Ignore
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 vim Ignore
Magnum Orchestration 7 vim Ignore
SUSE CaaS Platform 3.0 vim Ignore
SUSE Linux Enterprise Desktop 12 vim Ignore
SUSE Linux Enterprise Desktop 12 SP1 vim Ignore
SUSE Linux Enterprise Desktop 12 SP2 vim Ignore
SUSE Linux Enterprise Desktop 12 SP3 vim Ignore
SUSE Linux Enterprise Desktop 12 SP4 vim Ignore
SUSE Linux Enterprise Server 11 SP3 vim Ignore
SUSE Linux Enterprise Server 11 SP3 LTSS vim Ignore
SUSE Linux Enterprise Server 11 SP3-LTSS vim Ignore
SUSE Linux Enterprise Server 11 SP4 vim Ignore
SUSE Linux Enterprise Server 11 SP4-LTSS vim Ignore
SUSE Linux Enterprise Server 12 vim Ignore
SUSE Linux Enterprise Server 12 SP1 vim Ignore
SUSE Linux Enterprise Server 12 SP1-LTSS vim Ignore
SUSE Linux Enterprise Server 12 SP2 vim Ignore
SUSE Linux Enterprise Server 12 SP2-ESPOS vim Ignore
SUSE Linux Enterprise Server 12 SP2-LTSS vim Ignore
SUSE Linux Enterprise Server 12 SP3 vim Ignore
SUSE Linux Enterprise Server 12 SP3-BCL vim Ignore
SUSE Linux Enterprise Server 12 SP3-ESPOS vim Ignore
SUSE Linux Enterprise Server 12 SP3-LTSS vim Ignore
SUSE Linux Enterprise Server 12 SP4 vim Ignore
SUSE Linux Enterprise Server 12 SP4-ESPOS vim Ignore
SUSE Linux Enterprise Server 12 SP4-LTSS vim Ignore
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 vim Ignore
SUSE Linux Enterprise Server for SAP Applications 12 SP1 vim Ignore
SUSE Linux Enterprise Server for SAP Applications 12 SP2 vim Ignore
SUSE Linux Enterprise Server for SAP Applications 12 SP3 vim Ignore
SUSE Linux Enterprise Server for SAP Applications 12 SP4 vim Ignore
SUSE OpenStack Cloud 7 vim Ignore
SUSE OpenStack Cloud 8 vim Ignore
SUSE OpenStack Cloud 9 vim Ignore
SUSE OpenStack Cloud Crowbar 8 vim Ignore
SUSE OpenStack Cloud Crowbar 9 vim Ignore


SUSE Timeline for this CVE

CVE page created: Sat Jul 8 22:16:22 2017
CVE page last modified: Fri Oct 13 19:54:57 2023