Upstream information

CVE-2015-2278 at MITRE

Description

The LZH decompression implementation (CsObjectInt::BuildHufTree function in vpa108csulzh.cpp) in SAP MaxDB 7.5 and 7.6, Netweaver Application Server ABAP, Netweaver Application Server Java, Netweaver RFC SDK, GUI, RFC SDK, SAPCAR archive tool, and other products allows context-dependent attackers to cause a denial of service (out-of-bounds read) via unspecified vectors, related to look-ups of non-simple codes, aka SAP Security Note 2124806, 2121661, 2127995, and 2125316.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 935939 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for SAP Applications 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • clamsap >= 0.99.25-2.37
Patchnames:
SUSE Linux Enterprise Module for SAP Applications 15 SP1 GA clamsap-0.99.25-2.37
SUSE Linux Enterprise Module for SAP Applications 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
  • clamsap >= 0.99.25-2.37
Patchnames:
SUSE Linux Enterprise Module for SAP Applications 15 SP2 GA clamsap-0.99.25-2.37
SUSE Linux Enterprise Module for SAP Applications 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
  • clamsap >= 0.101.9-4.3.1
Patchnames:
SUSE Linux Enterprise Module for SAP Applications 15 SP3 GA clamsap-0.101.9-4.3.1
SUSE Linux Enterprise Module for SAP Applications 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
  • clamsap >= 0.101.9-4.3.1
Patchnames:
SUSE Linux Enterprise Module for SAP Applications 15 SP4 GA clamsap-0.101.9-4.3.1
SUSE Linux Enterprise Module for SAP Applications 15
SUSE Linux Enterprise Server for SAP Applications 15
  • clamsap >= 0.99.25-2.37
Patchnames:
SUSE Linux Enterprise Module for SAP Applications 15 GA clamsap-0.99.25-2.37
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • clamsap >= 0.98.9-0.7.1
Patchnames:
slesappsp4-clamsap-12462
SUSE Linux Enterprise Server for SAP Applications 12
  • clamsap >= 0.98.9-4.1
Patchnames:
SUSE-SLE-SAP-12-2016-472


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for SAP Applications 15 clamsap Already fixed
SUSE Linux Enterprise Module for SAP Applications 15 SP1 clamsap Already fixed
SUSE Linux Enterprise Module for SAP Applications 15 SP2 clamsap Already fixed
SUSE Linux Enterprise Module for SAP Applications 15 SP3 clamsap Already fixed
SUSE Linux Enterprise Module for SAP Applications 15 SP4 clamsap Already fixed
SUSE Linux Enterprise Server for SAP All-in-One 11 SP4 clamsap Released
SUSE Linux Enterprise Server for SAP Applications 11 SP4 clamsap Released
SUSE Linux Enterprise Server for SAP Applications 12 clamsap Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 clamsap Released
SUSE Linux Enterprise Server for SAP Applications 15 clamsap Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP1 clamsap Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP2 clamsap Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP3 clamsap Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP4 clamsap Already fixed


SUSE Timeline for this CVE

CVE page created: Tue Jun 2 18:15:20 2015
CVE page last modified: Tue Nov 29 13:15:56 2022