Upstream information

CVE-2009-0847 at MITRE

Description

The asn1buf_imbed function in the ASN.1 decoder in MIT Kerberos 5 (aka krb5) 1.6.3, when PK-INIT is used, allows remote attackers to cause a denial of service (application crash) via a crafted length value that triggers an erroneous malloc call, related to incorrect calculations with pointer arithmetic.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 486722 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • krb5 >= 1.12.1-19.1
  • krb5-32bit >= 1.12.1-19.1
  • krb5-client >= 1.12.1-19.1
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Desktop 12 SP3
  • krb5 >= 1.12.5-39.1
  • krb5-32bit >= 1.12.5-39.1
  • krb5-client >= 1.12.5-39.1
SUSE Linux Enterprise Desktop 12 SP4
  • krb5 >= 1.12.5-40.28.2
  • krb5-32bit >= 1.12.5-40.28.2
  • krb5-client >= 1.12.5-40.28.2
SUSE Linux Enterprise Desktop 12
  • krb5 >= 1.12.1-6.3
  • krb5-32bit >= 1.12.1-6.3
  • krb5-client >= 1.12.1-6.3
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • krb5 >= 1.12.5-40.37.7
  • krb5-32bit >= 1.12.5-40.37.7
  • krb5-client >= 1.12.5-40.37.7
  • krb5-doc >= 1.12.5-40.37.7
  • krb5-plugin-kdb-ldap >= 1.12.5-40.37.7
  • krb5-plugin-preauth-otp >= 1.12.5-40.37.7
  • krb5-plugin-preauth-pkinit >= 1.12.5-40.37.7
  • krb5-server >= 1.12.5-40.37.7
SUSE Linux Enterprise Module for Basesystem 15
  • krb5 >= 1.15.2-4.25
  • krb5-32bit >= 1.15.2-4.25
  • krb5-client >= 1.15.2-4.25
  • krb5-devel >= 1.15.2-4.25
  • krb5-plugin-preauth-otp >= 1.15.2-4.25
  • krb5-plugin-preauth-pkinit >= 1.15.2-4.25
SUSE Linux Enterprise Module for Server Applications 15
  • krb5-plugin-kdb-ldap >= 1.15.2-4.25
  • krb5-server >= 1.15.2-4.25
SUSE Linux Enterprise Server 11 SP1
  • krb5 >= 1.6.3-133.27.1
  • krb5-32bit >= 1.6.3-133.27.1
  • krb5-apps-clients >= 1.6.3-133.27.1
  • krb5-apps-servers >= 1.6.3-133.27.1
  • krb5-client >= 1.6.3-133.27.1
  • krb5-server >= 1.6.3-133.27.1
  • krb5-x86 >= 1.6.3-133.27.1
SUSE Linux Enterprise Server 11 SP2
  • krb5 >= 1.6.3-133.48.48.1
  • krb5-32bit >= 1.6.3-133.48.48.1
  • krb5-apps-clients >= 1.6.3-133.48.48.1
  • krb5-apps-servers >= 1.6.3-133.48.48.1
  • krb5-client >= 1.6.3-133.48.48.1
  • krb5-server >= 1.6.3-133.48.48.1
  • krb5-x86 >= 1.6.3-133.48.48.1
SUSE Linux Enterprise Server 11 SP3
  • krb5 >= 1.6.3-133.49.54.1
  • krb5-32bit >= 1.6.3-133.49.54.1
  • krb5-apps-clients >= 1.6.3-133.49.54.1
  • krb5-apps-servers >= 1.6.3-133.49.54.1
  • krb5-client >= 1.6.3-133.49.54.1
  • krb5-server >= 1.6.3-133.49.54.1
  • krb5-x86 >= 1.6.3-133.49.54.1
SUSE Linux Enterprise Server 11 SP4
  • krb5 >= 1.6.3-133.49.66.1
  • krb5-32bit >= 1.6.3-133.49.66.1
  • krb5-apps-clients >= 1.6.3-133.49.66.1
  • krb5-apps-servers >= 1.6.3-133.49.66.1
  • krb5-client >= 1.6.3-133.49.66.1
  • krb5-server >= 1.6.3-133.49.66.1
  • krb5-x86 >= 1.6.3-133.49.66.1
SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server for SAP Applications 11
  • krb5 >= 1.6.3-133.25.1
  • krb5-32bit >= 1.6.3-133.25.1
  • krb5-apps-clients >= 1.6.3-133.25.1
  • krb5-apps-servers >= 1.6.3-133.25.1
  • krb5-client >= 1.6.3-133.25.1
  • krb5-server >= 1.6.3-133.25.1
  • krb5-x86 >= 1.6.3-133.25.1
Patchnames:
slessp0-krb5
SUSE Linux Enterprise Server 12 SP1
  • krb5 >= 1.12.1-19.1
  • krb5-32bit >= 1.12.1-19.1
  • krb5-client >= 1.12.1-19.1
  • krb5-doc >= 1.12.1-19.1
  • krb5-plugin-kdb-ldap >= 1.12.1-19.1
  • krb5-plugin-preauth-otp >= 1.12.1-19.1
  • krb5-plugin-preauth-pkinit >= 1.12.1-19.1
  • krb5-server >= 1.12.1-19.1
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server 12 SP3
  • krb5 >= 1.12.5-39.1
  • krb5-32bit >= 1.12.5-39.1
  • krb5-client >= 1.12.5-39.1
  • krb5-doc >= 1.12.5-39.1
  • krb5-plugin-kdb-ldap >= 1.12.5-39.1
  • krb5-plugin-preauth-otp >= 1.12.5-39.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-39.1
  • krb5-server >= 1.12.5-39.1
SUSE Linux Enterprise Server 12 SP4
  • krb5 >= 1.12.5-40.28.2
  • krb5-32bit >= 1.12.5-40.28.2
  • krb5-client >= 1.12.5-40.28.2
  • krb5-doc >= 1.12.5-40.28.2
  • krb5-plugin-kdb-ldap >= 1.12.5-40.28.2
  • krb5-plugin-preauth-otp >= 1.12.5-40.28.2
  • krb5-plugin-preauth-pkinit >= 1.12.5-40.28.2
  • krb5-server >= 1.12.5-40.28.2
SUSE Linux Enterprise Server 12
  • krb5 >= 1.12.1-6.3
  • krb5-32bit >= 1.12.1-6.3
  • krb5-client >= 1.12.1-6.3
  • krb5-doc >= 1.12.1-6.3
  • krb5-plugin-kdb-ldap >= 1.12.1-6.3
  • krb5-plugin-preauth-otp >= 1.12.1-6.3
  • krb5-plugin-preauth-pkinit >= 1.12.1-6.3
  • krb5-server >= 1.12.1-6.3
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • krb5 >= 1.12.5-39.1
  • krb5-client >= 1.12.5-39.1
  • krb5-doc >= 1.12.5-39.1
  • krb5-plugin-kdb-ldap >= 1.12.5-39.1
  • krb5-plugin-preauth-otp >= 1.12.5-39.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-39.1
  • krb5-server >= 1.12.5-39.1
SUSE Linux Enterprise Software Development Kit 11 SP4
  • krb5-devel >= 1.6.3-133.49.66.1
  • krb5-devel-32bit >= 1.6.3-133.49.66.1
  • krb5-server >= 1.6.3-133.49.66.1
SUSE Linux Enterprise Software Development Kit 12 SP1
  • krb5-devel >= 1.12.1-19.1
SUSE Linux Enterprise Software Development Kit 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP3
  • krb5-devel >= 1.12.5-39.1
SUSE Linux Enterprise Software Development Kit 12 SP4
  • krb5-devel >= 1.12.5-40.28.2
SUSE Linux Enterprise Software Development Kit 12 SP5
  • krb5-devel >= 1.12.5-40.37.7
SUSE Linux Enterprise Software Development Kit 12
  • krb5-devel >= 1.12.1-6.3
openSUSE Leap 15.0
  • krb5 >= 1.15.2-lp150.4.4
  • krb5-32bit >= 1.15.2-lp150.4.4
  • krb5-server >= 1.15.2-lp150.4.4
Patchnames:
openSUSE Leap 15.0 GA krb5
openSUSE Tumbleweed
  • krb5 >= 1.15-1.1
  • krb5-32bit >= 1.15-1.1
  • krb5-client >= 1.15-1.1
  • krb5-devel >= 1.15-1.1
  • krb5-devel-32bit >= 1.15-1.1
  • krb5-doc >= 1.15-1.1
  • krb5-mini >= 1.15-1.1
  • krb5-mini-devel >= 1.15-1.1
  • krb5-plugin-kdb-ldap >= 1.15-1.1
  • krb5-plugin-preauth-otp >= 1.15-1.1
  • krb5-plugin-preauth-pkinit >= 1.15-1.1
  • krb5-server >= 1.15-1.1
Patchnames:
openSUSE Tumbleweed GA krb5