Upstream information

CVE-2019-7307 at MITRE

Description

Apport before versions 2.14.1-0ubuntu3.29+esm1, 2.20.1-0ubuntu2.19, 2.20.9-0ubuntu7.7, 2.20.10-0ubuntu27.1, 2.20.11-0ubuntu5 contained a TOCTTOU vulnerability when reading the users ~/.apport-ignore.xml file, which allows a local attacker to replace this file with a symlink to any other file on the system and so cause Apport to include the contents of this other file in the resulting crash report. The crash report could then be read by that user either by causing it to be uploaded and reported to Launchpad, or by leveraging some other vulnerability to read the resulting crash report, and so allow the user to read arbitrary files on the system.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.4
Vector AV:L/AC:M/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7 2.8
Vector CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N
Attack Vector Local Local
Attack Complexity High Low
Privileges Required Low Low
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High None
Availability Impact High None
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1140986 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products past their end of life and not receiving proactive updates anymore.
SLES for SAP Applications 11 SP3 apport Affected
SUSE Linux Enterprise Point of Service 11 SP3 apport Released
SUSE Linux Enterprise Point of Service 11 SP3 apport-crashdb-sle Affected
SUSE Linux Enterprise Server 11 SP3 apport Affected
SUSE Linux Enterprise Server 11 SP3 apport-crashdb-sle Affected
SUSE Linux Enterprise Server 11 SP3 LTSS apport Affected
SUSE Linux Enterprise Server 11 SP3-LTSS apport Affected
SUSE Linux Enterprise Server 11 SP3-LTSS apport-crashdb-sle Affected
SUSE Linux Enterprise Server 11 SP4 apport Affected
SUSE Linux Enterprise Server 11 SP4 apport-crashdb-sle Affected
SUSE Linux Enterprise Server 11 SP4 LTSS apport Released
SUSE Linux Enterprise Server 11 SP4 LTSS apport-crashdb-sle Affected
SUSE Linux Enterprise Server 11 SP4-LTSS apport Affected
SUSE Linux Enterprise Server 11 SP4-LTSS apport-crashdb-sle Affected


SUSE Timeline for this CVE

CVE page created: Tue Jul 9 04:05:37 2019
CVE page last modified: Tue Jan 17 15:32:22 2023