Upstream information

CVE-2013-5651 at MITRE

Description

The virBitmapParse function in util/virbitmap.c in libvirt before 1.1.2 allows context-dependent attackers to cause a denial of service (out-of-bounds read and crash) via a crafted bitmap, as demonstrated by a large nodeset value to numatune.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 837999 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • libvirt >= 1.0.5.6-0.7.1
  • libvirt-client >= 1.0.5.6-0.7.1
  • libvirt-client-32bit >= 1.0.5.6-0.7.1
  • libvirt-devel >= 1.0.5.6-0.7.1
  • libvirt-devel-32bit >= 1.0.5.6-0.7.1
  • libvirt-doc >= 1.0.5.6-0.7.1
  • libvirt-python >= 1.0.5.6-0.7.1
Patchnames:
sdksp3-libvirt
sledsp3-libvirt
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libvirt-devel >= 1.2.5-3.76
  • libvirt-devel-32bit >= 1.2.5-3.76
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libvirt-devel-1.2.5-3.76
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • libvirt >= 1.0.5.6-0.7.1
  • libvirt-client >= 1.0.5.6-0.7.1
  • libvirt-client-32bit >= 1.0.5.9-0.9.1
  • libvirt-devel >= 1.0.5.6-0.7.1
  • libvirt-devel-32bit >= 1.0.5.6-0.7.1
  • libvirt-doc >= 1.0.5.6-0.7.1
  • libvirt-lock-sanlock >= 1.0.5.6-0.7.1
  • libvirt-python >= 1.0.5.6-0.7.1
Patchnames:
sdksp3-libvirt
slessp3-libvirt
SUSE Linux Enterprise Server 11 SP4
  • libvirt >= 1.2.5-3.76
  • libvirt-client >= 1.2.5-3.76
  • libvirt-client-32bit >= 1.2.5-3.76
  • libvirt-devel >= 1.2.5-3.76
  • libvirt-devel-32bit >= 1.2.5-3.76
  • libvirt-doc >= 1.2.5-3.76
  • libvirt-lock-sanlock >= 1.2.5-3.76
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libvirt-1.2.5-3.76
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libvirt-devel-1.2.5-3.76
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libvirt-devel >= 1.0.5.6-0.7.1
  • libvirt-devel-32bit >= 1.0.5.6-0.7.1
Patchnames:
sdksp3-libvirt


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products past their end of life and not receiving proactive updates anymore.
SLES for SAP Applications 11 SP2 libvirt Released
SLES for SAP Applications 11 SP3 libvirt Released
SUSE Linux Enterprise Desktop 11 SP2 libvirt Released
SUSE Linux Enterprise Desktop 11 SP3 libvirt Released
SUSE Linux Enterprise Server 11 SP2 libvirt Released
SUSE Linux Enterprise Server 11 SP2 LTSS libvirt Released
SUSE Linux Enterprise Server 11 SP3 libvirt Released
SUSE Linux Enterprise Server 11 SP3 LTSS libvirt Released
SUSE Linux Enterprise Server 11 SP3-LTSS libvirt Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP2 libvirt Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 libvirt Released
SUSE Linux Enterprise Software Development Kit 11 SP2 libvirt Released
SUSE Linux Enterprise Software Development Kit 11 SP3 libvirt Released


SUSE Timeline for this CVE

CVE page created: Mon Sep 2 11:16:15 2013
CVE page last modified: Sat Jun 15 21:59:57 2024