SUSE Support

Here When You Need Us

PostgreSQL vacuum failure during migration from SUSE Multi-Linux Manager 4.3 to 5.0

This document (000021846) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Multi-Linux Manager 5.0


Situation

Migrating from SUSE Multi-Linux Manager 4.3 to SUSE Multi-Linux Manager 5.0 by using mgradm utility tool, fails with the following error message:

( 52/188) apply upgrade [susemanager-schema-4.3.11-to-susemanager-schema-4.3.12/900-vacuum-analyze.sql.postgresql] .postgresql]
Upgrade failed, please see log [/var/log/spacewalk/schema-upgrade/schema-from-20250516-071648-to-susemanager-schema-5.0.14.log].
You can fix the failed migration in [/var/log/spacewalk/schema-upgrade/schema-from-20250516-071648] and run spacewalk-schema-upgrade again

A review of the end of the schema-upgrade log reveals the following:

psql:<stdin>:2: ERROR:  could not resize shared memory segment "/PostgreSQL.3349103096" to 95413760 bytes: No space left on device

Resolution

As a workaround, ShmSize to 0 (=unlimited) can be set as a default for the Podman containers to be created.

To do so, create the file /etc/containers/containers.conf on the SUSE MLM 5.0 host with the following content, and run again the migration.

# cat /etc/containers/containers.conf 
[containers]
shm_size = "0"

Cause

During the upgrade process, some Podman containers - such as uyuni-finalize-pgsql and uyuni-upgrade-pgsql - are launched on the fly to manage PostgreSQL database migration.

Since ShmSize is not explicitly defined for these containers, the default value of 64 MB is used which may be insufficient and can cause the migration to fail.

Status

Reported to Engineering

Additional Information

This issue has been reported to SUSE engineering and a new version of mgradm is expected to be released. When the update has been released, this document will be updated with information about the version containing the fix.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021846
  • Creation Date: 21-May-2025
  • Modified Date:22-May-2025
    • SUSE Manager Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.