SUSE Support

Here When You Need Us

Exclude cattle-system namespace from Dynatrace monitoring

This document (000020657) is provided subject to the disclaimer at the end of this document.

Environment

The cattle-cluster-agent pod is stuck in a CrashLoopBackOff, logging the following messages:
usage: agent <absolute path of static Go application> [Go application arguments]

 


Situation

We have observed messages from downstream clusters where the cattle-cluster-agent on any Rancher version can contain no logging outputs, with messages only relating to environment variables.

Running kubectl exec to access a shell on the pod and running /usr/bin/run.sh also produces the error.

Resolution

It is recommend to exclude the cattle-system namespace from being monitored by Dynatrace. The below documentation is specific for Dynatrace, however other solutions could have similar options.

Option 3: https://www.dynatrace.com/support/help/setup-and-configuration/setup-on-container-platforms/kubernetes/get-started-with-kubernetes-monitoring/dto-config-options-k8s#annotate

Cause

Solutions like Dynatrace can potentially inject sidecar containers alongside cattle-cluster-agent/cattle-node-agent containers, causing the agent to exit unpredictably..
 

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020657
  • Creation Date: 18-May-2022
  • Modified Date:20-Sep-2022
    • SUSE Rancher

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.