Upstream information

CVE-2022-24939 at MITRE

Description

A malformed packet containing an invalid destination address, causes a stack overflow in the Ember ZNet stack. This causes an assert which leads to a reset, immediately clearing the error.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

SUSE Bugzilla entry: 1198739 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 nekohtml Unsupported
SUSE Enterprise Storage 7.1 rubygem-nokogiri Not affected
SUSE Linux Enterprise Desktop 15 SP5 nekohtml Unsupported
SUSE Linux Enterprise Desktop 15 SP5 rubygem-nokogiri Not affected
SUSE Linux Enterprise High Performance Computing 15 SP5 nekohtml Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP5 rubygem-nokogiri Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP5 rubygem-nokogiri Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP5 nekohtml Unsupported
SUSE Linux Enterprise Real Time 15 SP3 nekohtml Unsupported
SUSE Linux Enterprise Real Time 15 SP3 rubygem-nokogiri Not affected
SUSE Linux Enterprise Server 15 SP5 nekohtml Unsupported
SUSE Linux Enterprise Server 15 SP5 rubygem-nokogiri Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 nekohtml Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP4 rubygem-nokogiri Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 nekohtml Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP5 rubygem-nokogiri Not affected
SUSE Manager Proxy 4.3 nekohtml Unsupported
SUSE Manager Proxy 4.3 rubygem-nokogiri Not affected
SUSE Manager Retail Branch Server 4.3 nekohtml Unsupported
SUSE Manager Retail Branch Server 4.3 rubygem-nokogiri Not affected
SUSE Manager Server 4.3 nekohtml Unsupported
SUSE Manager Server 4.3 rubygem-nokogiri Not affected
SUSE Manager Server Module 4.3 nekohtml Affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 nekohtml Unsupported
SUSE Linux Enterprise Desktop 15 SP4 rubygem-nokogiri Not affected
SUSE Linux Enterprise High Availability Extension 15 SP2 rubygem-nokogiri Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 nekohtml Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS nekohtml Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS nekohtml Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3 nekohtml Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3 rubygem-nokogiri Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS nekohtml Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS rubygem-nokogiri Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS nekohtml Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS rubygem-nokogiri Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 nekohtml Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP4 rubygem-nokogiri Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS nekohtml Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS rubygem-nokogiri Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS nekohtml Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS rubygem-nokogiri Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 rubygem-nokogiri Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 rubygem-nokogiri Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 nekohtml Unsupported
SUSE Linux Enterprise Module for Development Tools 15 SP3 nekohtml Unsupported
SUSE Linux Enterprise Module for Development Tools 15 SP4 nekohtml Unsupported
SUSE Linux Enterprise Server 15 SP2 nekohtml Unsupported
SUSE Linux Enterprise Server 15 SP2-LTSS nekohtml Unsupported
SUSE Linux Enterprise Server 15 SP3 nekohtml Unsupported
SUSE Linux Enterprise Server 15 SP3 rubygem-nokogiri Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS nekohtml Unsupported
SUSE Linux Enterprise Server 15 SP3-LTSS rubygem-nokogiri Not affected
SUSE Linux Enterprise Server 15 SP4 nekohtml Unsupported
SUSE Linux Enterprise Server 15 SP4 rubygem-nokogiri Not affected
SUSE Linux Enterprise Server 15 SP4-LTSS nekohtml Unsupported
SUSE Linux Enterprise Server 15 SP4-LTSS rubygem-nokogiri Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 nekohtml Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP2 nekohtml Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP3 nekohtml Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP3 rubygem-nokogiri Not affected
Products past their end of life and not receiving proactive updates anymore.
SUSE Enterprise Storage 2.1 rubygem-nokogiri Not affected
SUSE Enterprise Storage 3 rubygem-nokogiri Not affected
SUSE Enterprise Storage 4 rubygem-nokogiri Not affected
SUSE Enterprise Storage 7 nekohtml Unsupported
SUSE Linux Enterprise Desktop 15 SP2 nekohtml Unsupported
SUSE Linux Enterprise Desktop 15 SP3 nekohtml Unsupported
SUSE Linux Enterprise Desktop 15 SP3 rubygem-nokogiri Not affected
SUSE Linux Enterprise High Availability Extension 15 rubygem-nokogiri Not affected
SUSE Linux Enterprise High Availability Extension 15 SP1 rubygem-nokogiri Not affected
SUSE Linux Enterprise Real Time 15 SP2 nekohtml Unsupported
SUSE Linux Enterprise Real Time 15 SP4 nekohtml Unsupported
SUSE Linux Enterprise Real Time 15 SP4 rubygem-nokogiri Not affected
SUSE Linux Enterprise Server 15 SP2-BCL nekohtml Unsupported
SUSE Linux Enterprise Server 15 SP3-BCL nekohtml Unsupported
SUSE Linux Enterprise Server 15 SP3-BCL rubygem-nokogiri Not affected
SUSE Manager Proxy 4.1 nekohtml Unsupported
SUSE Manager Proxy 4.2 nekohtml Unsupported
SUSE Manager Proxy 4.2 rubygem-nokogiri Not affected
SUSE Manager Retail Branch Server 4.1 nekohtml Unsupported
SUSE Manager Retail Branch Server 4.2 nekohtml Unsupported
SUSE Manager Retail Branch Server 4.2 rubygem-nokogiri Not affected
SUSE Manager Server 4.1 nekohtml Unsupported
SUSE Manager Server 4.2 nekohtml Unsupported
SUSE Manager Server 4.2 rubygem-nokogiri Not affected
SUSE Manager Server Module 4.1 nekohtml Won't fix
SUSE Manager Server Module 4.2 nekohtml Unsupported
SUSE OpenStack Cloud 6 rubygem-nokogiri Not affected
SUSE OpenStack Cloud 6-LTSS rubygem-nokogiri Not affected
SUSE OpenStack Cloud 7 rubygem-nokogiri Not affected
SUSE OpenStack Cloud Crowbar 8 rubygem-nokogiri Not affected
SUSE OpenStack Cloud Crowbar 9 rubygem-nokogiri Not affected
Products at an unknown state of their lifecycle.
SUSE Linux Enterprise Desktop 15 SP4-LTSS nekohtml Unsupported
SUSE Linux Enterprise Desktop 15 SP4-LTSS rubygem-nokogiri Not affected


SUSE Timeline for this CVE

CVE page created: Fri Oct 7 12:52:13 2022
CVE page last modified: Thu Feb 1 01:43:15 2024