Upstream information

CVE-2021-40516 at MITRE

Description

WeeChat before 3.2.1 allows remote attackers to cause a denial of service (crash) via a crafted WebSocket frame that trigger an out-of-bounds read in plugins/relay/relay-websocket.c in the Relay plugin.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently not rated by SUSE as it is not affecting the SUSE Enterprise products.

SUSE Bugzilla entry: 1190206 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 15 SP3
  • weechat >= 3.2.1-bp153.2.3.1
  • weechat-devel >= 3.2.1-bp153.2.3.1
  • weechat-lang >= 3.2.1-bp153.2.3.1
  • weechat-lua >= 3.2.1-bp153.2.3.1
  • weechat-perl >= 3.2.1-bp153.2.3.1
  • weechat-python >= 3.2.1-bp153.2.3.1
  • weechat-ruby >= 3.2.1-bp153.2.3.1
  • weechat-spell >= 3.2.1-bp153.2.3.1
  • weechat-tcl >= 3.2.1-bp153.2.3.1
Patchnames:
openSUSE-2022-83
openSUSE Leap 15.3
  • weechat >= 3.2.1-bp153.2.3.1
  • weechat-devel >= 3.2.1-bp153.2.3.1
  • weechat-lang >= 3.2.1-bp153.2.3.1
  • weechat-lua >= 3.2.1-bp153.2.3.1
  • weechat-perl >= 3.2.1-bp153.2.3.1
  • weechat-python >= 3.2.1-bp153.2.3.1
  • weechat-ruby >= 3.2.1-bp153.2.3.1
  • weechat-spell >= 3.2.1-bp153.2.3.1
  • weechat-tcl >= 3.2.1-bp153.2.3.1
Patchnames:
openSUSE-2022-83