DescriptionSome components in Apache Kafka use `Arrays.equals` to validate a password or key, which is vulnerable to timing attacks that make brute force attacks for such credentials more likely to be successful. Users should upgrade to 2.8.1 or higher, or 3.0.0 or higher where this vulnerability has been fixed. The affected versions include Apache Kafka 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, and 2.8.0.
Overall state of this security issue: Resolved
This issue is currently rated as having moderate severity.SUSE Bugzilla entry: 1190852 [NEW] No SUSE Security Announcements cross referenced.
Status of this issue by product and package
Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.
|HPE Helion OpenStack 8||kafka||Not affected|
|SUSE OpenStack Cloud 8||kafka||Not affected|
|SUSE OpenStack Cloud 9||kafka||Not affected|
|SUSE OpenStack Cloud Crowbar 8||kafka||Not affected|
|SUSE OpenStack Cloud Crowbar 9||kafka||Not affected|