Upstream information

CVE-2021-3450 at MITRE

Description

The X509_V_FLAG_X509_STRICT flag enables additional security checks of the certificates present in a certificate chain. It is not set by default. Starting from OpenSSL version 1.1.1h a check to disallow certificates in the chain that have explicitly encoded elliptic curve parameters was added as an additional strict check. An error in the implementation of this check meant that the result of a previous check to confirm that certificates in the chain are valid CA certificates was overwritten. This effectively bypasses the check that non-CA certificates must not be able to issue other certificates. If a "purpose" has been configured then there is a subsequent opportunity for checks that the certificate is a valid CA. All of the named "purpose" values implemented in libcrypto perform this check. Therefore, where a purpose is set the certificate chain will still be rejected even when the strict flag has been used. A purpose is set by default in libssl client and server certificate verification routines, but it can be overridden or removed by an application. In order to be affected, an application must explicitly set the X509_V_FLAG_X509_STRICT verification flag and either not set a purpose for the certificate verification or, in the case of TLS client or server applications, override the default purpose. OpenSSL versions 1.1.1h and newer are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1k. OpenSSL 1.0.2 is not impacted by this issue. Fixed in OpenSSL 1.1.1k (Affected 1.1.1h-1.1.1j).

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.4 6.5
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Access Vector Network Network
Access Complexity High Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact None None
CVSSv3 Version 3.1 3.1

Note from the SUSE Security Team

This issue affects only openssl 1.1.1h and newer, so no SUSE Linux Enterprise was affected.

SUSE Bugzilla entry: 1183851 [IN_PROGRESS]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
Carwos 1 openssl Not affected
Carwos 1 openssl-1_1 Not affected
HPE Helion OpenStack 8 openssl Not affected
SUSE CaaS Platform 4.0 openssl Not affected
SUSE CaaS Platform 4.0 openssl-1_0_0 Not affected
SUSE CaaS Platform 4.0 openssl-1_1 Not affected
SUSE Enterprise Storage 6 openssl Not affected
SUSE Enterprise Storage 6 openssl-1_0_0 Not affected
SUSE Enterprise Storage 6 openssl-1_1 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 openssl Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 openssl-1_0_0 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 openssl-1_1 Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS openssl Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS openssl-1_1 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS openssl Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS openssl-1_1 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 openssl Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 openssl-1_1 Not affected
SUSE Linux Enterprise Module for Legacy 12 compat-openssl098 Not affected
SUSE Linux Enterprise Module for Legacy 15 SP2 openssl-1_0_0 Not affected
SUSE Linux Enterprise Point of Service 11 SP3 openssl Not affected
SUSE Linux Enterprise Point of Service Image Server 12 openssl Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS openssl Not affected
SUSE Linux Enterprise Server 12 SP2 BCL openssl Not affected
SUSE Linux Enterprise Server 12 SP2 ESPOS openssl Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS openssl Not affected
SUSE Linux Enterprise Server 12 SP3 BCL openssl Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS openssl Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS openssl Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS openssl Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS openssl-1_1 Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS openssl Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS openssl-1_1 Not affected
SUSE Linux Enterprise Server 12 SP5 openssl Not affected
SUSE Linux Enterprise Server 12 SP5 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 12 SP5 openssl-1_1 Not affected
SUSE Linux Enterprise Server 15 LTSS openssl Not affected
SUSE Linux Enterprise Server 15 LTSS openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 15 LTSS openssl-1_1 Not affected
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux openssl Not affected
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux openssl-1_1 Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS openssl Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS openssl-1_0_0 Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS openssl-1_1 Not affected
SUSE Linux Enterprise Server ESPOS 15 openssl Not affected
SUSE Linux Enterprise Server ESPOS 15 openssl-1_1 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 compat-openssl098 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 compat-openssl098 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openssl-1_1 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 compat-openssl098 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 openssl-1_1 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 15 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 openssl-1_1 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 openssl-1_0_0 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 openssl-1_1 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 openssl-1_1 Not affected
SUSE Manager Proxy 4.0 openssl Not affected
SUSE Manager Proxy 4.0 openssl-1_0_0 Not affected
SUSE Manager Proxy 4.0 openssl-1_1 Not affected
SUSE Manager Retail Branch Server 4.0 openssl Not affected
SUSE Manager Retail Branch Server 4.0 openssl-1_0_0 Not affected
SUSE Manager Retail Branch Server 4.0 openssl-1_1 Not affected
SUSE Manager Server 4.0 openssl Not affected
SUSE Manager Server 4.0 openssl-1_0_0 Not affected
SUSE Manager Server 4.0 openssl-1_1 Not affected
SUSE OpenStack Cloud 7 openssl Not affected
SUSE OpenStack Cloud 8 openssl Not affected
SUSE OpenStack Cloud 9 openssl Not affected
SUSE OpenStack Cloud 9 openssl-1_0_0 Not affected
SUSE OpenStack Cloud 9 openssl-1_1 Not affected
SUSE OpenStack Cloud Crowbar 8 openssl Not affected
SUSE OpenStack Cloud Crowbar 9 openssl Not affected
SUSE OpenStack Cloud Crowbar 9 openssl-1_0_0 Not affected
SUSE OpenStack Cloud Crowbar 9 openssl-1_1 Not affected
Security Module for SUSE Linux Enterprise 11 openssl1 Not affected