Upstream information

CVE-2021-3114 at MITRE

Description

In Go before 1.14.14 and 1.15.x before 1.15.7, crypto/elliptic/p224.go can generate incorrect outputs, related to an underflow of the lowest limb during the final complete reduction in the P-224 field.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.4
Vector AV:N/AC:L/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 4.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact Low Low
Integrity Impact Low Low
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1181145 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform 4.0
  • go1.14 >= 1.14.14-1.32.1
  • go1.14-doc >= 1.14.14-1.32.1
  • go1.15 >= 1.15.7-1.17.1
  • go1.15-doc >= 1.15.7-1.17.1
  • go1.15-race >= 1.15.7-1.17.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2021-222
SUSE-SUSE-CAASP-4.0-2021-223
SUSE Enterprise Storage 6
  • go1.14 >= 1.14.14-1.32.1
  • go1.14-doc >= 1.14.14-1.32.1
  • go1.15 >= 1.15.7-1.17.1
  • go1.15-doc >= 1.15.7-1.17.1
  • go1.15-race >= 1.15.7-1.17.1
Patchnames:
SUSE-Storage-6-2021-222
SUSE-Storage-6-2021-223
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • go1.14 >= 1.14.14-1.32.1
  • go1.14-doc >= 1.14.14-1.32.1
  • go1.15 >= 1.15.7-1.17.1
  • go1.15-doc >= 1.15.7-1.17.1
  • go1.15-race >= 1.15.7-1.17.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-222
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-223
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • go1.14 >= 1.14.14-1.32.1
  • go1.14-doc >= 1.14.14-1.32.1
  • go1.15 >= 1.15.7-1.17.1
  • go1.15-doc >= 1.15.7-1.17.1
  • go1.15-race >= 1.15.7-1.17.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-222
SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-223
SUSE Linux Enterprise Module for Development Tools 15 SP2
  • go1.14 >= 1.14.14-1.32.1
  • go1.14-doc >= 1.14.14-1.32.1
  • go1.15 >= 1.15.7-1.17.1
  • go1.15-doc >= 1.15.7-1.17.1
  • go1.15-race >= 1.15.7-1.17.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP2-2021-222
SUSE-SLE-Module-Development-Tools-15-SP2-2021-223
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • go1.14 >= 1.14.14-1.32.1
  • go1.14-race >= 1.14.14-1.32.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2021-222
SUSE Linux Enterprise Server 15 SP1-BCL
  • go1.14 >= 1.14.14-1.32.1
  • go1.14-doc >= 1.14.14-1.32.1
  • go1.15 >= 1.15.7-1.17.1
  • go1.15-doc >= 1.15.7-1.17.1
  • go1.15-race >= 1.15.7-1.17.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-BCL-2021-222
SUSE-SLE-Product-SLES-15-SP1-BCL-2021-223
SUSE Linux Enterprise Server 15 SP1-LTSS
  • go1.14 >= 1.14.14-1.32.1
  • go1.14-doc >= 1.14.14-1.32.1
  • go1.15 >= 1.15.7-1.17.1
  • go1.15-doc >= 1.15.7-1.17.1
  • go1.15-race >= 1.15.7-1.17.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-222
SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-223
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • go1.14 >= 1.14.14-1.32.1
  • go1.14-doc >= 1.14.14-1.32.1
  • go1.15 >= 1.15.7-1.17.1
  • go1.15-doc >= 1.15.7-1.17.1
  • go1.15-race >= 1.15.7-1.17.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2021-222
SUSE-SLE-Product-SLES_SAP-15-SP1-2021-223
SUSE Manager Proxy 4.0
  • go1.14 >= 1.14.14-1.32.1
  • go1.14-doc >= 1.14.14-1.32.1
  • go1.15 >= 1.15.7-1.17.1
  • go1.15-doc >= 1.15.7-1.17.1
  • go1.15-race >= 1.15.7-1.17.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.0-2021-222
SUSE-SLE-Product-SUSE-Manager-Proxy-4.0-2021-223
SUSE Manager Retail Branch Server 4.0
  • go1.14 >= 1.14.14-1.32.1
  • go1.14-doc >= 1.14.14-1.32.1
  • go1.15 >= 1.15.7-1.17.1
  • go1.15-doc >= 1.15.7-1.17.1
  • go1.15-race >= 1.15.7-1.17.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.0-2021-222
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.0-2021-223
SUSE Manager Server 4.0
  • go1.14 >= 1.14.14-1.32.1
  • go1.14-doc >= 1.14.14-1.32.1
  • go1.15 >= 1.15.7-1.17.1
  • go1.15-doc >= 1.15.7-1.17.1
  • go1.15-race >= 1.15.7-1.17.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.0-2021-222
SUSE-SLE-Product-SUSE-Manager-Server-4.0-2021-223
openSUSE Leap 15.1
  • go1.14 >= 1.14.14-lp151.28.1
  • go1.14-doc >= 1.14.14-lp151.28.1
  • go1.14-race >= 1.14.14-lp151.28.1
Patchnames:
openSUSE-2021-190
openSUSE Leap 15.2
  • go1.14 >= 1.14.14-lp152.2.18.1
  • go1.14-doc >= 1.14.14-lp152.2.18.1
  • go1.14-race >= 1.14.14-lp152.2.18.1
  • go1.15 >= 1.15.7-lp152.8.1
  • go1.15-doc >= 1.15.7-lp152.8.1
  • go1.15-race >= 1.15.7-lp152.8.1
Patchnames:
openSUSE-2021-192
openSUSE-2021-194


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 go1.14 Released
SUSE CaaS Platform 4.0 go1.15 Released
SUSE Enterprise Storage 6 go1.14 Released
SUSE Enterprise Storage 6 go1.15 Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS go1.14 Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS go1.15 Released
SUSE Linux Enterprise Module for Development Tools 15 SP1 go1.14 Released
SUSE Linux Enterprise Module for Development Tools 15 SP1 go1.15 Released
SUSE Linux Enterprise Module for Development Tools 15 SP2 go1.14 Released
SUSE Linux Enterprise Module for Development Tools 15 SP2 go1.15 Released
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux go1.14 Released
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux go1.15 Released
SUSE Linux Enterprise Server 15 SP1 LTSS go1.14 Released
SUSE Linux Enterprise Server 15 SP1 LTSS go1.15 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 go1.14 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 go1.15 Released
SUSE Manager Proxy 4.0 go1.14 Released
SUSE Manager Proxy 4.0 go1.15 Released
SUSE Manager Retail Branch Server 4.0 go1.14 Released
SUSE Manager Retail Branch Server 4.0 go1.15 Released
SUSE Manager Server 4.0 go1.14 Released
SUSE Manager Server 4.0 go1.15 Released