Upstream information

CVE-2021-25329 at MITRE

Description

The fix for CVE-2020-9484 was incomplete. When using Apache Tomcat 10.0.0-M1 to 10.0.0, 9.0.0.M1 to 9.0.41, 8.5.0 to 8.5.61 or 7.0.0. to 7.0.107 with a configuration edge case that was highly unlikely to be used, the Tomcat instance was still vulnerable to CVE-2020-9494. Note that both the previously published prerequisites for CVE-2020-9484 and the previously published mitigations for CVE-2020-9484 also apply to this issue.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.4
Vector AV:L/AC:M/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7 7
Vector CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Local Local
Access Complexity High High
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1182909 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform 4.0
  • tomcat >= 9.0.36-4.58.1
  • tomcat-admin-webapps >= 9.0.36-4.58.1
  • tomcat-el-3_0-api >= 9.0.36-4.58.1
  • tomcat-jsp-2_3-api >= 9.0.36-4.58.1
  • tomcat-lib >= 9.0.36-4.58.1
  • tomcat-servlet-4_0-api >= 9.0.36-4.58.1
  • tomcat-webapps >= 9.0.36-4.58.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2021-1009
SUSE Enterprise Storage 6
  • tomcat >= 9.0.36-4.58.1
  • tomcat-admin-webapps >= 9.0.36-4.58.1
  • tomcat-el-3_0-api >= 9.0.36-4.58.1
  • tomcat-jsp-2_3-api >= 9.0.36-4.58.1
  • tomcat-lib >= 9.0.36-4.58.1
  • tomcat-servlet-4_0-api >= 9.0.36-4.58.1
  • tomcat-webapps >= 9.0.36-4.58.1
Patchnames:
SUSE-Storage-6-2021-1009
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • tomcat >= 9.0.36-4.58.1
  • tomcat-admin-webapps >= 9.0.36-4.58.1
  • tomcat-el-3_0-api >= 9.0.36-4.58.1
  • tomcat-jsp-2_3-api >= 9.0.36-4.58.1
  • tomcat-lib >= 9.0.36-4.58.1
  • tomcat-servlet-4_0-api >= 9.0.36-4.58.1
  • tomcat-webapps >= 9.0.36-4.58.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-1009
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • tomcat >= 9.0.36-4.58.1
  • tomcat-admin-webapps >= 9.0.36-4.58.1
  • tomcat-el-3_0-api >= 9.0.36-4.58.1
  • tomcat-jsp-2_3-api >= 9.0.36-4.58.1
  • tomcat-lib >= 9.0.36-4.58.1
  • tomcat-servlet-4_0-api >= 9.0.36-4.58.1
  • tomcat-webapps >= 9.0.36-4.58.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-1009
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • tomcat >= 9.0.36-3.79.1
  • tomcat-admin-webapps >= 9.0.36-3.79.1
  • tomcat-el-3_0-api >= 9.0.36-3.79.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.79.1
  • tomcat-lib >= 9.0.36-3.79.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.79.1
  • tomcat-webapps >= 9.0.36-3.79.1
Patchnames:
SUSE-SLE-Product-HPC-15-2021-989
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • tomcat >= 9.0.36-3.24.1
  • tomcat-docs-webapp >= 9.0.36-3.24.1
  • tomcat-embed >= 9.0.36-3.24.1
  • tomcat-javadoc >= 9.0.36-3.24.1
  • tomcat-jsvc >= 9.0.36-3.24.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2021-1008
SUSE Linux Enterprise Module for Web Scripting 15 SP2
  • tomcat >= 9.0.36-3.24.1
  • tomcat-admin-webapps >= 9.0.36-3.24.1
  • tomcat-el-3_0-api >= 9.0.36-3.24.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.24.1
  • tomcat-lib >= 9.0.36-3.24.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.24.1
  • tomcat-webapps >= 9.0.36-3.24.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-15-SP2-2021-1008
SUSE Linux Enterprise Server 12 SP4-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP4-ESPOS
  • tomcat >= 9.0.36-3.64.1
  • tomcat-admin-webapps >= 9.0.36-3.64.1
  • tomcat-docs-webapp >= 9.0.36-3.64.1
  • tomcat-el-3_0-api >= 9.0.36-3.64.1
  • tomcat-javadoc >= 9.0.36-3.64.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.64.1
  • tomcat-lib >= 9.0.36-3.64.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.64.1
  • tomcat-webapps >= 9.0.36-3.64.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-ESPOS-2021-988
SUSE Linux Enterprise Server 12 SP4-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP4-LTSS
  • tomcat >= 9.0.36-3.64.1
  • tomcat-admin-webapps >= 9.0.36-3.64.1
  • tomcat-docs-webapp >= 9.0.36-3.64.1
  • tomcat-el-3_0-api >= 9.0.36-3.64.1
  • tomcat-javadoc >= 9.0.36-3.64.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.64.1
  • tomcat-lib >= 9.0.36-3.64.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.64.1
  • tomcat-webapps >= 9.0.36-3.64.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-LTSS-2021-988
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • tomcat >= 9.0.36-3.64.1
  • tomcat-admin-webapps >= 9.0.36-3.64.1
  • tomcat-docs-webapp >= 9.0.36-3.64.1
  • tomcat-el-3_0-api >= 9.0.36-3.64.1
  • tomcat-javadoc >= 9.0.36-3.64.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.64.1
  • tomcat-lib >= 9.0.36-3.64.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.64.1
  • tomcat-webapps >= 9.0.36-3.64.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2021-988
SUSE Linux Enterprise Server 15 SP1-BCL
  • tomcat >= 9.0.36-4.58.1
  • tomcat-admin-webapps >= 9.0.36-4.58.1
  • tomcat-el-3_0-api >= 9.0.36-4.58.1
  • tomcat-jsp-2_3-api >= 9.0.36-4.58.1
  • tomcat-lib >= 9.0.36-4.58.1
  • tomcat-servlet-4_0-api >= 9.0.36-4.58.1
  • tomcat-webapps >= 9.0.36-4.58.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-BCL-2021-1009
SUSE Linux Enterprise Server 15 SP1-LTSS
  • tomcat >= 9.0.36-4.58.1
  • tomcat-admin-webapps >= 9.0.36-4.58.1
  • tomcat-el-3_0-api >= 9.0.36-4.58.1
  • tomcat-jsp-2_3-api >= 9.0.36-4.58.1
  • tomcat-lib >= 9.0.36-4.58.1
  • tomcat-servlet-4_0-api >= 9.0.36-4.58.1
  • tomcat-webapps >= 9.0.36-4.58.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-1009
SUSE Linux Enterprise Server 15-LTSS
  • tomcat >= 9.0.36-3.79.1
  • tomcat-admin-webapps >= 9.0.36-3.79.1
  • tomcat-el-3_0-api >= 9.0.36-3.79.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.79.1
  • tomcat-lib >= 9.0.36-3.79.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.79.1
  • tomcat-webapps >= 9.0.36-3.79.1
Patchnames:
SUSE-SLE-Product-SLES-15-2021-989
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • tomcat >= 9.0.36-3.64.1
  • tomcat-admin-webapps >= 9.0.36-3.64.1
  • tomcat-docs-webapp >= 9.0.36-3.64.1
  • tomcat-el-3_0-api >= 9.0.36-3.64.1
  • tomcat-javadoc >= 9.0.36-3.64.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.64.1
  • tomcat-lib >= 9.0.36-3.64.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.64.1
  • tomcat-webapps >= 9.0.36-3.64.1
Patchnames:
SUSE-SLE-SAP-12-SP4-2021-988
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • tomcat >= 9.0.36-4.58.1
  • tomcat-admin-webapps >= 9.0.36-4.58.1
  • tomcat-el-3_0-api >= 9.0.36-4.58.1
  • tomcat-jsp-2_3-api >= 9.0.36-4.58.1
  • tomcat-lib >= 9.0.36-4.58.1
  • tomcat-servlet-4_0-api >= 9.0.36-4.58.1
  • tomcat-webapps >= 9.0.36-4.58.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2021-1009
SUSE Linux Enterprise Server for SAP Applications 15
  • tomcat >= 9.0.36-3.79.1
  • tomcat-admin-webapps >= 9.0.36-3.79.1
  • tomcat-el-3_0-api >= 9.0.36-3.79.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.79.1
  • tomcat-lib >= 9.0.36-3.79.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.79.1
  • tomcat-webapps >= 9.0.36-3.79.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2021-989
SUSE Manager Proxy 4.0
  • tomcat >= 9.0.36-4.58.1
  • tomcat-admin-webapps >= 9.0.36-4.58.1
  • tomcat-el-3_0-api >= 9.0.36-4.58.1
  • tomcat-jsp-2_3-api >= 9.0.36-4.58.1
  • tomcat-lib >= 9.0.36-4.58.1
  • tomcat-servlet-4_0-api >= 9.0.36-4.58.1
  • tomcat-webapps >= 9.0.36-4.58.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.0-2021-1009
SUSE Manager Retail Branch Server 4.0
  • tomcat >= 9.0.36-4.58.1
  • tomcat-admin-webapps >= 9.0.36-4.58.1
  • tomcat-el-3_0-api >= 9.0.36-4.58.1
  • tomcat-jsp-2_3-api >= 9.0.36-4.58.1
  • tomcat-lib >= 9.0.36-4.58.1
  • tomcat-servlet-4_0-api >= 9.0.36-4.58.1
  • tomcat-webapps >= 9.0.36-4.58.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.0-2021-1009
SUSE Manager Server 4.0
  • tomcat >= 9.0.36-4.58.1
  • tomcat-admin-webapps >= 9.0.36-4.58.1
  • tomcat-el-3_0-api >= 9.0.36-4.58.1
  • tomcat-jsp-2_3-api >= 9.0.36-4.58.1
  • tomcat-lib >= 9.0.36-4.58.1
  • tomcat-servlet-4_0-api >= 9.0.36-4.58.1
  • tomcat-webapps >= 9.0.36-4.58.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.0-2021-1009
SUSE OpenStack Cloud 9
  • tomcat >= 9.0.36-3.64.1
  • tomcat-admin-webapps >= 9.0.36-3.64.1
  • tomcat-docs-webapp >= 9.0.36-3.64.1
  • tomcat-el-3_0-api >= 9.0.36-3.64.1
  • tomcat-javadoc >= 9.0.36-3.64.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.64.1
  • tomcat-lib >= 9.0.36-3.64.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.64.1
  • tomcat-webapps >= 9.0.36-3.64.1
Patchnames:
SUSE-OpenStack-Cloud-9-2021-988
SUSE OpenStack Cloud Crowbar 9
  • tomcat >= 9.0.36-3.64.1
  • tomcat-admin-webapps >= 9.0.36-3.64.1
  • tomcat-docs-webapp >= 9.0.36-3.64.1
  • tomcat-el-3_0-api >= 9.0.36-3.64.1
  • tomcat-javadoc >= 9.0.36-3.64.1
  • tomcat-jsp-2_3-api >= 9.0.36-3.64.1
  • tomcat-lib >= 9.0.36-3.64.1
  • tomcat-servlet-4_0-api >= 9.0.36-3.64.1
  • tomcat-webapps >= 9.0.36-3.64.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2021-988
openSUSE Leap 15.2
  • tomcat >= 9.0.36-lp152.2.22.1
  • tomcat-admin-webapps >= 9.0.36-lp152.2.22.1
  • tomcat-docs-webapp >= 9.0.36-lp152.2.22.1
  • tomcat-el-3_0-api >= 9.0.36-lp152.2.22.1
  • tomcat-embed >= 9.0.36-lp152.2.22.1
  • tomcat-javadoc >= 9.0.36-lp152.2.22.1
  • tomcat-jsp-2_3-api >= 9.0.36-lp152.2.22.1
  • tomcat-jsvc >= 9.0.36-lp152.2.22.1
  • tomcat-lib >= 9.0.36-lp152.2.22.1
  • tomcat-servlet-4_0-api >= 9.0.36-lp152.2.22.1
  • tomcat-webapps >= 9.0.36-lp152.2.22.1
Patchnames:
openSUSE-2021-496


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 tomcat Affected
SUSE CaaS Platform 4.0 tomcat Released
SUSE Enterprise Storage 6 tomcat Released
SUSE Linux Enterprise High Performance Computing 12 SP5 tomcat Released
SUSE Linux Enterprise High Performance Computing 15 LTSS tomcat Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS tomcat Released
SUSE Linux Enterprise Module for Web and Scripting 15 SP2 tomcat Released
SUSE Linux Enterprise Point of Service 11 SP3 tomcat6 Affected
SUSE Linux Enterprise Point of Service Image Server 12 tomcat Affected
SUSE Linux Enterprise Server 11 SP4 LTSS tomcat6 Affected
SUSE Linux Enterprise Server 12 SP2 BCL tomcat Affected
SUSE Linux Enterprise Server 12 SP2 ESPOS tomcat Affected
SUSE Linux Enterprise Server 12 SP2 LTSS tomcat Affected
SUSE Linux Enterprise Server 12 SP3 BCL tomcat Affected
SUSE Linux Enterprise Server 12 SP3 ESPOS tomcat Affected
SUSE Linux Enterprise Server 12 SP3 LTSS tomcat Affected
SUSE Linux Enterprise Server 12 SP4 ESPOS tomcat Released
SUSE Linux Enterprise Server 12 SP4 LTSS tomcat Released
SUSE Linux Enterprise Server 12 SP5 tomcat Released
SUSE Linux Enterprise Server 15 LTSS tomcat Released
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux tomcat Released
SUSE Linux Enterprise Server 15 SP1 LTSS tomcat Released
SUSE Linux Enterprise Server ESPOS 15 tomcat Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 tomcat Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 tomcat Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 tomcat Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 tomcat Released
SUSE Linux Enterprise Server for SAP Applications 15 tomcat Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 tomcat Released
SUSE Manager Proxy 4.0 tomcat Released
SUSE Manager Retail Branch Server 4.0 tomcat Released
SUSE Manager Server 4.0 tomcat Released
SUSE OpenStack Cloud 7 tomcat Affected
SUSE OpenStack Cloud 8 tomcat Affected
SUSE OpenStack Cloud 9 tomcat Released
SUSE OpenStack Cloud Crowbar 8 tomcat Affected
SUSE OpenStack Cloud Crowbar 9 tomcat Released