Upstream information

CVE-2021-21241 at MITRE

Description

The Python "Flask-Security-Too" package is used for adding security features to your Flask application. It is an is a independently maintained version of Flask-Security based on the 3.0.0 version of Flask-Security. In Flask-Security-Too from version 3.3.0 and before version 3.4.5, the /login and /change endpoints can return the authenticated user's authentication token in response to a GET request. Since GET requests aren't protected with a CSRF token, this could lead to a malicious 3rd party site acquiring the authentication token. Version 3.4.5 and version 4.0.0 are patched. As a workaround, if you aren't using authentication tokens - you can set the SECURITY_TOKEN_MAX_AGE to "0" (seconds) which should make the token unusable.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.4 7.4
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Changed Changed
Confidentiality Impact High High
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1181058 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 python-Flask-Security Not affected
SUSE Enterprise Storage 6 python-Flask-Security Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS python-Flask-Security Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 python-Flask-Security Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP2 python-Flask-Security-Too Affected
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux python-Flask-Security Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS python-Flask-Security Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 python-Flask-Security Not affected
SUSE Manager Proxy 4.0 python-Flask-Security Not affected
SUSE Manager Retail Branch Server 4.0 python-Flask-Security Not affected
SUSE Manager Server 4.0 python-Flask-Security Not affected