Upstream information

CVE-2020-8903 at MITRE

Description

A vulnerability in Google Cloud Platform's guest-oslogin versions between 20190304 and 20200507 allows a user that is only granted the role "roles/compute.osLogin" to escalate privileges to root. Using their membership to the "adm" group, users with this role are able to read the DHCP XID from the systemd journal. Using the DHCP XID, it is then possible to set the IP address and hostname of the instance to any value, which is then stored in /etc/hosts. An attacker can then point metadata.google.internal to an arbitrary IP address and impersonate the GCE metadata server which make it is possible to instruct the OS Login PAM module to grant administrative privileges. All images created after 2020-May-07 (20200507) are fixed, and if you cannot update, we recommend you edit /etc/group/security.conf and remove the "adm" user from the OS Login entry.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.9
Vector AV:L/AC:M/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 7.8
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1173258 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • google-compute-engine >= 20190801-4.38.1
  • google-compute-engine-oslogin-32bit >= 20190801-4.38.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-1934
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • google-compute-engine >= 20190801-4.38.1
  • google-compute-engine-oslogin-32bit >= 20190801-4.38.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2020-1934
SUSE Linux Enterprise Module for Public Cloud 12
  • google-compute-engine >= 20190801-54.1
  • google-compute-engine-init >= 20190801-54.1
  • google-compute-engine-oslogin >= 20190801-54.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-12-2020-2200
SUSE Linux Enterprise Module for Public Cloud 15 SP1
  • google-compute-engine >= 20190801-4.38.1
  • google-compute-engine-init >= 20190801-4.38.1
  • google-compute-engine-oslogin >= 20190801-4.38.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-15-SP1-2020-1934
SUSE Linux Enterprise Module for Public Cloud 15 SP2
  • google-compute-engine >= 20190801-4.38.1
  • google-compute-engine-init >= 20190801-4.38.1
  • google-compute-engine-oslogin >= 20190801-4.38.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-15-SP2-2020-1934
openSUSE Leap 15.1
  • google-compute-engine >= 20190801-lp151.2.25.1
  • google-compute-engine-debugsource >= 20190801-lp151.2.25.1
  • google-compute-engine-init >= 20190801-lp151.2.25.1
  • google-compute-engine-oslogin >= 20190801-lp151.2.25.1
  • google-compute-engine-oslogin-32bit >= 20190801-lp151.2.25.1
  • google-compute-engine-oslogin-32bit-debuginfo >= 20190801-lp151.2.25.1
  • google-compute-engine-oslogin-debuginfo >= 20190801-lp151.2.25.1
Patchnames:
openSUSE-2020-996
openSUSE Leap 15.2
  • google-compute-engine >= 20190801-lp152.5.4.1
  • google-compute-engine-debugsource >= 20190801-lp152.5.4.1
  • google-compute-engine-init >= 20190801-lp152.5.4.1
  • google-compute-engine-oslogin >= 20190801-lp152.5.4.1
  • google-compute-engine-oslogin-32bit >= 20190801-lp152.5.4.1
  • google-compute-engine-oslogin-32bit-debuginfo >= 20190801-lp152.5.4.1
  • google-compute-engine-oslogin-debuginfo >= 20190801-lp152.5.4.1
Patchnames:
openSUSE-2020-1014

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Module for Public Cloud 15 SP1
  • google-compute-engine >= 20190801-4.38.1
  • google-compute-engine-debugsource >= 20190801-4.38.1
  • google-compute-engine-init >= 20190801-4.38.1
  • google-compute-engine-oslogin >= 20190801-4.38.1
  • google-compute-engine-oslogin-debuginfo >= 20190801-4.38.1
SUSE Linux Enterprise Module for Public Cloud 15 SP2
  • google-compute-engine >= 20190801-4.38.1
  • google-compute-engine-debugsource >= 20190801-4.38.1
  • google-compute-engine-init >= 20190801-4.38.1
  • google-compute-engine-oslogin >= 20190801-4.38.1
  • google-compute-engine-oslogin-debuginfo >= 20190801-4.38.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
Public Cloud Module for SUSE Linux Enterprise 11 google-compute-engine Not affected
SUSE Linux Enterprise 12 Module for Public Cloud google-compute-engine Released
SUSE Linux Enterprise 15 Module for Public Cloud google-compute-engine Affected
SUSE Linux Enterprise 15-SP1 Module for Public Cloud google-compute-engine Released
SUSE Linux Enterprise 15-SP2 Module for Public Cloud google-compute-engine Released