Upstream information

CVE-2020-8177 at MITRE

Description

** RESERVED ** This candidate has been reserved by an organization or individual that will use it when announcing a new security problem. When the candidate has been publicized, the details for this candidate will be provided.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  SUSE
Base Score 8.1
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1173027 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container caasp/v5/389-ds:beta
Container caasp/v5/busybox:beta
Container caasp/v5/caasp-dex:beta
Container caasp/v5/cert-manager-cainjector:beta
Container caasp/v5/cert-manager-controller:beta
Container caasp/v5/cert-manager-webhook:beta
Container caasp/v5/cilium-etcd-operator:beta
Container caasp/v5/cilium-operator:beta
Container caasp/v5/cilium:beta
Container caasp/v5/configmap-reload:beta
Container caasp/v5/coredns:beta
Container caasp/v5/default-http-backend:beta
Container caasp/v5/etcd:beta
Container caasp/v5/gangway:beta
Container caasp/v5/grafana:beta
Container caasp/v5/helm-tiller:beta
Container caasp/v5/k8s-sidecar:beta
Container caasp/v5/kube-apiserver:beta
Container caasp/v5/kube-controller-manager:beta
Container caasp/v5/kube-proxy:beta
Container caasp/v5/kube-scheduler:beta
Container caasp/v5/kube-state-metrics:beta
Container caasp/v5/kubernetes-client:beta
Container caasp/v5/kucero:beta
Container caasp/v5/kured:beta
Container caasp/v5/metrics-server:beta
Container caasp/v5/prometheus-alertmanager:beta
Container caasp/v5/prometheus-node-exporter:beta
Container caasp/v5/prometheus-pushgateway:beta
Container caasp/v5/prometheus-server:beta
Container caasp/v5/reloader:beta
Container caasp/v5/rsyslog:beta
Container caasp/v5/skuba-tooling:beta
Container caasp/v5/velero-plugin-for-aws:beta
Container caasp/v5/velero-plugin-for-gcp:beta
Container caasp/v5/velero-plugin-for-microsoft-azure:beta
Container caasp/v5/velero-restic-restore-helper:beta
Container caasp/v5/velero:beta
Container ingress-nginx-controller:0.15.0
Container suse/sle15:15.2
Image caasp-cert-manager-cainjector-image
Image caasp-cert-manager-controller-image
Image caasp-cert-manager-webhook-image
Image caasp-kube-apiserver-image
Image caasp-kube-controller-manager-image
Image caasp-kube-proxy-image
Image caasp-kube-scheduler-image
Image caasp-kucero-image
Image caasp-reloader-image
Image caasp-skuba-tooling-image
  • libcurl4 >= 7.66.0-4.3.1
Container caasp/v5/curl:beta
Image SLES15-SP2-CHOST-BYOS-Ali
Image SLES15-SP2-CHOST-BYOS-Azure
Image SLES15-SP2-CHOST-BYOS-EC2
Image SLES15-SP2-CHOST-BYOS-GCE
Image SLES15-SP2-CHOST-BYOS-OpenStack
  • curl >= 7.66.0-4.3.1
  • libcurl4 >= 7.66.0-4.3.1
Container suse/sle15:15.0
Container suse/sle15:15.1
Image caasp-389-ds-image
Image caasp-busybox-image
Image caasp-caasp-dex-image
Image caasp-cert-exporter-image
Image caasp-cilium-etcd-operator-image
Image caasp-cilium-image
Image caasp-cilium-init-image
Image caasp-cilium-operator-image
Image caasp-cloud-provider-openstack-image
Image caasp-configmap-reload-image
Image caasp-coredns-image
Image caasp-etcd-image
Image caasp-gangway-image
Image caasp-grafana-image
Image caasp-helm-tiller-image
Image caasp-hyperkube-image
Image caasp-k8s-sidecar-image
Image caasp-kube-state-metrics-image
Image caasp-kubernetes-client-image
Image caasp-kured-image
Image caasp-metrics-server-image
Image caasp-prometheus-alertmanager-image
Image caasp-prometheus-node-exporter-image
Image caasp-prometheus-pushgateway-image
Image caasp-prometheus-server-image
Image caasp-rsyslog-image
Image caasp-test-update-image
Image caasp-velero-image
Image caasp-velero-plugin-for-aws-image
Image caasp-velero-plugin-for-gcp-image
Image caasp-velero-plugin-for-microsoft-azure-image
Image caasp-velero-restic-restore-helper-image
  • libcurl4 >= 7.60.0-3.29.1
Container suse/sles12sp4:latest
  • libcurl4 >= 7.60.0-4.15.2
Container suse/sles12sp5:latest
  • libcurl4 >= 7.60.0-11.3.2
HPE Helion Openstack 8
  • curl >= 7.37.0-37.47.1
  • libcurl4 >= 7.37.0-37.47.1
  • libcurl4-32bit >= 7.37.0-37.47.1
Patchnames:
HPE-Helion-OpenStack-8-2020-1732
Image SLES15-EC2-CHOST-HVM-BYOS
Image SLES15-SP1-CHOST-BYOS-Ali
Image SLES15-SP1-CHOST-BYOS-Azure
Image SLES15-SP1-CHOST-BYOS-EC2
Image SLES15-SP1-CHOST-BYOS-GCE
Image SLES15-SP1-CHOST-BYOS-OpenStack
Image caasp-curl-image
  • curl >= 7.60.0-3.29.1
  • libcurl4 >= 7.60.0-3.29.1
SUSE Enterprise Storage 5
  • curl >= 7.37.0-37.47.1
  • libcurl4 >= 7.37.0-37.47.1
  • libcurl4-32bit >= 7.37.0-37.47.1
Patchnames:
SUSE-Storage-5-2020-1732
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • curl >= 7.60.0-3.29.1
  • libcurl-devel >= 7.60.0-3.29.1
  • libcurl4 >= 7.60.0-3.29.1
  • libcurl4-32bit >= 7.60.0-3.29.1
Patchnames:
SUSE-SLE-Product-HPC-15-2020-1773
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • curl >= 7.60.0-3.29.1
  • libcurl-devel >= 7.60.0-3.29.1
  • libcurl4 >= 7.60.0-3.29.1
  • libcurl4-32bit >= 7.60.0-3.29.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2020-1773
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • curl >= 7.66.0-4.3.1
  • libcurl-devel >= 7.66.0-4.3.1
  • libcurl4 >= 7.66.0-4.3.1
  • libcurl4-32bit >= 7.66.0-4.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2020-1733
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • curl >= 7.60.0-3.29.1
  • curl-mini >= 7.60.0-3.29.1
  • libcurl-devel-32bit >= 7.60.0-3.29.1
  • libcurl-mini-devel >= 7.60.0-3.29.1
  • libcurl4-mini >= 7.60.0-3.29.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-1773
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • curl >= 7.66.0-4.3.1
  • curl-mini >= 7.66.0-4.3.1
  • libcurl-devel-32bit >= 7.66.0-4.3.1
  • libcurl-mini-devel >= 7.66.0-4.3.1
  • libcurl4-mini >= 7.66.0-4.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2020-1733
SUSE Linux Enterprise Point of Sale 11 SP3
  • curl >= 7.37.0-70.47.1
  • libcurl-devel >= 7.37.0-70.47.1
  • libcurl4 >= 7.37.0-70.47.1
Patchnames:
sleposp3-curl-14409
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • curl >= 7.37.0-37.47.1
  • libcurl4 >= 7.37.0-37.47.1
  • libcurl4-32bit >= 7.37.0-37.47.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2020-1732
SUSE Linux Enterprise Server 11 SP4-LTSS
SUSE Linux Enterprise Server for SAP Applications 11 SP4-LTSS
  • curl >= 7.37.0-70.47.1
  • libcurl4 >= 7.37.0-70.47.1
  • libcurl4-32bit >= 7.37.0-70.47.1
Patchnames:
slessp4-curl-14409
SUSE Linux Enterprise Server 11-SECURITY
SUSE Linux Enterprise Server for SAP Applications 11-SECURITY
  • curl-openssl1 >= 7.37.0-70.47.1
  • libcurl4-openssl1 >= 7.37.0-70.47.1
  • libcurl4-openssl1-32bit >= 7.37.0-70.47.1
  • libcurl4-openssl1-x86 >= 7.37.0-70.47.1
Patchnames:
secsp3-curl-14409
SUSE Linux Enterprise Server 12 SP2-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • curl >= 7.37.0-37.47.1
  • libcurl4 >= 7.37.0-37.47.1
  • libcurl4-32bit >= 7.37.0-37.47.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2020-1732
SUSE Linux Enterprise Server 12 SP2-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • curl >= 7.37.0-37.47.1
  • libcurl4 >= 7.37.0-37.47.1
  • libcurl4-32bit >= 7.37.0-37.47.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2020-1732
SUSE Linux Enterprise Server 12 SP2-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • curl >= 7.37.0-37.47.1
  • libcurl4 >= 7.37.0-37.47.1
  • libcurl4-32bit >= 7.37.0-37.47.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2020-1732
SUSE Linux Enterprise Server 12 SP3-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • curl >= 7.37.0-37.47.1
  • libcurl4 >= 7.37.0-37.47.1
  • libcurl4-32bit >= 7.37.0-37.47.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2020-1732
SUSE Linux Enterprise Server 12 SP3-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • curl >= 7.37.0-37.47.1
  • libcurl4 >= 7.37.0-37.47.1
  • libcurl4-32bit >= 7.37.0-37.47.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2020-1732
SUSE Linux Enterprise Server 12 SP3-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • curl >= 7.37.0-37.47.1
  • libcurl4 >= 7.37.0-37.47.1
  • libcurl4-32bit >= 7.37.0-37.47.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2020-1732
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • curl >= 7.60.0-4.15.2
  • libcurl4 >= 7.60.0-4.15.2
  • libcurl4-32bit >= 7.60.0-4.15.2
Patchnames:
SUSE-SLE-SERVER-12-SP4-2020-1735
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • curl >= 7.60.0-11.3.2
  • libcurl4 >= 7.60.0-11.3.2
  • libcurl4-32bit >= 7.60.0-11.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP5-2020-1734
SUSE Linux Enterprise Server 15-LTSS
  • curl >= 7.60.0-3.29.1
  • libcurl-devel >= 7.60.0-3.29.1
  • libcurl4 >= 7.60.0-3.29.1
  • libcurl4-32bit >= 7.60.0-3.29.1
Patchnames:
SUSE-SLE-Product-SLES-15-2020-1773
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • curl >= 7.37.0-37.47.1
  • libcurl4 >= 7.37.0-37.47.1
  • libcurl4-32bit >= 7.37.0-37.47.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2020-1732
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • curl >= 7.37.0-37.47.1
  • libcurl4 >= 7.37.0-37.47.1
  • libcurl4-32bit >= 7.37.0-37.47.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2020-1732
SUSE Linux Enterprise Server for SAP Applications 15
  • curl >= 7.60.0-3.29.1
  • libcurl-devel >= 7.60.0-3.29.1
  • libcurl4 >= 7.60.0-3.29.1
  • libcurl4-32bit >= 7.60.0-3.29.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2020-1773
SUSE Linux Enterprise Software Development Kit 12 SP4
  • curl >= 7.60.0-4.15.2
  • libcurl-devel >= 7.60.0-4.15.2
Patchnames:
SUSE-SLE-SDK-12-SP4-2020-1735
SUSE Linux Enterprise Software Development Kit 12 SP5
  • curl >= 7.60.0-11.3.2
  • libcurl-devel >= 7.60.0-11.3.2
Patchnames:
SUSE-SLE-SDK-12-SP5-2020-1734
SUSE OpenStack Cloud 7
  • curl >= 7.37.0-37.47.1
  • libcurl4 >= 7.37.0-37.47.1
  • libcurl4-32bit >= 7.37.0-37.47.1
Patchnames:
SUSE-OpenStack-Cloud-7-2020-1732
SUSE OpenStack Cloud 8
  • curl >= 7.37.0-37.47.1
  • libcurl4 >= 7.37.0-37.47.1
  • libcurl4-32bit >= 7.37.0-37.47.1
Patchnames:
SUSE-OpenStack-Cloud-8-2020-1732
SUSE OpenStack Cloud Crowbar 8
  • curl >= 7.37.0-37.47.1
  • libcurl4 >= 7.37.0-37.47.1
  • libcurl4-32bit >= 7.37.0-37.47.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2020-1732
openSUSE Leap 15.1
  • curl >= 7.60.0-lp151.5.12.1
  • curl-debuginfo >= 7.60.0-lp151.5.12.1
  • curl-debugsource >= 7.60.0-lp151.5.12.1
  • curl-mini >= 7.60.0-lp151.5.12.1
  • curl-mini-debuginfo >= 7.60.0-lp151.5.12.1
  • curl-mini-debugsource >= 7.60.0-lp151.5.12.1
  • libcurl-devel >= 7.60.0-lp151.5.12.1
  • libcurl-devel-32bit >= 7.60.0-lp151.5.12.1
  • libcurl-mini-devel >= 7.60.0-lp151.5.12.1
  • libcurl4 >= 7.60.0-lp151.5.12.1
  • libcurl4-32bit >= 7.60.0-lp151.5.12.1
  • libcurl4-32bit-debuginfo >= 7.60.0-lp151.5.12.1
  • libcurl4-debuginfo >= 7.60.0-lp151.5.12.1
  • libcurl4-mini >= 7.60.0-lp151.5.12.1
  • libcurl4-mini-debuginfo >= 7.60.0-lp151.5.12.1
Patchnames:
openSUSE-2020-908
openSUSE Leap 15.2
  • curl >= 7.66.0-lp152.3.3.1
  • curl-debuginfo >= 7.66.0-lp152.3.3.1
  • curl-debugsource >= 7.66.0-lp152.3.3.1
  • curl-mini >= 7.66.0-lp152.3.3.1
  • curl-mini-debuginfo >= 7.66.0-lp152.3.3.1
  • curl-mini-debugsource >= 7.66.0-lp152.3.3.1
  • libcurl-devel >= 7.66.0-lp152.3.3.1
  • libcurl-devel-32bit >= 7.66.0-lp152.3.3.1
  • libcurl-mini-devel >= 7.66.0-lp152.3.3.1
  • libcurl4 >= 7.66.0-lp152.3.3.1
  • libcurl4-32bit >= 7.66.0-lp152.3.3.1
  • libcurl4-32bit-debuginfo >= 7.66.0-lp152.3.3.1
  • libcurl4-debuginfo >= 7.66.0-lp152.3.3.1
  • libcurl4-mini >= 7.66.0-lp152.3.3.1
  • libcurl4-mini-debuginfo >= 7.66.0-lp152.3.3.1
Patchnames:
openSUSE-2020-883


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 curl Affected
CaaS Platform 2.0 curl Affected
CaaS Platform 3.0 curl Affected
SUSE Business Critical Linux 12 SP2 curl Released
SUSE Business Critical Linux 12 SP3 curl Released
SUSE Linux Enterprise High Performance Computing 12 curl Released
SUSE Linux Enterprise High Performance Computing ESPOS 15 GA curl Released
SUSE Linux Enterprise High Performance Computing LTSS 15 GA curl Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 curl Released
SUSE Linux Enterprise Module for Basesystem 15 SP2 curl Released
SUSE Linux Enterprise SDK 12 SP4 curl Released
SUSE Linux Enterprise SDK 12 SP5 curl Released
SUSE Linux Enterprise Server 11 SP4 LTSS curl Released
SUSE Linux Enterprise Server 12 SP2 LTSS curl Released
SUSE Linux Enterprise Server 12 SP3 LTSS curl Released
SUSE Linux Enterprise Server 12 SP4 curl Released
SUSE Linux Enterprise Server 12 SP5 curl Released
SUSE Linux Enterprise Server 15 GA LTSS curl Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 curl Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 curl Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 curl Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 curl Released