Upstream information

CVE-2020-7216 at MITRE

Description

An ni_dhcp4_parse_response memory leak in openSUSE wicked 0.6.55 and earlier allows network attackers to cause a denial of service by sending DHCP4 packets without a message type option.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.3
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1160905 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • wicked >= 0.6.60-38.27.1
  • wicked-service >= 0.6.60-38.27.1
Patchnames:
HPE-Helion-OpenStack-8-2020-410
Image SLES15-EC2-CHOST-HVM-BYOS
  • wicked >= 0.6.60-3.21.1
  • wicked-service >= 0.6.60-3.21.1
Image SLES15-SP1-CHOST-BYOS-Ali
Image SLES15-SP1-CHOST-BYOS-Azure
Image SLES15-SP1-CHOST-BYOS-EC2
Image SLES15-SP1-CHOST-BYOS-GCE
Image SLES15-SP1-CHOST-BYOS-OpenStack
Image caasp-rsyslog-image
  • wicked >= 0.6.60-3.10.1
  • wicked-service >= 0.6.60-3.10.1
SUSE CaaS Platform 3.0
  • wicked >= 0.6.60-38.27.1
  • wicked-service >= 0.6.60-38.27.1
Patchnames:
SUSE-CAASP-3.0-2020-410
SUSE Enterprise Storage 5
  • wicked >= 0.6.60-38.27.1
  • wicked-service >= 0.6.60-38.27.1
Patchnames:
SUSE-Storage-5-2020-410
SUSE Linux Enterprise Desktop 12 SP4
  • wicked >= 0.6.60-2.18.1
  • wicked-service >= 0.6.60-2.18.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2020-369
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • wicked >= 0.6.60-3.21.1
  • wicked-service >= 0.6.60-3.21.1
Patchnames:
SUSE-SLE-Product-HPC-15-2020-263
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • wicked >= 0.6.60-3.10.1
  • wicked-service >= 0.6.60-3.10.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2020-264
SUSE Linux Enterprise Module for Basesystem 15
  • wicked >= 0.6.60-3.21.1
  • wicked-service >= 0.6.60-3.21.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2020-263
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • wicked >= 0.6.60-38.27.1
  • wicked-service >= 0.6.60-38.27.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2020-410
SUSE Linux Enterprise Server 12 SP1-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • wicked >= 0.6.60-28.26.1
  • wicked-service >= 0.6.60-28.26.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2020-358
SUSE Linux Enterprise Server 12 SP2-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • wicked >= 0.6.60-38.27.1
  • wicked-service >= 0.6.60-38.27.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2020-410
SUSE Linux Enterprise Server 12 SP2-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • wicked >= 0.6.60-38.27.1
  • wicked-service >= 0.6.60-38.27.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2020-410
SUSE Linux Enterprise Server 12 SP2-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • wicked >= 0.6.60-38.27.1
  • wicked-service >= 0.6.60-38.27.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2020-410
SUSE Linux Enterprise Server 12 SP3-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • wicked >= 0.6.60-38.27.1
  • wicked-service >= 0.6.60-38.27.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2020-410
SUSE Linux Enterprise Server 12 SP3-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • wicked >= 0.6.60-38.27.1
  • wicked-service >= 0.6.60-38.27.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2020-410
SUSE Linux Enterprise Server 12 SP3-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • wicked >= 0.6.60-38.27.1
  • wicked-service >= 0.6.60-38.27.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2020-410
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • wicked >= 0.6.60-2.18.1
  • wicked-service >= 0.6.60-2.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2020-369
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • wicked >= 0.6.60-3.5.1
  • wicked-service >= 0.6.60-3.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2020-351
SUSE Linux Enterprise Server 15-LTSS
  • wicked >= 0.6.60-3.21.1
  • wicked-service >= 0.6.60-3.21.1
Patchnames:
SUSE-SLE-Product-SLES-15-2020-263
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • wicked >= 0.6.60-28.26.1
  • wicked-service >= 0.6.60-28.26.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2020-358
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • wicked >= 0.6.60-38.27.1
  • wicked-service >= 0.6.60-38.27.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2020-410
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • wicked >= 0.6.60-38.27.1
  • wicked-service >= 0.6.60-38.27.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2020-410
SUSE Linux Enterprise Server for SAP Applications 15
  • wicked >= 0.6.60-3.21.1
  • wicked-service >= 0.6.60-3.21.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2020-263
SUSE OpenStack Cloud 7
  • wicked >= 0.6.60-38.27.1
  • wicked-service >= 0.6.60-38.27.1
Patchnames:
SUSE-OpenStack-Cloud-7-2020-410
SUSE OpenStack Cloud 8
  • wicked >= 0.6.60-38.27.1
  • wicked-service >= 0.6.60-38.27.1
Patchnames:
SUSE-OpenStack-Cloud-8-2020-410
SUSE OpenStack Cloud Crowbar 8
  • wicked >= 0.6.60-38.27.1
  • wicked-service >= 0.6.60-38.27.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2020-410
openSUSE Leap 15.1
  • wicked >= 0.6.60-lp151.2.6.1
  • wicked-debuginfo >= 0.6.60-lp151.2.6.1
  • wicked-debugsource >= 0.6.60-lp151.2.6.1
  • wicked-service >= 0.6.60-lp151.2.6.1
Patchnames:
openSUSE-2020-165


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 3.0 wicked Released
SUSE Container as a Service Platform 1.0 wicked Affected
SUSE Container as a Service Platform 2.0 wicked Affected
SUSE Linux Enterprise 15 Module for Basesystem wicked Released
SUSE Linux Enterprise 15-SP1 Module for Basesystem wicked Released
SUSE Linux Enterprise High Performance Computing 12 SP4 wicked Released
SUSE Linux Enterprise High Performance Computing 12 SP5 wicked Already fixed
SUSE Linux Enterprise Server 12 SP1 LTSS wicked Released
SUSE Linux Enterprise Server 12 SP2 LTSS wicked Released
SUSE Linux Enterprise Server 12 SP3 LTSS wicked Released
SUSE Linux Enterprise Server 12 SP4 wicked Released
SUSE Linux Enterprise Server 12 SP5 wicked Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP2 wicked Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 wicked Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 wicked Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 wicked Already fixed