Upstream information

CVE-2020-7067 at MITRE

Description

In PHP versions 7.2.x below 7.2.30, 7.3.x below 7.3.17 and 7.4.x below 7.4.5, if PHP is compiled with EBCDIC support (uncommon), urldecode() function can be made to access locations past the allocated memory, due to erroneously using signed numbers as array indexes.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 4.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact None None
Availability Impact None Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1169676 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Performance Computing ESPOS 15 GA php7 Not affected
SUSE Linux Enterprise High Performance Computing LTSS 15 GA php7 Not affected
SUSE Linux Enterprise Module for Web and Scripting 12 php5 Not affected
SUSE Linux Enterprise Module for Web and Scripting 12 php7 Not affected
SUSE Linux Enterprise Module for Web and Scripting 12 php72 Not affected
SUSE Linux Enterprise Module for Web and Scripting 15 php7 Not affected
SUSE Linux Enterprise SDK 11 GA php5 Not affected
SUSE Linux Enterprise SDK 11 SP1 php5 Not affected
SUSE Linux Enterprise SDK 11 SP2 php5 Not affected
SUSE Linux Enterprise SDK 11 SP2 php53 Unsupported
SUSE Linux Enterprise SDK 11 SP3 php53 Not affected
SUSE Linux Enterprise SDK 11 SP4 php53 Not affected
SUSE Linux Enterprise SDK 12 GA php5 Not affected
SUSE Linux Enterprise SDK 12 GA php7 Not affected
SUSE Linux Enterprise SDK 12 SP1 php5 Not affected
SUSE Linux Enterprise SDK 12 SP1 php7 Not affected
SUSE Linux Enterprise SDK 12 SP2 php5 Not affected
SUSE Linux Enterprise SDK 12 SP2 php7 Not affected
SUSE Linux Enterprise SDK 12 SP3 php5 Not affected
SUSE Linux Enterprise SDK 12 SP3 php7 Not affected
SUSE Linux Enterprise SDK 12 SP3 php72 Not affected
SUSE Linux Enterprise SDK 12 SP4 php5 Not affected
SUSE Linux Enterprise SDK 12 SP4 php7 Not affected
SUSE Linux Enterprise SDK 12 SP4 php72 Not affected
SUSE Linux Enterprise SDK 12 SP5 php7 Not affected
SUSE Linux Enterprise SDK 12 SP5 php72 Not affected
SUSE Linux Enterprise Server 10 SP3 php5 Not affected
SUSE Linux Enterprise Server 10 SP4 php5 Not affected
SUSE Linux Enterprise Server 10 SP4 LTSS php5 Not affected
SUSE Linux Enterprise Server 11 SP1 php5 Not affected
SUSE Linux Enterprise Server 11 SP1 LTSS php5 Not affected
SUSE Linux Enterprise Server 11 SP2 php5 Not affected
SUSE Linux Enterprise Server 11 SP2 php53 Unsupported
SUSE Linux Enterprise Server 11 SP2 LTSS php5 Not affected
SUSE Linux Enterprise Server 11 SP2 LTSS php53 Unsupported
SUSE Linux Enterprise Server 11 SP3 php53 Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS php53 Not affected
SUSE Linux Enterprise Server 11 SP4 php53 Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS php53 Not affected
SUSE Linux Enterprise Server 15 GA LTSS php7 Not affected
SUSE Linux Enterprise Server for SAP AIO 11 SP1 php5 Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP2 php5 Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP2 php53 Unsupported
SUSE Linux Enterprise Server for SAP Applications 11 SP3 php53 Not affected
SUSE Linux Enterprise Server for SAP ES 11 SP1 php5 Not affected
SUSE Linux Enterprise Server for VMWare 11 SP2 php5 Not affected
SUSE Linux Enterprise Server for VMWare 11 SP2 php53 Unsupported
SUSE Linux Enterprise Server for VMWare 11 SP3 php53 Not affected