Upstream information

CVE-2020-7039 at MITRE

Description

tcp_emu in tcp_subr.c in libslirp 4.1.0, as used in QEMU 4.2.0, mismanages memory, as demonstrated by IRC DCC commands in EMU_IRC. This can cause a heap-based buffer overflow or other out-of-bounds access which can lead to a DoS or potential execute arbitrary code.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1161066 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • qemu >= 3.1.1.1-9.14.1
  • qemu-tools >= 3.1.1.1-9.14.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2020-844
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • qemu >= 3.1.1.1-9.14.1
  • qemu-arm >= 3.1.1.1-9.14.1
  • qemu-audio-alsa >= 3.1.1.1-9.14.1
  • qemu-audio-oss >= 3.1.1.1-9.14.1
  • qemu-audio-pa >= 3.1.1.1-9.14.1
  • qemu-block-dmg >= 3.1.1.1-9.14.1
  • qemu-extra >= 3.1.1.1-9.14.1
  • qemu-linux-user >= 3.1.1.1-9.14.1
  • qemu-ppc >= 3.1.1.1-9.14.1
  • qemu-s390 >= 3.1.1.1-9.14.1
  • qemu-seabios >= 1.12.0-9.14.1
  • qemu-sgabios >= 8-9.14.1
  • qemu-testsuite >= 3.1.1.1-9.14.2
  • qemu-ui-curses >= 3.1.1.1-9.14.1
  • qemu-ui-gtk >= 3.1.1.1-9.14.1
  • qemu-x86 >= 3.1.1.1-9.14.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-844
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • qemu >= 3.1.1.1-9.14.1
  • qemu-arm >= 3.1.1.1-9.14.1
  • qemu-audio-alsa >= 3.1.1.1-9.14.1
  • qemu-audio-oss >= 3.1.1.1-9.14.1
  • qemu-audio-pa >= 3.1.1.1-9.14.1
  • qemu-block-curl >= 3.1.1.1-9.14.1
  • qemu-block-iscsi >= 3.1.1.1-9.14.1
  • qemu-block-rbd >= 3.1.1.1-9.14.1
  • qemu-block-ssh >= 3.1.1.1-9.14.1
  • qemu-guest-agent >= 3.1.1.1-9.14.1
  • qemu-ipxe >= 1.0.0+-9.14.1
  • qemu-kvm >= 3.1.1.1-9.14.1
  • qemu-lang >= 3.1.1.1-9.14.1
  • qemu-ppc >= 3.1.1.1-9.14.1
  • qemu-s390 >= 3.1.1.1-9.14.1
  • qemu-seabios >= 1.12.0-9.14.1
  • qemu-sgabios >= 8-9.14.1
  • qemu-ui-curses >= 3.1.1.1-9.14.1
  • qemu-ui-gtk >= 3.1.1.1-9.14.1
  • qemu-vgabios >= 1.12.0-9.14.1
  • qemu-x86 >= 3.1.1.1-9.14.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP1-2020-844
SUSE Linux Enterprise Server 12 SP5
  • qemu >= 3.1.1.1-3.9.1
  • qemu-arm >= 3.1.1.1-3.9.1
  • qemu-audio-alsa >= 3.1.1.1-3.9.1
  • qemu-audio-oss >= 3.1.1.1-3.9.1
  • qemu-audio-pa >= 3.1.1.1-3.9.1
  • qemu-audio-sdl >= 3.1.1.1-3.9.1
  • qemu-block-curl >= 3.1.1.1-3.9.1
  • qemu-block-iscsi >= 3.1.1.1-3.9.1
  • qemu-block-rbd >= 3.1.1.1-3.9.1
  • qemu-block-ssh >= 3.1.1.1-3.9.1
  • qemu-guest-agent >= 3.1.1.1-3.9.1
  • qemu-ipxe >= 1.0.0+-3.9.1
  • qemu-kvm >= 3.1.1.1-3.9.1
  • qemu-lang >= 3.1.1.1-3.9.1
  • qemu-ppc >= 3.1.1.1-3.9.1
  • qemu-s390 >= 3.1.1.1-3.9.1
  • qemu-seabios >= 1.12.0-3.9.1
  • qemu-sgabios >= 8-3.9.1
  • qemu-tools >= 3.1.1.1-3.9.1
  • qemu-ui-curses >= 3.1.1.1-3.9.1
  • qemu-ui-gtk >= 3.1.1.1-3.9.1
  • qemu-ui-sdl >= 3.1.1.1-3.9.1
  • qemu-vgabios >= 1.12.0-3.9.1
  • qemu-x86 >= 3.1.1.1-3.9.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2020-845
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • qemu >= 3.1.1.1-3.9.1
  • qemu-arm >= 3.1.1.1-3.9.1
  • qemu-audio-alsa >= 3.1.1.1-3.9.1
  • qemu-audio-oss >= 3.1.1.1-3.9.1
  • qemu-audio-pa >= 3.1.1.1-3.9.1
  • qemu-audio-sdl >= 3.1.1.1-3.9.1
  • qemu-block-curl >= 3.1.1.1-3.9.1
  • qemu-block-iscsi >= 3.1.1.1-3.9.1
  • qemu-block-rbd >= 3.1.1.1-3.9.1
  • qemu-block-ssh >= 3.1.1.1-3.9.1
  • qemu-guest-agent >= 3.1.1.1-3.9.1
  • qemu-ipxe >= 1.0.0+-3.9.1
  • qemu-kvm >= 3.1.1.1-3.9.1
  • qemu-lang >= 3.1.1.1-3.9.1
  • qemu-ppc >= 3.1.1.1-3.9.1
  • qemu-s390 >= 3.1.1.1-3.9.1
  • qemu-seabios >= 1.12.0-3.9.1
  • qemu-sgabios >= 8-3.9.1
  • qemu-tools >= 3.1.1.1-3.9.1
  • qemu-ui-curses >= 3.1.1.1-3.9.1
  • qemu-ui-gtk >= 3.1.1.1-3.9.1
  • qemu-ui-sdl >= 3.1.1.1-3.9.1
  • qemu-vgabios >= 1.12.0-3.9.1
  • qemu-x86 >= 3.1.1.1-3.9.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2020-845


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 qemu Unsupported
CaaS Platform 2.0 qemu Unsupported
CaaS Platform 3.0 qemu Affected
SUSE Business Critical Linux 12 SP2 qemu Affected
SUSE Linux Enterprise Desktop 11 GA kvm Unsupported
SUSE Linux Enterprise Desktop 11 SP1 kvm Affected
SUSE Linux Enterprise Desktop 11 SP2 kvm Unsupported
SUSE Linux Enterprise Desktop 11 SP3 kvm Affected
SUSE Linux Enterprise Desktop 11 SP4 kvm Affected
SUSE Linux Enterprise Desktop 12 GA qemu Unsupported
SUSE Linux Enterprise Desktop 12 SP1 qemu Affected
SUSE Linux Enterprise Desktop 12 SP2 qemu Affected
SUSE Linux Enterprise Desktop 12 SP3 qemu Affected
SUSE Linux Enterprise Desktop 12 SP4 qemu Affected
SUSE Linux Enterprise High Performance Computing 12 qemu Unsupported
SUSE Linux Enterprise Module for Basesystem 15 GA qemu Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 qemu Released
SUSE Linux Enterprise Module for Server Applications 15 GA qemu Affected
SUSE Linux Enterprise Module for Server Applications 15 SP1 qemu Released
SUSE Linux Enterprise Point of Sale 11 SP2 qemu Unsupported
SUSE Linux Enterprise Point of Sale 11 SP3 qemu Affected
SUSE Linux Enterprise SDK 11 GA qemu Affected
SUSE Linux Enterprise SDK 11 SP1 qemu Affected
SUSE Linux Enterprise SDK 11 SP2 qemu Affected
SUSE Linux Enterprise SDK 11 SP3 qemu Affected
SUSE Linux Enterprise SDK 11 SP4 qemu Affected
SUSE Linux Enterprise Server 11 GA kvm Unsupported
SUSE Linux Enterprise Server 11 SP1 kvm Affected
SUSE Linux Enterprise Server 11 SP1 LTSS kvm Affected
SUSE Linux Enterprise Server 11 SP2 kvm Unsupported
SUSE Linux Enterprise Server 11 SP2 LTSS kvm Unsupported
SUSE Linux Enterprise Server 11 SP3 kvm Affected
SUSE Linux Enterprise Server 11 SP3 LTSS kvm Affected
SUSE Linux Enterprise Server 11 SP4 kvm Affected
SUSE Linux Enterprise Server 11 SP4 LTSS kvm Affected
SUSE Linux Enterprise Server 12 GA qemu Unsupported
SUSE Linux Enterprise Server 12 GA LTSS qemu Unsupported
SUSE Linux Enterprise Server 12 SP1 qemu Affected
SUSE Linux Enterprise Server 12 SP1 LTSS qemu Affected
SUSE Linux Enterprise Server 12 SP2 qemu Affected
SUSE Linux Enterprise Server 12 SP2 LTSS qemu Affected
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI qemu Affected
SUSE Linux Enterprise Server 12 SP3 qemu Affected
SUSE Linux Enterprise Server 12 SP3 LTSS qemu Affected
SUSE Linux Enterprise Server 12 SP4 qemu Affected
SUSE Linux Enterprise Server 12 SP5 qemu Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 kvm Unsupported
SUSE Linux Enterprise Server for SAP Applications 11 SP2 kvm Unsupported
SUSE Linux Enterprise Server for SAP Applications 11 SP3 kvm Affected
SUSE Linux Enterprise Server for SAP Applications 12 GA qemu Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP2 qemu Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 qemu Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 qemu Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 qemu Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 kvm Unsupported
SUSE Studio Onsite 1.3 qemu Affected
SUSE Studio Onsite Runner 1 kvm Affected
openSUSE 11.4 kvm Unsupported