Upstream information

CVE-2020-5267 at MITRE

Description

In ActionView before versions 6.0.2.2 and 5.2.4.2, there is a possible XSS vulnerability in ActionView's JavaScript literal escape helpers. Views that use the `j` or `escape_javascript` methods may be susceptible to XSS attacks. The issue is fixed in versions 6.0.2.2 and 5.2.4.2.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 3.5
Vector AV:N/AC:M/Au:S/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication Single
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 4.8 4.8
Vector CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Access Vector Network Network
Access Complexity Low Low
Privileges Required High High
User Interaction Required Required
Scope Changed Changed
Confidentiality Impact Low Low
Integrity Impact Low Low
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1167240 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Availability 15 SP1
  • ruby2.5-rubygem-actionview-5_1 >= 5.1.4-3.3.1
  • rubygem-actionview-5_1 >= 5.1.4-3.3.1
Patchnames:
SUSE-SLE-Product-HA-15-SP1-2020-1178
SUSE Linux Enterprise High Availability 15
  • ruby2.5-rubygem-actionview-5_1 >= 5.1.4-3.3.1
  • rubygem-actionview-5_1 >= 5.1.4-3.3.1
Patchnames:
SUSE-SLE-Product-HA-15-2020-1178
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • ruby2.5-rubygem-actionview-doc-5_1 >= 5.1.4-3.3.1
  • rubygem-actionview-5_1 >= 5.1.4-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-1178
SUSE OpenStack Cloud 7
  • ruby2.1-rubygem-actionview-4_2 >= 4.2.9-9.6.1
  • rubygem-actionview-4_2 >= 4.2.9-9.6.1
Patchnames:
SUSE-OpenStack-Cloud-7-2020-954
SUSE OpenStack Cloud Crowbar 8
  • ruby2.1-rubygem-actionview-4_2 >= 4.2.9-9.6.1
  • rubygem-actionview-4_2 >= 4.2.9-9.6.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2020-954
SUSE OpenStack Cloud Crowbar 9
  • ruby2.1-rubygem-actionview-4_2 >= 4.2.9-9.6.1
  • rubygem-actionview-4_2 >= 4.2.9-9.6.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2020-954
openSUSE Leap 15.1
  • ruby2.5-rubygem-actionview-5_1 >= 5.1.4-lp151.3.3.1
  • ruby2.5-rubygem-actionview-doc-5_1 >= 5.1.4-lp151.3.3.1
  • rubygem-actionview-5_1 >= 5.1.4-lp151.3.3.1
Patchnames:
openSUSE-2020-627


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Availability 15 GA rubygem-actionview-5_1 Released
SUSE Linux Enterprise High Availability 15 SP1 rubygem-actionview-5_1 Released
SUSE Openstack Cloud 6 rubygem-actionview-4_2 Already fixed
SUSE Openstack Cloud 7 rubygem-actionview-4_2 Already fixed
SUSE Openstack Cloud 8 rubygem-actionview-4_2 Already fixed
SUSE Openstack Cloud 9 rubygem-actionview-4_2 Already fixed