Upstream information

CVE-2020-26217 at MITRE

Description

XStream before version 1.4.14 is vulnerable to Remote Code Execution.The vulnerability may allow a remote attacker to run arbitrary shell commands only by manipulating the processed input stream. Only users who rely on blocklists are affected. Anyone using XStream's Security Framework allowlist is not affected. The linked advisory provides code workarounds for users who cannot upgrade. The issue is fixed in version 1.4.14.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 8.1
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity Low High
Privileges Required Low None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1180994 [CONFIRMED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Development Tools 15 SP2
  • xstream >= 1.4.15-3.3.2
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP2-2021-176
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • xstream-benchmark >= 1.4.15-3.3.2
  • xstream-javadoc >= 1.4.15-3.3.2
  • xstream-parent >= 1.4.15-3.3.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2021-176
SUSE Linux Enterprise Module for SUSE Manager Server 4.1
  • cobbler >= 3.0.0+git20190806.32c4bae0-5.6.4
  • grafana-formula >= 0.4.0-3.6.2
  • mgr-libmod >= 4.1.7-3.16.2
  • mgr-osa-dispatcher >= 4.1.5-2.9.4
  • prometheus-exporters-formula >= 0.9.0-3.19.2
  • prometheus-formula >= 0.3.1-3.6.2
  • py26-compat-salt >= 2016.11.10-6.11.2
  • python3-mgr-osa-common >= 4.1.5-2.9.4
  • python3-mgr-osa-dispatcher >= 4.1.5-2.9.4
  • python3-rhnlib >= 4.1.3-4.3.2
  • python3-spacewalk-client-tools >= 4.1.9-4.12.4
  • smdba >= 1.7.8-0.3.6.2
  • spacewalk-backend >= 4.1.21-4.22.7
  • spacewalk-backend-app >= 4.1.21-4.22.7
  • spacewalk-backend-applet >= 4.1.21-4.22.7
  • spacewalk-backend-config-files >= 4.1.21-4.22.7
  • spacewalk-backend-config-files-common >= 4.1.21-4.22.7
  • spacewalk-backend-config-files-tool >= 4.1.21-4.22.7
  • spacewalk-backend-iss >= 4.1.21-4.22.7
  • spacewalk-backend-iss-export >= 4.1.21-4.22.7
  • spacewalk-backend-package-push-server >= 4.1.21-4.22.7
  • spacewalk-backend-server >= 4.1.21-4.22.7
  • spacewalk-backend-sql >= 4.1.21-4.22.7
  • spacewalk-backend-sql-postgresql >= 4.1.21-4.22.7
  • spacewalk-backend-tools >= 4.1.21-4.22.7
  • spacewalk-backend-xml-export-libs >= 4.1.21-4.22.7
  • spacewalk-backend-xmlrpc >= 4.1.21-4.22.7
  • spacewalk-base >= 4.1.23-3.18.6
  • spacewalk-base-minimal >= 4.1.23-3.18.6
  • spacewalk-base-minimal-config >= 4.1.23-3.18.6
  • spacewalk-client-tools >= 4.1.9-4.12.4
  • spacewalk-config >= 4.1.5-3.3.2
  • spacewalk-html >= 4.1.23-3.18.6
  • spacewalk-java >= 4.1.30-3.31.7
  • spacewalk-java-config >= 4.1.30-3.31.7
  • spacewalk-java-lib >= 4.1.30-3.31.7
  • spacewalk-java-postgresql >= 4.1.30-3.31.7
  • spacewalk-taskomatic >= 4.1.30-3.31.7
  • spacewalk-utils >= 4.1.14-3.12.2
  • spacewalk-utils-extras >= 4.1.14-3.12.2
  • subscription-matcher >= 0.26-3.6.2
  • susemanager >= 4.1.24-3.20.2
  • susemanager-doc-indexes >= 4.1-11.28.4
  • susemanager-docs_en >= 4.1-11.28.2
  • susemanager-docs_en-pdf >= 4.1-11.28.2
  • susemanager-schema >= 4.1.19-3.24.4
  • susemanager-sls >= 4.1.21-3.26.2
  • susemanager-tools >= 4.1.24-3.20.2
  • susemanager-web-libs >= 4.1.23-3.18.6
  • uyuni-config-modules >= 4.1.21-3.26.2
  • xpp3 >= 1.1.4c-11.2.2
  • xpp3-minimal >= 1.1.4c-11.2.2
  • xstream >= 1.4.15-3.5.2
Patchnames:
SUSE-SLE-Module-SUSE-Manager-Server-4.1-2021-906
openSUSE Leap 15.2
  • xstream >= 1.4.15-lp152.2.3.1
  • xstream-benchmark >= 1.4.15-lp152.2.3.1
  • xstream-javadoc >= 1.4.15-lp152.2.3.1
  • xstream-parent >= 1.4.15-lp152.2.3.1
Patchnames:
openSUSE-2021-140


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Development Tools 15 SP2 xstream Released
SUSE Manager Server 4.0 Module xstream Affected
SUSE Manager Server 4.1 release-notes-susemanager Released
SUSE Manager Server 4.1 Module xstream Released