DescriptionXStream before version 1.4.14 is vulnerable to Remote Code Execution.The vulnerability may allow a remote attacker to run arbitrary shell commands only by manipulating the processed input stream. Only users who rely on blocklists are affected. Anyone using XStream's Security Framework allowlist is not affected. The linked advisory provides code workarounds for users who cannot upgrade. The issue is fixed in version 1.4.14.
Overall state of this security issue: Running
This issue is currently rated as having important severity.
|National Vulnerability Database|
|National Vulnerability Database||SUSE|
- SUSE-SU-2021:0176-1, published Wed Jan 20 07:17:27 MST 2021
- openSUSE-SU-2021:0140-1, published Tue Feb 16 10:27:50 2021
List of released packages
|Product(s)||Fixed package version(s)||References|
|SUSE Linux Enterprise Module for Development Tools 15 SP2|| ||Patchnames:
|SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2|| ||Patchnames:
|openSUSE Leap 15.2|| ||Patchnames:
Status of this issue by product and package
Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.
|SUSE Linux Enterprise 15-SP2 Module for Development Tools||xstream||Released|
|SUSE Manager Server 4.0 Module||xstream||Affected|
|SUSE Manager Server 4.1 Module||xstream||Affected|