Upstream information

CVE-2020-25708 at MITRE

Description

A divide by zero issue was found to occur in libvncserver-0.9.12. A malicious client could use this flaw to send a specially crafted message that, when processed by the VNC server, would lead to a floating point exception, resulting in a denial of service.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entries: 1178682 [RESOLVED / FIXED], 1183902 [NEW], 1183903 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • libvncclient0 >= 0.9.9-17.34.1
  • libvncserver0 >= 0.9.9-17.34.1
Patchnames:
HPE-Helion-OpenStack-8-2020-3550
SUSE Enterprise Storage 5
  • libvncclient0 >= 0.9.9-17.34.1
  • libvncserver0 >= 0.9.9-17.34.1
Patchnames:
SUSE-Storage-5-2020-3550
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • LibVNCServer-devel >= 0.9.10-4.25.1
  • libvncserver0 >= 0.9.10-4.25.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-3515
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • LibVNCServer-devel >= 0.9.10-4.25.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2020-3515
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP1
  • libvncserver0 >= 0.9.10-4.25.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP1-2020-3515
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP2
  • libvncserver0 >= 0.9.10-4.25.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP2-2020-3515
SUSE Linux Enterprise Point of Sale 11 SP3
  • LibVNCServer >= 0.9.1-160.22.1
Patchnames:
sleposp3-LibVNCServer-14549
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • libvncclient0 >= 0.9.9-17.34.1
  • libvncserver0 >= 0.9.9-17.34.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2020-3550
SUSE Linux Enterprise Server 11 SP4-LTSS
SUSE Linux Enterprise Server for SAP Applications 11 SP4-LTSS
  • LibVNCServer >= 0.9.1-160.22.1
Patchnames:
slessp4-LibVNCServer-14549
SUSE Linux Enterprise Server 12 SP2-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • libvncclient0 >= 0.9.9-17.34.1
  • libvncserver0 >= 0.9.9-17.34.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2020-3550
SUSE Linux Enterprise Server 12 SP2-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • libvncclient0 >= 0.9.9-17.34.1
  • libvncserver0 >= 0.9.9-17.34.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2020-3550
SUSE Linux Enterprise Server 12 SP2-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • libvncclient0 >= 0.9.9-17.34.1
  • libvncserver0 >= 0.9.9-17.34.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2020-3550
SUSE Linux Enterprise Server 12 SP3-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • libvncclient0 >= 0.9.9-17.34.1
  • libvncserver0 >= 0.9.9-17.34.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2020-3550
SUSE Linux Enterprise Server 12 SP3-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • libvncclient0 >= 0.9.9-17.34.1
  • libvncserver0 >= 0.9.9-17.34.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2020-3550
SUSE Linux Enterprise Server 12 SP3-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • libvncclient0 >= 0.9.9-17.34.1
  • libvncserver0 >= 0.9.9-17.34.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2020-3550
SUSE Linux Enterprise Server 12 SP4-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP4-ESPOS
  • libvncclient0 >= 0.9.9-17.34.1
  • libvncserver0 >= 0.9.9-17.34.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-ESPOS-2020-3550
SUSE Linux Enterprise Server 12 SP4-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP4-LTSS
  • libvncclient0 >= 0.9.9-17.34.1
  • libvncserver0 >= 0.9.9-17.34.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-LTSS-2020-3550
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libvncclient0 >= 0.9.9-17.34.1
  • libvncserver0 >= 0.9.9-17.34.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2020-3550
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libvncclient0 >= 0.9.9-17.34.1
  • libvncserver0 >= 0.9.9-17.34.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2020-3550
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libvncclient0 >= 0.9.9-17.34.1
  • libvncserver0 >= 0.9.9-17.34.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2020-3550
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libvncclient0 >= 0.9.9-17.34.1
  • libvncserver0 >= 0.9.9-17.34.1
Patchnames:
SUSE-SLE-SAP-12-SP4-2020-3550
SUSE Linux Enterprise Software Development Kit 12 SP5
  • LibVNCServer-devel >= 0.9.9-17.34.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2020-3550
SUSE Linux Enterprise Workstation Extension 15 SP1
  • libvncclient0 >= 0.9.10-4.25.1
Patchnames:
SUSE-SLE-Product-WE-15-SP1-2020-3515
SUSE Linux Enterprise Workstation Extension 15 SP2
  • libvncclient0 >= 0.9.10-4.25.1
  • libvncserver0 >= 0.9.10-4.25.1
Patchnames:
SUSE-SLE-Product-WE-15-SP2-2020-3515
SUSE OpenStack Cloud 7
  • libvncclient0 >= 0.9.9-17.34.1
  • libvncserver0 >= 0.9.9-17.34.1
Patchnames:
SUSE-OpenStack-Cloud-7-2020-3550
SUSE OpenStack Cloud 8
  • libvncclient0 >= 0.9.9-17.34.1
  • libvncserver0 >= 0.9.9-17.34.1
Patchnames:
SUSE-OpenStack-Cloud-8-2020-3550
SUSE OpenStack Cloud 9
  • libvncclient0 >= 0.9.9-17.34.1
  • libvncserver0 >= 0.9.9-17.34.1
Patchnames:
SUSE-OpenStack-Cloud-9-2020-3550
SUSE OpenStack Cloud Crowbar 8
  • libvncclient0 >= 0.9.9-17.34.1
  • libvncserver0 >= 0.9.9-17.34.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2020-3550
SUSE OpenStack Cloud Crowbar 9
  • libvncclient0 >= 0.9.9-17.34.1
  • libvncserver0 >= 0.9.9-17.34.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2020-3550
openSUSE Leap 15.1
  • LibVNCServer-debugsource >= 0.9.10-lp151.7.12.1
  • LibVNCServer-devel >= 0.9.10-lp151.7.12.1
  • libvncclient0 >= 0.9.10-lp151.7.12.1
  • libvncclient0-debuginfo >= 0.9.10-lp151.7.12.1
  • libvncserver0 >= 0.9.10-lp151.7.12.1
  • libvncserver0-debuginfo >= 0.9.10-lp151.7.12.1
Patchnames:
openSUSE-2020-2097
openSUSE Leap 15.2
  • LibVNCServer-debugsource >= 0.9.10-lp152.9.8.1
  • LibVNCServer-devel >= 0.9.10-lp152.9.8.1
  • libvncclient0 >= 0.9.10-lp152.9.8.1
  • libvncclient0-debuginfo >= 0.9.10-lp152.9.8.1
  • libvncserver0 >= 0.9.10-lp152.9.8.1
  • libvncserver0-debuginfo >= 0.9.10-lp152.9.8.1
Patchnames:
openSUSE-2020-2025
openSUSE Leap 15.3 SLE Imports
  • LibVNCServer-debugsource >= 0.9.10-4.25.1
  • LibVNCServer-devel >= 0.9.10-4.25.1
  • libvncclient0 >= 0.9.10-4.25.1
  • libvncclient0-debuginfo >= 0.9.10-4.25.1
  • libvncserver0 >= 0.9.10-4.25.1
  • libvncserver0-debuginfo >= 0.9.10-4.25.1
Patchnames:
SUSE-2020-3515


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 LibVNCServer Affected
SUSE Enterprise Storage 5 LibVNCServer Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 LibVNCServer Released
SUSE Linux Enterprise Point of Service 11 SP3 LibVNCServer Affected
SUSE Linux Enterprise Point of Service Image Server 12 LibVNCServer Affected
SUSE Linux Enterprise Server 11 SP4 LTSS LibVNCServer Affected
SUSE Linux Enterprise Server 12 SP2 BCL LibVNCServer Affected
SUSE Linux Enterprise Server 12 SP2 ESPOS LibVNCServer Affected
SUSE Linux Enterprise Server 12 SP2 LTSS LibVNCServer Affected
SUSE Linux Enterprise Server 12 SP3 BCL LibVNCServer Affected
SUSE Linux Enterprise Server 12 SP3 ESPOS LibVNCServer Affected
SUSE Linux Enterprise Server 12 SP3 LTSS LibVNCServer Affected
SUSE Linux Enterprise Server 12 SP4 ESPOS LibVNCServer Affected
SUSE Linux Enterprise Server 12 SP4 LTSS LibVNCServer Affected
SUSE Linux Enterprise Server 12 SP5 LibVNCServer Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 LibVNCServer Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 LibVNCServer Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 LibVNCServer Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 LibVNCServer Released
SUSE Linux Enterprise Workstation Extension 15 SP1 LibVNCServer Released
SUSE Linux Enterprise Workstation Extension 15 SP2 LibVNCServer Released
SUSE OpenStack Cloud 7 LibVNCServer Affected
SUSE OpenStack Cloud 8 LibVNCServer Affected
SUSE OpenStack Cloud 9 LibVNCServer Affected
SUSE OpenStack Cloud Crowbar 8 LibVNCServer Affected
SUSE OpenStack Cloud Crowbar 9 LibVNCServer Affected