Upstream information

CVE-2020-25657 at MITRE

Description

A flaw was found in all released versions of m2crypto, where they are vulnerable to Bleichenbacher timing attacks in the RSA decryption API via the timed processing of valid PKCS#1 v1.5 Ciphertext. The highest threat from this vulnerability is to confidentiality.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.9 7.5
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Access Vector Network Network
Access Complexity High Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1178829 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 python-M2Crypto Affected
SUSE Enterprise Storage 5 python-M2Crypto Unsupported
SUSE Linux Enterprise High Performance Computing 12 SP5 python-M2Crypto Affected
SUSE Linux Enterprise High Performance Computing 15 LTSS python-M2Crypto Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 python-M2Crypto Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP2 python-M2Crypto Affected
SUSE Linux Enterprise Module for Python 2 15 SP1 python-M2Crypto Unsupported
SUSE Linux Enterprise Module for Python 2 15 SP2 python-M2Crypto Affected
SUSE Linux Enterprise Point of Service 11 SP3 python-m2crypto Affected
SUSE Linux Enterprise Point of Service Image Server 12 python-M2Crypto Unsupported
SUSE Linux Enterprise Server 11 SP4 LTSS python-m2crypto Affected
SUSE Linux Enterprise Server 12 SP2 BCL python-M2Crypto Affected
SUSE Linux Enterprise Server 12 SP2 ESPOS python-M2Crypto Unsupported
SUSE Linux Enterprise Server 12 SP2 LTSS python-M2Crypto Affected
SUSE Linux Enterprise Server 12 SP3 BCL python-M2Crypto Affected
SUSE Linux Enterprise Server 12 SP3 ESPOS python-M2Crypto Affected
SUSE Linux Enterprise Server 12 SP3 LTSS python-M2Crypto Affected
SUSE Linux Enterprise Server 12 SP4 ESPOS python-M2Crypto Affected
SUSE Linux Enterprise Server 12 SP4 LTSS python-M2Crypto Affected
SUSE Linux Enterprise Server 12 SP5 python-M2Crypto Affected
SUSE Linux Enterprise Server 15 LTSS python-M2Crypto Affected
SUSE Linux Enterprise Server ESPOS 15 python-M2Crypto Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 python-M2Crypto Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 python-M2Crypto Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 python-M2Crypto Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 python-M2Crypto Affected
SUSE Linux Enterprise Server for SAP Applications 15 python-M2Crypto Affected
SUSE OpenStack Cloud 7 python-M2Crypto Affected
SUSE OpenStack Cloud 8 python-M2Crypto Affected
SUSE OpenStack Cloud 9 python-M2Crypto Affected
SUSE OpenStack Cloud Crowbar 8 python-M2Crypto Affected
SUSE OpenStack Cloud Crowbar 9 python-M2Crypto Affected