Upstream information

CVE-2020-1930 at MITRE

Description

A command execution issue was found in Apache SpamAssassin prior to 3.4.3. Carefully crafted nefarious rule configuration (.cf) files can be configured to run system commands similar to CVE-2018-11805. With this bug unpatched, exploits can be injected in a number of scenarios including the same privileges as spamd is run which may be elevated though doing so remotely is difficult. In addition to upgrading to SA 3.4.4, we again recommend that users should only use update channels or 3rd party .cf files from trusted places. If you cannot upgrade, do not use 3rd party rulesets, do not use sa-compile and do not run spamd as an account with elevated privileges.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v3 Scores
  SUSE
Base Score 7.4
Vector CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1162197 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • perl-Mail-SpamAssassin >= 3.4.2-44.8.1
  • spamassassin >= 3.4.2-44.8.1
Patchnames:
HPE-Helion-OpenStack-8-2020-810
SUSE Enterprise Storage 4
  • perl-Mail-SpamAssassin >= 3.4.2-44.8.1
  • spamassassin >= 3.4.2-44.8.1
Patchnames:
SUSE-Storage-4-2020-810
SUSE Enterprise Storage 5
  • perl-Mail-SpamAssassin >= 3.4.2-44.8.1
  • spamassassin >= 3.4.2-44.8.1
Patchnames:
SUSE-Storage-5-2020-810
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • perl-Mail-SpamAssassin >= 3.4.2-7.9.1
  • perl-Mail-SpamAssassin-Plugin-iXhash2 >= 2.05-7.9.1
  • spamassassin >= 3.4.2-7.9.1
Patchnames:
SUSE-SLE-Product-HPC-15-2020-813
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • perl-Mail-SpamAssassin >= 3.4.2-12.5.1
  • spamassassin >= 3.4.2-12.5.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2020-811
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • perl-Mail-SpamAssassin-Plugin-iXhash2 >= 2.05-12.5.1
  • spamassassin >= 3.4.2-12.5.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP1-2020-811
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • perl-Mail-SpamAssassin >= 3.4.2-44.8.1
  • spamassassin >= 3.4.2-44.8.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2020-810
SUSE Linux Enterprise Server 12 SP1-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • perl-Mail-SpamAssassin >= 3.4.2-44.8.1
  • spamassassin >= 3.4.2-44.8.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2020-810
SUSE Linux Enterprise Server 12 SP2-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • perl-Mail-SpamAssassin >= 3.4.2-44.8.1
  • spamassassin >= 3.4.2-44.8.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2020-810
SUSE Linux Enterprise Server 12 SP2-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • perl-Mail-SpamAssassin >= 3.4.2-44.8.1
  • spamassassin >= 3.4.2-44.8.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2020-810
SUSE Linux Enterprise Server 12 SP2-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • perl-Mail-SpamAssassin >= 3.4.2-44.8.1
  • spamassassin >= 3.4.2-44.8.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2020-810
SUSE Linux Enterprise Server 12 SP3-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • perl-Mail-SpamAssassin >= 3.4.2-44.8.1
  • spamassassin >= 3.4.2-44.8.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2020-810
SUSE Linux Enterprise Server 12 SP3-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • perl-Mail-SpamAssassin >= 3.4.2-44.8.1
  • spamassassin >= 3.4.2-44.8.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2020-810
SUSE Linux Enterprise Server 12 SP3-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • perl-Mail-SpamAssassin >= 3.4.2-44.8.1
  • spamassassin >= 3.4.2-44.8.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2020-810
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • perl-Mail-SpamAssassin >= 3.4.2-44.8.1
  • spamassassin >= 3.4.2-44.8.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2020-810
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • perl-Mail-SpamAssassin >= 3.4.2-44.8.1
  • spamassassin >= 3.4.2-44.8.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2020-810
SUSE Linux Enterprise Server 15-LTSS
  • perl-Mail-SpamAssassin >= 3.4.2-7.9.1
  • perl-Mail-SpamAssassin-Plugin-iXhash2 >= 2.05-7.9.1
  • spamassassin >= 3.4.2-7.9.1
Patchnames:
SUSE-SLE-Product-SLES-15-2020-813
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • perl-Mail-SpamAssassin >= 3.4.2-44.8.1
  • spamassassin >= 3.4.2-44.8.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2020-810
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • perl-Mail-SpamAssassin >= 3.4.2-44.8.1
  • spamassassin >= 3.4.2-44.8.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2020-810
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • perl-Mail-SpamAssassin >= 3.4.2-44.8.1
  • spamassassin >= 3.4.2-44.8.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2020-810
SUSE Linux Enterprise Server for SAP Applications 15
  • perl-Mail-SpamAssassin >= 3.4.2-7.9.1
  • perl-Mail-SpamAssassin-Plugin-iXhash2 >= 2.05-7.9.1
  • spamassassin >= 3.4.2-7.9.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2020-813
SUSE OpenStack Cloud 7
  • perl-Mail-SpamAssassin >= 3.4.2-44.8.1
  • spamassassin >= 3.4.2-44.8.1
Patchnames:
SUSE-OpenStack-Cloud-7-2020-810
SUSE OpenStack Cloud 8
  • perl-Mail-SpamAssassin >= 3.4.2-44.8.1
  • spamassassin >= 3.4.2-44.8.1
Patchnames:
SUSE-OpenStack-Cloud-8-2020-810
SUSE OpenStack Cloud Crowbar 8
  • perl-Mail-SpamAssassin >= 3.4.2-44.8.1
  • spamassassin >= 3.4.2-44.8.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2020-810
openSUSE Leap 15.1
  • perl-Mail-SpamAssassin >= 3.4.2-lp151.8.3.1
  • perl-Mail-SpamAssassin-Plugin-iXhash2 >= 2.05-lp151.8.3.1
  • spamassassin >= 3.4.2-lp151.8.3.1
  • spamassassin-debuginfo >= 3.4.2-lp151.8.3.1
  • spamassassin-debugsource >= 3.4.2-lp151.8.3.1
Patchnames:
openSUSE-2020-446


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Business Critical Linux 12 SP2 spamassassin Released
SUSE Business Critical Linux 12 SP3 spamassassin Released
SUSE Linux Enterprise High Performance Computing 12 spamassassin Released
SUSE Linux Enterprise High Performance Computing ESPOS 15 GA spamassassin Released
SUSE Linux Enterprise High Performance Computing LTSS 15 GA spamassassin Released
SUSE Linux Enterprise Module for Basesystem 15 GA spamassassin Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 spamassassin Released
SUSE Linux Enterprise Module for Development Tools 15 GA spamassassin Affected
SUSE Linux Enterprise Module for Development Tools 15 SP1 spamassassin Released
SUSE Linux Enterprise Server 11 SP4 LTSS spamassassin Affected
SUSE Linux Enterprise Server 12 SP1 LTSS spamassassin Released
SUSE Linux Enterprise Server 12 SP2 spamassassin Affected
SUSE Linux Enterprise Server 12 SP2 LTSS spamassassin Released
SUSE Linux Enterprise Server 12 SP3 LTSS spamassassin Released
SUSE Linux Enterprise Server 12 SP4 spamassassin Released
SUSE Linux Enterprise Server 12 SP5 spamassassin Released
SUSE Linux Enterprise Server 15 GA LTSS spamassassin Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 spamassassin Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 spamassassin Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 spamassassin Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 spamassassin Released