Upstream information

CVE-2020-17482 at MITRE

Description

An issue has been found in PowerDNS Authoritative Server before 4.3.1 where an authorized user with the ability to insert crafted records into a zone might be able to leak the content of uninitialized memory.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 1176535 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • pdns >= 4.1.2-3.9.1
  • pdns-backend-mysql >= 4.1.2-3.9.1
Patchnames:
HPE-Helion-OpenStack-8-2020-2718
SUSE OpenStack Cloud 8
  • pdns >= 4.1.2-3.9.1
  • pdns-backend-mysql >= 4.1.2-3.9.1
Patchnames:
SUSE-OpenStack-Cloud-8-2020-2718
SUSE OpenStack Cloud 9
  • pdns >= 4.1.8-3.6.1
  • pdns-backend-mysql >= 4.1.8-3.6.1
Patchnames:
SUSE-OpenStack-Cloud-9-2020-2785
SUSE Package Hub for SUSE Linux Enterprise 12 SP1
  • pdns >= 4.1.14-23.1
  • pdns-backend-geoip >= 4.3.1-lp152.2.3.1
  • pdns-backend-geoip-debuginfo >= 4.3.1-lp152.2.3.1
  • pdns-backend-godbc >= 4.1.14-23.1
  • pdns-backend-godbc-debuginfo >= 4.1.14-23.1
  • pdns-backend-ldap >= 4.1.14-23.1
  • pdns-backend-ldap-debuginfo >= 4.1.14-23.1
  • pdns-backend-lua >= 4.1.14-23.1
  • pdns-backend-lua-debuginfo >= 4.1.14-23.1
  • pdns-backend-mydns >= 4.1.14-23.1
  • pdns-backend-mydns-debuginfo >= 4.1.14-23.1
  • pdns-backend-mysql >= 4.1.14-23.1
  • pdns-backend-mysql-debuginfo >= 4.1.14-23.1
  • pdns-backend-postgresql >= 4.1.14-23.1
  • pdns-backend-postgresql-debuginfo >= 4.1.14-23.1
  • pdns-backend-remote >= 4.1.14-23.1
  • pdns-backend-remote-debuginfo >= 4.1.14-23.1
  • pdns-backend-sqlite3 >= 4.1.14-23.1
  • pdns-backend-sqlite3-debuginfo >= 4.1.14-23.1
  • pdns-debuginfo >= 4.1.14-23.1
  • pdns-debugsource >= 4.1.14-23.1
Patchnames:
openSUSE-2020-1556
openSUSE Leap 15.1
  • pdns >= 4.1.8-lp151.2.9.1
  • pdns-backend-geoip >= 4.1.8-lp151.2.9.1
  • pdns-backend-geoip-debuginfo >= 4.1.8-lp151.2.9.1
  • pdns-backend-godbc >= 4.1.8-lp151.2.9.1
  • pdns-backend-godbc-debuginfo >= 4.1.8-lp151.2.9.1
  • pdns-backend-ldap >= 4.1.8-lp151.2.9.1
  • pdns-backend-ldap-debuginfo >= 4.1.8-lp151.2.9.1
  • pdns-backend-lua >= 4.1.8-lp151.2.9.1
  • pdns-backend-lua-debuginfo >= 4.1.8-lp151.2.9.1
  • pdns-backend-mydns >= 4.1.8-lp151.2.9.1
  • pdns-backend-mydns-debuginfo >= 4.1.8-lp151.2.9.1
  • pdns-backend-mysql >= 4.1.8-lp151.2.9.1
  • pdns-backend-mysql-debuginfo >= 4.1.8-lp151.2.9.1
  • pdns-backend-postgresql >= 4.1.8-lp151.2.9.1
  • pdns-backend-postgresql-debuginfo >= 4.1.8-lp151.2.9.1
  • pdns-backend-remote >= 4.1.8-lp151.2.9.1
  • pdns-backend-remote-debuginfo >= 4.1.8-lp151.2.9.1
  • pdns-backend-sqlite3 >= 4.1.8-lp151.2.9.1
  • pdns-backend-sqlite3-debuginfo >= 4.1.8-lp151.2.9.1
  • pdns-debuginfo >= 4.1.8-lp151.2.9.1
  • pdns-debugsource >= 4.1.8-lp151.2.9.1
Patchnames:
openSUSE-2020-1556
openSUSE Leap 15.2
  • pdns >= 4.3.1-lp152.2.3.1
  • pdns-backend-geoip >= 4.3.1-lp152.2.3.1
  • pdns-backend-geoip-debuginfo >= 4.3.1-lp152.2.3.1
  • pdns-backend-godbc >= 4.3.1-lp152.2.3.1
  • pdns-backend-godbc-debuginfo >= 4.3.1-lp152.2.3.1
  • pdns-backend-ldap >= 4.3.1-lp152.2.3.1
  • pdns-backend-ldap-debuginfo >= 4.3.1-lp152.2.3.1
  • pdns-backend-lua >= 4.3.1-lp152.2.3.1
  • pdns-backend-lua-debuginfo >= 4.3.1-lp152.2.3.1
  • pdns-backend-mydns >= 4.1.8-lp151.2.9.1
  • pdns-backend-mydns-debuginfo >= 4.1.8-lp151.2.9.1
  • pdns-backend-mysql >= 4.3.1-lp152.2.3.1
  • pdns-backend-mysql-debuginfo >= 4.3.1-lp152.2.3.1
  • pdns-backend-postgresql >= 4.3.1-lp152.2.3.1
  • pdns-backend-postgresql-debuginfo >= 4.3.1-lp152.2.3.1
  • pdns-backend-remote >= 4.3.1-lp152.2.3.1
  • pdns-backend-remote-debuginfo >= 4.3.1-lp152.2.3.1
  • pdns-backend-sqlite3 >= 4.3.1-lp152.2.3.1
  • pdns-backend-sqlite3-debuginfo >= 4.3.1-lp152.2.3.1
  • pdns-debuginfo >= 4.3.1-lp152.2.3.1
  • pdns-debugsource >= 4.3.1-lp152.2.3.1
Patchnames:
openSUSE-2020-1556


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 pdns Released
HPE Helion OpenStack Cloud 8 pdns Affected
SUSE OpenStack Cloud 8 pdns Released
SUSE OpenStack Cloud 9 pdns Released