Upstream information

CVE-2020-17437 at MITRE

Description

An issue was discovered in uIP 1.0, as used in Contiki 3.0 and other products. When the Urgent flag is set in a TCP packet, and the stack is configured to ignore the urgent data, the stack attempts to use the value of the Urgent pointer bytes to separate the Urgent data from the normal data, by calculating the offset at which the normal data should be present in the global buffer. However, the length of this offset is not checked; therefore, for large values of the Urgent pointer bytes, the data pointer can point to memory that is way beyond the data buffer in uip_process in uip.c.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.4
Vector AV:N/AC:L/Au:N/C:P/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.2 5.3
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact Low None
Integrity Impact None None
Availability Impact High Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entries: 1179907 [NEW], 1179908 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform 4.0
  • iscsiuio >= 0.7.8.2-13.42.1
  • libopeniscsiusr0_2_0 >= 2.0.876-13.42.1
  • open-iscsi >= 2.0.876-13.42.1
  • open-iscsi-devel >= 2.0.876-13.42.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2021-1164
SUSE Enterprise Storage 6
  • iscsiuio >= 0.7.8.2-13.42.1
  • libopeniscsiusr0_2_0 >= 2.0.876-13.42.1
  • open-iscsi >= 2.0.876-13.42.1
  • open-iscsi-devel >= 2.0.876-13.42.1
Patchnames:
SUSE-Storage-6-2021-1164
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • iscsiuio >= 0.7.8.2-13.42.1
  • libopeniscsiusr0_2_0 >= 2.0.876-13.42.1
  • open-iscsi >= 2.0.876-13.42.1
  • open-iscsi-devel >= 2.0.876-13.42.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-1164
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • iscsiuio >= 0.7.8.2-13.42.1
  • libopeniscsiusr0_2_0 >= 2.0.876-13.42.1
  • open-iscsi >= 2.0.876-13.42.1
  • open-iscsi-devel >= 2.0.876-13.42.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-1164
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • iscsiuio >= 0.7.8.2-13.42.1
  • libopeniscsiusr0_2_0 >= 2.0.876-13.42.1
  • open-iscsi >= 2.0.876-13.42.1
  • open-iscsi-devel >= 2.0.876-13.42.1
Patchnames:
SUSE-SLE-Product-HPC-15-2021-1164
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • iscsiuio >= 0.7.8.6-22.14.1
  • libopeniscsiusr0_2_0 >= 2.1.4-22.14.1
  • open-iscsi >= 2.1.4-22.14.1
  • open-iscsi-devel >= 2.1.4-22.14.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-1517
SUSE Linux Enterprise Module for Legacy 15 SP2
  • open-iscsi >= 2.0.876-13.42.1
Patchnames:
SUSE-SLE-Module-Legacy-15-SP2-2021-1164
SUSE Linux Enterprise Module for Legacy 15 SP3
  • open-iscsi >= 2.0.876-13.42.1
Patchnames:
SUSE-SLE-Module-Legacy-15-SP3-2021-1164
SUSE Linux Enterprise Server 12 SP4-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP4-ESPOS
  • iscsiuio >= 0.7.8.2-12.27.2
  • libopeniscsiusr0_2_0 >= 2.0.876-12.27.2
  • open-iscsi >= 2.0.876-12.27.2
Patchnames:
SUSE-SLE-SERVER-12-SP4-ESPOS-2021-663
SUSE Linux Enterprise Server 12 SP4-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP4-LTSS
  • iscsiuio >= 0.7.8.2-12.27.2
  • libopeniscsiusr0_2_0 >= 2.0.876-12.27.2
  • open-iscsi >= 2.0.876-12.27.2
Patchnames:
SUSE-SLE-SERVER-12-SP4-LTSS-2021-663
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • iscsiuio >= 0.7.8.2-12.27.2
  • libopeniscsiusr0_2_0 >= 2.0.876-12.27.2
  • open-iscsi >= 2.0.876-12.27.2
Patchnames:
SUSE-SLE-SERVER-12-SP5-2021-663
SUSE Linux Enterprise Server 15 SP1-BCL
  • iscsiuio >= 0.7.8.2-13.42.1
  • libopeniscsiusr0_2_0 >= 2.0.876-13.42.1
  • open-iscsi >= 2.0.876-13.42.1
  • open-iscsi-devel >= 2.0.876-13.42.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-BCL-2021-1164
SUSE Linux Enterprise Server 15 SP1-LTSS
  • iscsiuio >= 0.7.8.2-13.42.1
  • libopeniscsiusr0_2_0 >= 2.0.876-13.42.1
  • open-iscsi >= 2.0.876-13.42.1
  • open-iscsi-devel >= 2.0.876-13.42.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-1164
SUSE Linux Enterprise Server 15-LTSS
  • iscsiuio >= 0.7.8.2-13.42.1
  • libopeniscsiusr0_2_0 >= 2.0.876-13.42.1
  • open-iscsi >= 2.0.876-13.42.1
  • open-iscsi-devel >= 2.0.876-13.42.1
Patchnames:
SUSE-SLE-Product-SLES-15-2021-1164
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • iscsiuio >= 0.7.8.2-12.27.2
  • libopeniscsiusr0_2_0 >= 2.0.876-12.27.2
  • open-iscsi >= 2.0.876-12.27.2
Patchnames:
SUSE-SLE-SAP-12-SP4-2021-663
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • iscsiuio >= 0.7.8.2-13.42.1
  • libopeniscsiusr0_2_0 >= 2.0.876-13.42.1
  • open-iscsi >= 2.0.876-13.42.1
  • open-iscsi-devel >= 2.0.876-13.42.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2021-1164
SUSE Linux Enterprise Server for SAP Applications 15
  • iscsiuio >= 0.7.8.2-13.42.1
  • libopeniscsiusr0_2_0 >= 2.0.876-13.42.1
  • open-iscsi >= 2.0.876-13.42.1
  • open-iscsi-devel >= 2.0.876-13.42.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2021-1164
SUSE Manager Proxy 4.0
  • iscsiuio >= 0.7.8.2-13.42.1
  • libopeniscsiusr0_2_0 >= 2.0.876-13.42.1
  • open-iscsi >= 2.0.876-13.42.1
  • open-iscsi-devel >= 2.0.876-13.42.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.0-2021-1164
SUSE Manager Retail Branch Server 4.0
  • iscsiuio >= 0.7.8.2-13.42.1
  • libopeniscsiusr0_2_0 >= 2.0.876-13.42.1
  • open-iscsi >= 2.0.876-13.42.1
  • open-iscsi-devel >= 2.0.876-13.42.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.0-2021-1164
SUSE Manager Server 4.0
  • iscsiuio >= 0.7.8.2-13.42.1
  • libopeniscsiusr0_2_0 >= 2.0.876-13.42.1
  • open-iscsi >= 2.0.876-13.42.1
  • open-iscsi-devel >= 2.0.876-13.42.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.0-2021-1164
SUSE MicroOS 5.0
  • iscsiuio >= 0.7.8.6-22.14.1
  • libopeniscsiusr0_2_0 >= 2.1.4-22.14.1
  • open-iscsi >= 2.1.4-22.14.1
Patchnames:
SUSE-SUSE-MicroOS-5.0-2021-1517
SUSE OpenStack Cloud 9
  • iscsiuio >= 0.7.8.2-12.27.2
  • libopeniscsiusr0_2_0 >= 2.0.876-12.27.2
  • open-iscsi >= 2.0.876-12.27.2
Patchnames:
SUSE-OpenStack-Cloud-9-2021-663
SUSE OpenStack Cloud Crowbar 9
  • iscsiuio >= 0.7.8.2-12.27.2
  • libopeniscsiusr0_2_0 >= 2.0.876-12.27.2
  • open-iscsi >= 2.0.876-12.27.2
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2021-663


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 open-iscsi Affected
SUSE CaaS Platform 4.0 open-iscsi Released
SUSE Enterprise Storage 5 open-iscsi Unsupported
SUSE Enterprise Storage 6 open-iscsi Released
SUSE Linux Enterprise High Performance Computing 12 SP5 open-iscsi Released
SUSE Linux Enterprise High Performance Computing 15 LTSS open-iscsi Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS open-iscsi Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 open-iscsi Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP2 open-iscsi Released
SUSE Linux Enterprise Module for Legacy 15 SP1 open-iscsi Unsupported
SUSE Linux Enterprise Module for Legacy 15 SP2 open-iscsi Released
SUSE Linux Enterprise Point of Service 11 SP3 open-iscsi Affected
SUSE Linux Enterprise Point of Service Image Server 12 open-iscsi Unsupported
SUSE Linux Enterprise Server 11 SP4 LTSS open-iscsi Affected
SUSE Linux Enterprise Server 12 SP2 BCL open-iscsi Affected
SUSE Linux Enterprise Server 12 SP2 ESPOS open-iscsi Unsupported
SUSE Linux Enterprise Server 12 SP2 LTSS open-iscsi Affected
SUSE Linux Enterprise Server 12 SP3 BCL open-iscsi Affected
SUSE Linux Enterprise Server 12 SP3 ESPOS open-iscsi Affected
SUSE Linux Enterprise Server 12 SP3 LTSS open-iscsi Affected
SUSE Linux Enterprise Server 12 SP4 ESPOS open-iscsi Released
SUSE Linux Enterprise Server 12 SP4 LTSS open-iscsi Released
SUSE Linux Enterprise Server 12 SP5 open-iscsi Released
SUSE Linux Enterprise Server 15 LTSS open-iscsi Released
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux open-iscsi Released
SUSE Linux Enterprise Server 15 SP1 LTSS open-iscsi Released
SUSE Linux Enterprise Server ESPOS 15 open-iscsi Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 open-iscsi Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 open-iscsi Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 open-iscsi Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 open-iscsi Released
SUSE Linux Enterprise Server for SAP Applications 15 open-iscsi Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 open-iscsi Released
SUSE Manager Proxy 4.0 open-iscsi Released
SUSE Manager Retail Branch Server 4.0 open-iscsi Released
SUSE Manager Server 4.0 open-iscsi Released
SUSE OpenStack Cloud 7 open-iscsi Affected
SUSE OpenStack Cloud 8 open-iscsi Affected
SUSE OpenStack Cloud 9 open-iscsi Released
SUSE OpenStack Cloud Crowbar 8 open-iscsi Affected
SUSE OpenStack Cloud Crowbar 9 open-iscsi Released