Upstream information

CVE-2020-1693 at MITRE

Description

A flaw was found in Spacewalk up to version 2.9 where it was vulnerable to XML internal entity attacks via the /rpc/api endpoint. An unauthenticated remote attacker could use this flaw to retrieve the content of certain files and trigger a denial of service, or in certain circumstances, execute arbitrary code on the Spacewalk server.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 8.6
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High Low
Availability Impact High Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1164120 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for SUSE Manager Proxy 4.0
  • mgr-osad >= 4.0.11-3.9.2
  • patterns-suma_proxy >= 4.0-9.10.2
  • patterns-suse-manager >= 4.0-9.10.2
  • python3-mgr-osa-common >= 4.0.11-3.9.2
  • python3-mgr-osad >= 4.0.11-3.9.2
  • python3-spacewalk-backend-libs >= 4.0.30-3.23.3
  • python3-spacewalk-certs-tools >= 4.0.15-3.15.2
  • python3-spacewalk-check >= 4.0.12-3.13.2
  • python3-spacewalk-client-setup >= 4.0.12-3.13.2
  • python3-spacewalk-client-tools >= 4.0.12-3.13.2
  • spacecmd >= 4.0.18-3.13.2
  • spacewalk-backend >= 4.0.30-3.23.3
  • spacewalk-base-minimal >= 4.0.19-3.18.3
  • spacewalk-base-minimal-config >= 4.0.19-3.18.3
  • spacewalk-certs-tools >= 4.0.15-3.15.2
  • spacewalk-check >= 4.0.12-3.13.2
  • spacewalk-client-setup >= 4.0.12-3.13.2
  • spacewalk-client-tools >= 4.0.12-3.13.2
  • spacewalk-web >= 4.0.19-3.18.3
  • supportutils-plugin-susemanager-client >= 4.0.3-3.3.2
  • supportutils-plugin-susemanager-proxy >= 4.0.3-3.3.2
Patchnames:
SUSE-SLE-Module-SUSE-Manager-Proxy-4.0-2020-671
SUSE Linux Enterprise Module for SUSE Manager Server 4.0
  • branch-network-formula >= 0.1.1580471316.1839544-3.10.2
  • image-sync-formula >= 0.1.1579102150.4716559-3.11.2
  • mgr-osa-dispatcher >= 4.0.11-3.9.2
  • mgr-osad >= 4.0.11-3.9.2
  • patterns-suma_retail >= 4.0-9.10.2
  • patterns-suma_server >= 4.0-9.10.2
  • patterns-suse-manager >= 4.0-9.10.2
  • prometheus-formula >= 0.1-4.7.2
  • pxe-default-image-sle15 >= 4.0.1-20200305173027
  • pxe-formula >= 0.1.1580384994.6076a7e-3.11.2
  • py26-compat-salt >= 2016.11.10-10.11.2
  • python-susemanager-retail >= 1.0.1580471316.1839544-3.13.2
  • python3-mgr-osa-common >= 4.0.11-3.9.2
  • python3-mgr-osa-dispatcher >= 4.0.11-3.9.2
  • python3-spacewalk-backend-libs >= 4.0.30-3.23.3
  • python3-spacewalk-certs-tools >= 4.0.15-3.15.2
  • python3-spacewalk-client-tools >= 4.0.12-3.13.2
  • python3-susemanager-retail >= 1.0.1580471316.1839544-3.13.2
  • redstone-xmlrpc >= 1.1_20071120-0.11.3.2
  • salt-netapi-client >= 0.17.0-4.3.2
  • spacecmd >= 4.0.18-3.13.2
  • spacewalk-admin >= 4.0.9-3.6.2
  • spacewalk-backend >= 4.0.30-3.23.3
  • spacewalk-backend-app >= 4.0.30-3.23.3
  • spacewalk-backend-applet >= 4.0.30-3.23.3
  • spacewalk-backend-config-files >= 4.0.30-3.23.3
  • spacewalk-backend-config-files-common >= 4.0.30-3.23.3
  • spacewalk-backend-config-files-tool >= 4.0.30-3.23.3
  • spacewalk-backend-iss >= 4.0.30-3.23.3
  • spacewalk-backend-iss-export >= 4.0.30-3.23.3
  • spacewalk-backend-package-push-server >= 4.0.30-3.23.3
  • spacewalk-backend-server >= 4.0.30-3.23.3
  • spacewalk-backend-sql >= 4.0.30-3.23.3
  • spacewalk-backend-sql-postgresql >= 4.0.30-3.23.3
  • spacewalk-backend-tools >= 4.0.30-3.23.3
  • spacewalk-backend-xml-export-libs >= 4.0.30-3.23.3
  • spacewalk-backend-xmlrpc >= 4.0.30-3.23.3
  • spacewalk-base >= 4.0.19-3.18.3
  • spacewalk-base-minimal >= 4.0.19-3.18.3
  • spacewalk-base-minimal-config >= 4.0.19-3.18.3
  • spacewalk-certs-tools >= 4.0.15-3.15.2
  • spacewalk-client-tools >= 4.0.12-3.13.2
  • spacewalk-html >= 4.0.19-3.18.3
  • spacewalk-java >= 4.0.31-3.23.1
  • spacewalk-java-config >= 4.0.31-3.23.1
  • spacewalk-java-lib >= 4.0.31-3.23.1
  • spacewalk-java-postgresql >= 4.0.31-3.23.1
  • spacewalk-search >= 4.0.9-3.11.2
  • spacewalk-setup >= 4.0.13-3.11.1
  • spacewalk-taskomatic >= 4.0.31-3.23.1
  • spacewalk-utils >= 4.0.16-3.15.2
  • spacewalk-web >= 4.0.19-3.18.3
  • subscription-matcher >= 0.25-3.3.2
  • susemanager >= 4.0.22-3.20.3
  • susemanager-doc-indexes >= 4.0-10.18.2
  • susemanager-docs_en >= 4.0-10.18.2
  • susemanager-docs_en-pdf >= 4.0-10.18.2
  • susemanager-retail-tools >= 1.0.1580471316.1839544-3.13.2
  • susemanager-schema >= 4.0.18-3.17.2
  • susemanager-sls >= 4.0.24-3.17.2
  • susemanager-sync-data >= 4.0.16-3.15.2
  • susemanager-tools >= 4.0.22-3.20.3
  • susemanager-web-libs >= 4.0.19-3.18.3
  • system-lock-formula >= 0.2-4.5.1
  • virtualization-host-formula >= 0.2-4.3.2
Patchnames:
SUSE-SLE-Module-SUSE-Manager-Server-4.0-2020-671
SUSE Manager Server 3.2
  • py26-compat-salt >= 2016.11.10-6.35.1
  • python2-spacewalk-certs-tools >= 2.8.8.14-3.23.1
  • python2-spacewalk-client-tools >= 2.8.22.7-3.12.1
  • redstone-xmlrpc >= 1.1_20071120-0.11.3.1
  • spacecmd >= 2.8.25.14-3.32.1
  • spacewalk-admin >= 2.8.4.6-3.12.1
  • spacewalk-backend >= 2.8.57.22-3.48.1
  • spacewalk-backend-app >= 2.8.57.22-3.48.1
  • spacewalk-backend-applet >= 2.8.57.22-3.48.1
  • spacewalk-backend-config-files >= 2.8.57.22-3.48.1
  • spacewalk-backend-config-files-common >= 2.8.57.22-3.48.1
  • spacewalk-backend-config-files-tool >= 2.8.57.22-3.48.1
  • spacewalk-backend-iss >= 2.8.57.22-3.48.1
  • spacewalk-backend-iss-export >= 2.8.57.22-3.48.1
  • spacewalk-backend-libs >= 2.8.57.22-3.48.1
  • spacewalk-backend-package-push-server >= 2.8.57.22-3.48.1
  • spacewalk-backend-server >= 2.8.57.22-3.48.1
  • spacewalk-backend-sql >= 2.8.57.22-3.48.1
  • spacewalk-backend-sql-oracle >= 2.8.57.22-3.48.1
  • spacewalk-backend-sql-postgresql >= 2.8.57.22-3.48.1
  • spacewalk-backend-tools >= 2.8.57.22-3.48.1
  • spacewalk-backend-xml-export-libs >= 2.8.57.22-3.48.1
  • spacewalk-backend-xmlrpc >= 2.8.57.22-3.48.1
  • spacewalk-base >= 2.8.7.23-3.45.1
  • spacewalk-base-minimal >= 2.8.7.23-3.45.1
  • spacewalk-base-minimal-config >= 2.8.7.23-3.45.1
  • spacewalk-certs-tools >= 2.8.8.14-3.23.1
  • spacewalk-client-tools >= 2.8.22.7-3.12.1
  • spacewalk-html >= 2.8.7.23-3.45.1
  • spacewalk-java >= 2.8.78.28-3.47.1
  • spacewalk-java-config >= 2.8.78.28-3.47.1
  • spacewalk-java-lib >= 2.8.78.28-3.47.1
  • spacewalk-java-oracle >= 2.8.78.28-3.47.1
  • spacewalk-java-postgresql >= 2.8.78.28-3.47.1
  • spacewalk-setup >= 2.8.7.10-3.25.1
  • spacewalk-taskomatic >= 2.8.78.28-3.47.1
  • spacewalk-utils >= 2.8.18.6-3.12.1
  • spacewalk-web >= 2.8.7.23-3.45.1
  • subscription-matcher >= 0.25-4.15.1
  • susemanager >= 3.2.23-3.40.2
  • susemanager-sls >= 3.2.30-3.44.1
  • susemanager-sync-data >= 3.2.19-3.35.1
  • susemanager-tools >= 3.2.23-3.40.2
  • susemanager-web-libs >= 2.8.7.23-3.45.1
Patchnames:
SUSE-SUSE-Manager-Server-3.2-2020-856


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Manager Server 3.2 spacewalk Affected
SUSE Manager Server 4.0 Module spacewalk Not affected