Upstream information

CVE-2020-15396 at MITRE

Description

In HylaFAX+ through 7.0.2 and HylaFAX Enterprise, the faxsetup utility calls chown on files in user-owned directories. By winning a race, a local attacker could use this to escalate his privileges to root.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.2
Vector AV:L/AC:L/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1173521 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 15.1
  • hylafax+ >= 7.0.3-lp151.4.6.1
  • hylafax+-client >= 7.0.3-lp151.4.6.1
  • hylafax+-client-debuginfo >= 7.0.3-lp151.4.6.1
  • hylafax+-debuginfo >= 7.0.3-lp151.4.6.1
  • hylafax+-debugsource >= 7.0.3-lp151.4.6.1
  • libfaxutil7_0_3 >= 7.0.3-lp151.4.6.1
  • libfaxutil7_0_3-debuginfo >= 7.0.3-lp151.4.6.1
Patchnames:
openSUSE-2020-1210
openSUSE Leap 15.2
  • hylafax+ >= 7.0.3-lp152.3.6.1
  • hylafax+-client >= 7.0.3-lp152.3.6.1
  • hylafax+-client-debuginfo >= 7.0.3-lp152.3.6.1
  • hylafax+-debuginfo >= 7.0.3-lp152.3.6.1
  • hylafax+-debugsource >= 7.0.3-lp152.3.6.1
  • libfaxutil7_0_3 >= 7.0.3-lp152.3.6.1
  • libfaxutil7_0_3-debuginfo >= 7.0.3-lp152.3.6.1
Patchnames:
openSUSE-2020-1209