Upstream information

CVE-2020-15211 at MITRE

Description

In TensorFlow Lite before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, saved models in the flatbuffer format use a double indexing scheme: a model has a set of subgraphs, each subgraph has a set of operators and each operator has a set of input/output tensors. The flatbuffer format uses indices for the tensors, indexing into an array of tensors that is owned by the subgraph. This results in a pattern of double array indexing when trying to get the data of each tensor. However, some operators can have some tensors be optional. To handle this scenario, the flatbuffer model uses a negative `-1` value as index for these tensors. This results in special casing during validation at model loading time. Unfortunately, this means that the `-1` index is a valid tensor index for any operator, including those that don't expect optional inputs and including for output tensors. Thus, this allows writing and reading from outside the bounds of heap allocated arrays, although only at a specific offset from the start of these arrays. This results in both read and write gadgets, albeit very limited in scope. The issue is patched in several commits (46d5b0852, 00302787b7, e11f5558, cd31fd0ce, 1970c21, and fff2c83), and is released in TensorFlow versions 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1. A potential workaround would be to add a custom `Verifier` to the model loading code to ensure that only operators which accept optional inputs use the `-1` special value and only for the tensors that they expect to be optional. Since this allow-list type approach is erro-prone, we advise upgrading to the patched code.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database
Base Score 4.8
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact Low
Availability Impact None
CVSSv3 Version 3.1
No SUSE Bugzilla entries cross referenced.

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 15.2
  • libtensorflow2 >= 2.1.2-lp152.7.3.1
  • libtensorflow2-gnu-hpc >= 2.1.2-lp152.7.3.1
  • libtensorflow2-gnu-openmpi2-hpc >= 2.1.2-lp152.7.3.1
  • libtensorflow_cc2 >= 2.1.2-lp152.7.3.1
  • libtensorflow_cc2-gnu-hpc >= 2.1.2-lp152.7.3.1
  • libtensorflow_cc2-gnu-openmpi2-hpc >= 2.1.2-lp152.7.3.1
  • libtensorflow_framework2 >= 2.1.2-lp152.7.3.1
  • libtensorflow_framework2-gnu-hpc >= 2.1.2-lp152.7.3.1
  • libtensorflow_framework2-gnu-openmpi2-hpc >= 2.1.2-lp152.7.3.1
  • tensorflow2 >= 2.1.2-lp152.7.3.1
  • tensorflow2-devel >= 2.1.2-lp152.7.3.1
  • tensorflow2-doc >= 2.1.2-lp152.7.3.1
  • tensorflow2-gnu-hpc >= 2.1.2-lp152.7.3.1
  • tensorflow2-gnu-openmpi2-hpc >= 2.1.2-lp152.7.3.1
  • tensorflow2-lite >= 2.1.2-lp152.7.3.1
  • tensorflow2-lite-devel >= 2.1.2-lp152.7.3.1
  • tensorflow2_2_1_2-gnu-hpc >= 2.1.2-lp152.7.3.1
  • tensorflow2_2_1_2-gnu-hpc-devel >= 2.1.2-lp152.7.3.1
  • tensorflow2_2_1_2-gnu-hpc-doc >= 2.1.2-lp152.7.3.1
  • tensorflow2_2_1_2-gnu-openmpi2-hpc >= 2.1.2-lp152.7.3.1
  • tensorflow2_2_1_2-gnu-openmpi2-hpc-devel >= 2.1.2-lp152.7.3.1
  • tensorflow2_2_1_2-gnu-openmpi2-hpc-doc >= 2.1.2-lp152.7.3.1
Patchnames:
openSUSE-2020-1766