Upstream information

CVE-2020-11984 at MITRE

Description

Apache HTTP server 2.4.32 to 2.4.44 mod_proxy_uwsgi info disclosure and possible RCE

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1175074 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • apache2 >= 2.4.33-3.33.1
  • apache2-devel >= 2.4.33-3.33.1
  • apache2-doc >= 2.4.33-3.33.1
  • apache2-prefork >= 2.4.33-3.33.1
  • apache2-utils >= 2.4.33-3.33.1
  • apache2-worker >= 2.4.33-3.33.1
Patchnames:
SUSE-SLE-Product-HPC-15-2020-2344
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • apache2 >= 2.4.43-3.5.1
  • apache2-prefork >= 2.4.43-3.5.1
  • apache2-utils >= 2.4.43-3.5.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2020-2311
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • apache2 >= 2.4.33-3.33.1
  • apache2-event >= 2.4.33-3.33.1
  • apache2-example-pages >= 2.4.33-3.33.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-2344
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • apache2 >= 2.4.43-3.5.1
  • apache2-event >= 2.4.43-3.5.1
  • apache2-example-pages >= 2.4.43-3.5.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2020-2311
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • apache2 >= 2.4.33-3.33.1
  • apache2-devel >= 2.4.33-3.33.1
  • apache2-doc >= 2.4.33-3.33.1
  • apache2-prefork >= 2.4.33-3.33.1
  • apache2-utils >= 2.4.33-3.33.1
  • apache2-worker >= 2.4.33-3.33.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP1-2020-2344
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • apache2 >= 2.4.43-3.5.1
  • apache2-devel >= 2.4.43-3.5.1
  • apache2-doc >= 2.4.43-3.5.1
  • apache2-worker >= 2.4.43-3.5.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP2-2020-2311
SUSE Linux Enterprise Server 15-LTSS
  • apache2 >= 2.4.33-3.33.1
  • apache2-devel >= 2.4.33-3.33.1
  • apache2-doc >= 2.4.33-3.33.1
  • apache2-prefork >= 2.4.33-3.33.1
  • apache2-utils >= 2.4.33-3.33.1
  • apache2-worker >= 2.4.33-3.33.1
Patchnames:
SUSE-SLE-Product-SLES-15-2020-2344
SUSE Linux Enterprise Server for SAP Applications 15
  • apache2 >= 2.4.33-3.33.1
  • apache2-devel >= 2.4.33-3.33.1
  • apache2-doc >= 2.4.33-3.33.1
  • apache2-prefork >= 2.4.33-3.33.1
  • apache2-utils >= 2.4.33-3.33.1
  • apache2-worker >= 2.4.33-3.33.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2020-2344
openSUSE Leap 15.1
  • apache2 >= 2.4.33-lp151.8.15.1
  • apache2-debuginfo >= 2.4.33-lp151.8.15.1
  • apache2-debugsource >= 2.4.33-lp151.8.15.1
  • apache2-devel >= 2.4.33-lp151.8.15.1
  • apache2-doc >= 2.4.33-lp151.8.15.1
  • apache2-event >= 2.4.33-lp151.8.15.1
  • apache2-event-debuginfo >= 2.4.33-lp151.8.15.1
  • apache2-example-pages >= 2.4.33-lp151.8.15.1
  • apache2-prefork >= 2.4.33-lp151.8.15.1
  • apache2-prefork-debuginfo >= 2.4.33-lp151.8.15.1
  • apache2-utils >= 2.4.33-lp151.8.15.1
  • apache2-utils-debuginfo >= 2.4.33-lp151.8.15.1
  • apache2-worker >= 2.4.33-lp151.8.15.1
  • apache2-worker-debuginfo >= 2.4.33-lp151.8.15.1
Patchnames:
openSUSE-2020-1293
openSUSE Leap 15.2
  • apache2 >= 2.4.43-lp152.2.3.1
  • apache2-debuginfo >= 2.4.43-lp152.2.3.1
  • apache2-debugsource >= 2.4.43-lp152.2.3.1
  • apache2-devel >= 2.4.43-lp152.2.3.1
  • apache2-doc >= 2.4.43-lp152.2.3.1
  • apache2-event >= 2.4.43-lp152.2.3.1
  • apache2-event-debuginfo >= 2.4.43-lp152.2.3.1
  • apache2-example-pages >= 2.4.43-lp152.2.3.1
  • apache2-prefork >= 2.4.43-lp152.2.3.1
  • apache2-prefork-debuginfo >= 2.4.43-lp152.2.3.1
  • apache2-utils >= 2.4.43-lp152.2.3.1
  • apache2-utils-debuginfo >= 2.4.43-lp152.2.3.1
  • apache2-worker >= 2.4.43-lp152.2.3.1
  • apache2-worker-debuginfo >= 2.4.43-lp152.2.3.1
Patchnames:
openSUSE-2020-1285


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise 15-SP1 Module for Server Applications apache2 Released
SUSE Linux Enterprise 15-SP2 Module for Basesystem apache2 Released
SUSE Linux Enterprise 15-SP2 Module for Server Applications apache2 Released
SUSE Linux Enterprise High Performance Computing 12 SP4 apache2 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 apache2 Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS apache2 Released
SUSE Linux Enterprise Server 11 SP1 apache2 Not affected
SUSE Linux Enterprise Server 11 SP3 apache2 Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS apache2 Not affected
SUSE Linux Enterprise Server 12 SP2 BCL apache2 Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS apache2 Not affected
SUSE Linux Enterprise Server 12 SP3 BCL apache2 Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS apache2 Not affected
SUSE Linux Enterprise Server 12 SP4 apache2 Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS apache2 Not affected
SUSE Linux Enterprise Server 12 SP5 apache2 Not affected
SUSE Linux Enterprise Server 15 LTSS apache2 Released
SUSE Linux Enterprise Server ESPOS 15 apache2 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 apache2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 apache2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 apache2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 apache2 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 apache2 Not affected