Upstream information

CVE-2020-10761 at MITRE

Description

An assertion failure issue was found in the Network Block Device(NBD) Server in all QEMU versions before QEMU 5.0.1. This flaw occurs when an nbd-client sends a spec-compliant request that is near the boundary of maximum permitted request length. A remote nbd-client could use this flaw to crash the qemu-nbd server resulting in a denial of service.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4
Vector AV:N/AC:L/Au:S/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:L CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required Low None
User Interaction None None
Scope Changed Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Low High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1172710 [CONFIRMED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES15-SP2-CHOST-BYOS-Ali
Image SLES15-SP2-CHOST-BYOS-Azure
Image SLES15-SP2-CHOST-BYOS-EC2
Image SLES15-SP2-CHOST-BYOS-GCE
Image SLES15-SP2-CHOST-BYOS-OpenStack
  • qemu-tools >= 4.2.1-11.4.4
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • qemu >= 4.2.1-11.4.4
  • qemu-tools >= 4.2.1-11.4.4
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2020-2015
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • qemu >= 4.2.1-11.4.4
  • qemu-arm >= 4.2.1-11.4.4
  • qemu-audio-alsa >= 4.2.1-11.4.4
  • qemu-audio-pa >= 4.2.1-11.4.4
  • qemu-block-dmg >= 4.2.1-11.4.4
  • qemu-extra >= 4.2.1-11.4.4
  • qemu-linux-user >= 4.2.1-11.4.1
  • qemu-microvm >= 4.2.1-11.4.4
  • qemu-ppc >= 4.2.1-11.4.4
  • qemu-s390 >= 4.2.1-11.4.4
  • qemu-seabios >= 1.12.1+-11.4.4
  • qemu-sgabios >= 8-11.4.4
  • qemu-testsuite >= 4.2.1-11.4.6
  • qemu-ui-curses >= 4.2.1-11.4.4
  • qemu-ui-gtk >= 4.2.1-11.4.4
  • qemu-vhost-user-gpu >= 4.2.1-11.4.4
  • qemu-x86 >= 4.2.1-11.4.4
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2020-2015
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • qemu >= 4.2.1-11.4.4
  • qemu-arm >= 4.2.1-11.4.4
  • qemu-audio-alsa >= 4.2.1-11.4.4
  • qemu-audio-pa >= 4.2.1-11.4.4
  • qemu-block-curl >= 4.2.1-11.4.4
  • qemu-block-iscsi >= 4.2.1-11.4.4
  • qemu-block-rbd >= 4.2.1-11.4.4
  • qemu-block-ssh >= 4.2.1-11.4.4
  • qemu-guest-agent >= 4.2.1-11.4.4
  • qemu-ipxe >= 1.0.0+-11.4.4
  • qemu-kvm >= 4.2.1-11.4.4
  • qemu-lang >= 4.2.1-11.4.4
  • qemu-microvm >= 4.2.1-11.4.4
  • qemu-ppc >= 4.2.1-11.4.4
  • qemu-s390 >= 4.2.1-11.4.4
  • qemu-seabios >= 1.12.1+-11.4.4
  • qemu-sgabios >= 8-11.4.4
  • qemu-ui-curses >= 4.2.1-11.4.4
  • qemu-ui-gtk >= 4.2.1-11.4.4
  • qemu-ui-spice-app >= 4.2.1-11.4.4
  • qemu-vgabios >= 1.12.1+-11.4.4
  • qemu-x86 >= 4.2.1-11.4.4
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP2-2020-2015
openSUSE Leap 15.2
  • qemu >= 4.2.1-lp152.9.3.1
  • qemu-arm >= 4.2.1-lp152.9.3.1
  • qemu-arm-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-audio-alsa >= 4.2.1-lp152.9.3.1
  • qemu-audio-alsa-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-audio-pa >= 4.2.1-lp152.9.3.1
  • qemu-audio-pa-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-audio-sdl >= 4.2.1-lp152.9.3.1
  • qemu-audio-sdl-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-block-curl >= 4.2.1-lp152.9.3.1
  • qemu-block-curl-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-block-dmg >= 4.2.1-lp152.9.3.1
  • qemu-block-dmg-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-block-gluster >= 4.2.1-lp152.9.3.1
  • qemu-block-gluster-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-block-iscsi >= 4.2.1-lp152.9.3.1
  • qemu-block-iscsi-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-block-nfs >= 4.2.1-lp152.9.3.1
  • qemu-block-nfs-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-block-rbd >= 4.2.1-lp152.9.3.1
  • qemu-block-rbd-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-block-ssh >= 4.2.1-lp152.9.3.1
  • qemu-block-ssh-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-debugsource >= 4.2.1-lp152.9.3.1
  • qemu-extra >= 4.2.1-lp152.9.3.1
  • qemu-extra-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-guest-agent >= 4.2.1-lp152.9.3.1
  • qemu-guest-agent-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-ipxe >= 1.0.0+-lp152.9.3.1
  • qemu-ksm >= 4.2.1-lp152.9.3.1
  • qemu-kvm >= 4.2.1-lp152.9.3.1
  • qemu-lang >= 4.2.1-lp152.9.3.1
  • qemu-linux-user >= 4.2.1-lp152.9.3.1
  • qemu-linux-user-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-linux-user-debugsource >= 4.2.1-lp152.9.3.1
  • qemu-microvm >= 4.2.1-lp152.9.3.1
  • qemu-ppc >= 4.2.1-lp152.9.3.1
  • qemu-ppc-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-s390 >= 4.2.1-lp152.9.3.1
  • qemu-s390-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-seabios >= 1.12.1+-lp152.9.3.1
  • qemu-sgabios >= 8-lp152.9.3.1
  • qemu-testsuite >= 4.2.1-lp152.9.3.1
  • qemu-tools >= 4.2.1-lp152.9.3.1
  • qemu-tools-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-ui-curses >= 4.2.1-lp152.9.3.1
  • qemu-ui-curses-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-ui-gtk >= 4.2.1-lp152.9.3.1
  • qemu-ui-gtk-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-ui-sdl >= 4.2.1-lp152.9.3.1
  • qemu-ui-sdl-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-ui-spice-app >= 4.2.1-lp152.9.3.1
  • qemu-ui-spice-app-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-vgabios >= 1.12.1+-lp152.9.3.1
  • qemu-vhost-user-gpu >= 4.2.1-lp152.9.3.1
  • qemu-vhost-user-gpu-debuginfo >= 4.2.1-lp152.9.3.1
  • qemu-x86 >= 4.2.1-lp152.9.3.1
  • qemu-x86-debuginfo >= 4.2.1-lp152.9.3.1
Patchnames:
openSUSE-2020-1108


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
kvm Not affected
SLES for SAP Applications kvm Not affected
SUSE CaaS Platform 3.0 qemu Not affected
SUSE Container as a Service Platform 1.0 qemu Affected
SUSE Container as a Service Platform 2.0 qemu Not affected
SUSE Linux Enterprise 15 Module for Basesystem qemu Not affected
SUSE Linux Enterprise 15 Module for Server Applications qemu Not affected
SUSE Linux Enterprise 15-SP1 Module for Basesystem qemu Not affected
SUSE Linux Enterprise 15-SP1 Module for Server Applications qemu Not affected
SUSE Linux Enterprise 15-SP2 Module for Basesystem qemu Released
SUSE Linux Enterprise 15-SP2 Module for Server Applications qemu Released
SUSE Linux Enterprise Desktop 11 kvm Not affected
SUSE Linux Enterprise Desktop 11 SP1 kvm Not affected
SUSE Linux Enterprise Desktop 11 SP2 kvm Not affected
SUSE Linux Enterprise Desktop 11 SP3 kvm Not affected
SUSE Linux Enterprise Desktop 11 SP4 kvm Not affected
SUSE Linux Enterprise Desktop 12 qemu Not affected
SUSE Linux Enterprise Desktop 12 SP1 qemu Not affected
SUSE Linux Enterprise Desktop 12 SP2 qemu Not affected
SUSE Linux Enterprise Desktop 12 SP3 qemu Not affected
SUSE Linux Enterprise Desktop 12 SP4 qemu Not affected
SUSE Linux Enterprise Desktop 12 SP5 qemu Not affected
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search kvm Not affected
SUSE Linux Enterprise High Performance Computing 12 SP2 qemu Not affected
SUSE Linux Enterprise High Performance Computing 12 SP3 qemu Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 qemu Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 qemu Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS qemu Not affected
SUSE Linux Enterprise Point of Service 11 SP2 qemu Not affected
SUSE Linux Enterprise Point of Service 11 SP3 qemu Not affected
SUSE Linux Enterprise Server 11 kvm Not affected
SUSE Linux Enterprise Server 11 SP1 kvm Not affected
SUSE Linux Enterprise Server 11 SP1 LTSS kvm Not affected
SUSE Linux Enterprise Server 11 SP2 kvm Not affected
SUSE Linux Enterprise Server 11 SP2 LTSS kvm Not affected
SUSE Linux Enterprise Server 11 SP3 kvm Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS kvm Not affected
SUSE Linux Enterprise Server 11 SP4 kvm Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS kvm Not affected
SUSE Linux Enterprise Server 12 qemu Not affected
SUSE Linux Enterprise Server 12 LTSS qemu Not affected
SUSE Linux Enterprise Server 12 SP1 qemu Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS qemu Not affected
SUSE Linux Enterprise Server 12 SP2 qemu Not affected
SUSE Linux Enterprise Server 12 SP2 BCL qemu Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS qemu Not affected
SUSE Linux Enterprise Server 12 SP3 qemu Not affected
SUSE Linux Enterprise Server 12 SP3 BCL qemu Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS qemu Not affected
SUSE Linux Enterprise Server 12 SP4 qemu Not affected
SUSE Linux Enterprise Server 12 SP5 qemu Not affected
SUSE Linux Enterprise Server 15 LTSS qemu Not affected
SUSE Linux Enterprise Server ESPOS 15 qemu Not affected
SUSE Linux Enterprise Server for SAP Applications 12 qemu Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 qemu Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 qemu Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 qemu Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 qemu Not affected
SUSE Linux Enterprise Server for SAP Business All-in-One kvm Not affected
SUSE Linux Enterprise Server for the Raspberry Pi qemu Not affected
SUSE Linux Enterprise Software Development Kit 11 qemu Not affected
SUSE Linux Enterprise Software Development Kit 11 SP1 qemu Not affected
SUSE Linux Enterprise Software Development Kit 11 SP2 qemu Not affected
SUSE Linux Enterprise Software Development Kit 11 SP3 qemu Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 qemu Not affected
SUSE Studio Extension for System z 1.2 kvm Not affected
SUSE Studio Onsite qemu Not affected