Upstream information

CVE-2020-10749 at MITRE

Description

A vulnerability was found in all versions of containernetworking/plugins before version 0.8.6, that allows malicious containers in Kubernetes clusters to perform man-in-the-middle (MitM) attacks. A malicious container can exploit this flaw by sending rogue IPv6 router advertisements to the host or other containers, to redirect traffic to the malicious container.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6
Vector AV:N/AC:M/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6 6
Vector CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:L CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:L
Access Vector Network Network
Access Complexity High High
Privileges Required Low Low
User Interaction None None
Scope Changed Changed
Confidentiality Impact Low Low
Integrity Impact Low Low
Availability Impact Low Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entries: 1172375 [NEW], 1172410 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container caasp/v4.5/cilium:1.7.6
Container caasp/v4/cilium:1.6.6
Image caasp4/caasp-cilium-image
Image caasp45/caasp-cilium-image
  • cni-plugins >= 0.8.6-3.6.1
SUSE Linux Enterprise Module for Containers 15 SP1
  • cni-plugins >= 0.8.6-3.6.1
Patchnames:
SUSE-SLE-Module-Containers-15-SP1-2020-1957
SUSE Linux Enterprise Module for Containers 15 SP2
  • cni-plugins >= 0.8.6-3.6.1
Patchnames:
SUSE-SLE-Module-Containers-15-SP2-2020-1957
SUSE Linux Enterprise Module for Public Cloud 15 SP1
  • cni-plugins >= 0.8.6-3.6.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-15-SP1-2020-1957
openSUSE Leap 15.1
  • cni-plugins >= 0.8.6-lp151.2.6.1
Patchnames:
openSUSE-2020-1049
openSUSE Leap 15.2
  • cni-plugins >= 0.8.6-lp152.2.4.1
Patchnames:
openSUSE-2020-1050


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 3.0 cni-plugins Affected
SUSE Linux Enterprise 15 Module for Public Cloud cni-plugins Affected
SUSE Linux Enterprise 15-SP1 Module for Containers cni-plugins Released
SUSE Linux Enterprise 15-SP1 Module for Public Cloud cni-plugins Released
SUSE Linux Enterprise 15-SP2 Module for Containers cni-plugins Released
SUSE Linux Enterprise 15-SP2 Module for Public Cloud cni-plugins Released