Upstream information

CVE-2020-10703 at MITRE

Description

A NULL pointer dereference was found in the libvirt API responsible introduced in upstream version 3.10.0, and fixed in libvirt 6.0.0, for fetching a storage pool based on its target path. In more detail, this flaw affects storage pools created without a target path such as network-based pools like gluster and RBD. Unprivileged users with a read-only connection could abuse this flaw to crash the libvirt daemon, resulting in a potential denial of service.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4
Vector AV:N/AC:L/Au:S/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 6.5
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1168683 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • libvirt >= 4.0.0-9.32.1
  • libvirt-admin >= 4.0.0-9.32.1
  • libvirt-client >= 4.0.0-9.32.1
  • libvirt-daemon >= 4.0.0-9.32.1
  • libvirt-daemon-config-network >= 4.0.0-9.32.1
  • libvirt-daemon-config-nwfilter >= 4.0.0-9.32.1
  • libvirt-daemon-driver-interface >= 4.0.0-9.32.1
  • libvirt-daemon-driver-libxl >= 4.0.0-9.32.1
  • libvirt-daemon-driver-lxc >= 4.0.0-9.32.1
  • libvirt-daemon-driver-network >= 4.0.0-9.32.1
  • libvirt-daemon-driver-nodedev >= 4.0.0-9.32.1
  • libvirt-daemon-driver-nwfilter >= 4.0.0-9.32.1
  • libvirt-daemon-driver-qemu >= 4.0.0-9.32.1
  • libvirt-daemon-driver-secret >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage-core >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage-disk >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage-iscsi >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage-logical >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage-mpath >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage-rbd >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage-scsi >= 4.0.0-9.32.1
  • libvirt-daemon-hooks >= 4.0.0-9.32.1
  • libvirt-daemon-lxc >= 4.0.0-9.32.1
  • libvirt-daemon-qemu >= 4.0.0-9.32.1
  • libvirt-daemon-xen >= 4.0.0-9.32.1
  • libvirt-devel >= 4.0.0-9.32.1
  • libvirt-doc >= 4.0.0-9.32.1
  • libvirt-libs >= 4.0.0-9.32.1
  • libvirt-lock-sanlock >= 4.0.0-9.32.1
  • libvirt-nss >= 4.0.0-9.32.1
Patchnames:
SUSE-SLE-Product-HPC-15-2020-1250
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libvirt >= 5.1.0-8.16.1
  • libvirt-libs >= 5.1.0-8.16.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2020-1208
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • libvirt >= 5.1.0-8.16.1
  • libvirt-devel-32bit >= 5.1.0-8.16.1
  • wireshark-plugin-libvirt >= 5.1.0-8.16.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-1208
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • libvirt >= 5.1.0-8.16.1
  • libvirt-admin >= 5.1.0-8.16.1
  • libvirt-bash-completion >= 5.1.0-8.16.1
  • libvirt-client >= 5.1.0-8.16.1
  • libvirt-daemon >= 5.1.0-8.16.1
  • libvirt-daemon-config-network >= 5.1.0-8.16.1
  • libvirt-daemon-config-nwfilter >= 5.1.0-8.16.1
  • libvirt-daemon-driver-interface >= 5.1.0-8.16.1
  • libvirt-daemon-driver-libxl >= 5.1.0-8.16.1
  • libvirt-daemon-driver-lxc >= 5.1.0-8.16.1
  • libvirt-daemon-driver-network >= 5.1.0-8.16.1
  • libvirt-daemon-driver-nodedev >= 5.1.0-8.16.1
  • libvirt-daemon-driver-nwfilter >= 5.1.0-8.16.1
  • libvirt-daemon-driver-qemu >= 5.1.0-8.16.1
  • libvirt-daemon-driver-secret >= 5.1.0-8.16.1
  • libvirt-daemon-driver-storage >= 5.1.0-8.16.1
  • libvirt-daemon-driver-storage-core >= 5.1.0-8.16.1
  • libvirt-daemon-driver-storage-disk >= 5.1.0-8.16.1
  • libvirt-daemon-driver-storage-iscsi >= 5.1.0-8.16.1
  • libvirt-daemon-driver-storage-logical >= 5.1.0-8.16.1
  • libvirt-daemon-driver-storage-mpath >= 5.1.0-8.16.1
  • libvirt-daemon-driver-storage-rbd >= 5.1.0-8.16.1
  • libvirt-daemon-driver-storage-scsi >= 5.1.0-8.16.1
  • libvirt-daemon-hooks >= 5.1.0-8.16.1
  • libvirt-daemon-lxc >= 5.1.0-8.16.1
  • libvirt-daemon-qemu >= 5.1.0-8.16.1
  • libvirt-daemon-xen >= 5.1.0-8.16.1
  • libvirt-devel >= 5.1.0-8.16.1
  • libvirt-doc >= 5.1.0-8.16.1
  • libvirt-lock-sanlock >= 5.1.0-8.16.1
  • libvirt-nss >= 5.1.0-8.16.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP1-2020-1208
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libvirt >= 4.0.0-8.20.2
  • libvirt-admin >= 4.0.0-8.20.2
  • libvirt-client >= 4.0.0-8.20.2
  • libvirt-daemon >= 4.0.0-8.20.2
  • libvirt-daemon-config-network >= 4.0.0-8.20.2
  • libvirt-daemon-config-nwfilter >= 4.0.0-8.20.2
  • libvirt-daemon-driver-interface >= 4.0.0-8.20.2
  • libvirt-daemon-driver-libxl >= 4.0.0-8.20.2
  • libvirt-daemon-driver-lxc >= 4.0.0-8.20.2
  • libvirt-daemon-driver-network >= 4.0.0-8.20.2
  • libvirt-daemon-driver-nodedev >= 4.0.0-8.20.2
  • libvirt-daemon-driver-nwfilter >= 4.0.0-8.20.2
  • libvirt-daemon-driver-qemu >= 4.0.0-8.20.2
  • libvirt-daemon-driver-secret >= 4.0.0-8.20.2
  • libvirt-daemon-driver-storage >= 4.0.0-8.20.2
  • libvirt-daemon-driver-storage-core >= 4.0.0-8.20.2
  • libvirt-daemon-driver-storage-disk >= 4.0.0-8.20.2
  • libvirt-daemon-driver-storage-iscsi >= 4.0.0-8.20.2
  • libvirt-daemon-driver-storage-logical >= 4.0.0-8.20.2
  • libvirt-daemon-driver-storage-mpath >= 4.0.0-8.20.2
  • libvirt-daemon-driver-storage-rbd >= 4.0.0-8.20.2
  • libvirt-daemon-driver-storage-scsi >= 4.0.0-8.20.2
  • libvirt-daemon-hooks >= 4.0.0-8.20.2
  • libvirt-daemon-lxc >= 4.0.0-8.20.2
  • libvirt-daemon-qemu >= 4.0.0-8.20.2
  • libvirt-daemon-xen >= 4.0.0-8.20.2
  • libvirt-doc >= 4.0.0-8.20.2
  • libvirt-libs >= 4.0.0-8.20.2
  • libvirt-lock-sanlock >= 4.0.0-8.20.2
  • libvirt-nss >= 4.0.0-8.20.2
Patchnames:
SUSE-SLE-SERVER-12-SP4-2020-1289
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libvirt >= 5.1.0-13.6.2
  • libvirt-admin >= 5.1.0-13.6.2
  • libvirt-client >= 5.1.0-13.6.2
  • libvirt-daemon >= 5.1.0-13.6.2
  • libvirt-daemon-config-network >= 5.1.0-13.6.2
  • libvirt-daemon-config-nwfilter >= 5.1.0-13.6.2
  • libvirt-daemon-driver-interface >= 5.1.0-13.6.2
  • libvirt-daemon-driver-libxl >= 5.1.0-13.6.2
  • libvirt-daemon-driver-lxc >= 5.1.0-13.6.2
  • libvirt-daemon-driver-network >= 5.1.0-13.6.2
  • libvirt-daemon-driver-nodedev >= 5.1.0-13.6.2
  • libvirt-daemon-driver-nwfilter >= 5.1.0-13.6.2
  • libvirt-daemon-driver-qemu >= 5.1.0-13.6.2
  • libvirt-daemon-driver-secret >= 5.1.0-13.6.2
  • libvirt-daemon-driver-storage >= 5.1.0-13.6.2
  • libvirt-daemon-driver-storage-core >= 5.1.0-13.6.2
  • libvirt-daemon-driver-storage-disk >= 5.1.0-13.6.2
  • libvirt-daemon-driver-storage-iscsi >= 5.1.0-13.6.2
  • libvirt-daemon-driver-storage-logical >= 5.1.0-13.6.2
  • libvirt-daemon-driver-storage-mpath >= 5.1.0-13.6.2
  • libvirt-daemon-driver-storage-rbd >= 5.1.0-13.6.2
  • libvirt-daemon-driver-storage-scsi >= 5.1.0-13.6.2
  • libvirt-daemon-hooks >= 5.1.0-13.6.2
  • libvirt-daemon-lxc >= 5.1.0-13.6.2
  • libvirt-daemon-qemu >= 5.1.0-13.6.2
  • libvirt-daemon-xen >= 5.1.0-13.6.2
  • libvirt-doc >= 5.1.0-13.6.2
  • libvirt-libs >= 5.1.0-13.6.2
  • libvirt-lock-sanlock >= 5.1.0-13.6.2
  • libvirt-nss >= 5.1.0-13.6.2
Patchnames:
SUSE-SLE-SERVER-12-SP5-2020-1277
SUSE Linux Enterprise Server 15-LTSS
  • libvirt >= 4.0.0-9.32.1
  • libvirt-admin >= 4.0.0-9.32.1
  • libvirt-client >= 4.0.0-9.32.1
  • libvirt-daemon >= 4.0.0-9.32.1
  • libvirt-daemon-config-network >= 4.0.0-9.32.1
  • libvirt-daemon-config-nwfilter >= 4.0.0-9.32.1
  • libvirt-daemon-driver-interface >= 4.0.0-9.32.1
  • libvirt-daemon-driver-libxl >= 4.0.0-9.32.1
  • libvirt-daemon-driver-lxc >= 4.0.0-9.32.1
  • libvirt-daemon-driver-network >= 4.0.0-9.32.1
  • libvirt-daemon-driver-nodedev >= 4.0.0-9.32.1
  • libvirt-daemon-driver-nwfilter >= 4.0.0-9.32.1
  • libvirt-daemon-driver-qemu >= 4.0.0-9.32.1
  • libvirt-daemon-driver-secret >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage-core >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage-disk >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage-iscsi >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage-logical >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage-mpath >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage-rbd >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage-scsi >= 4.0.0-9.32.1
  • libvirt-daemon-hooks >= 4.0.0-9.32.1
  • libvirt-daemon-lxc >= 4.0.0-9.32.1
  • libvirt-daemon-qemu >= 4.0.0-9.32.1
  • libvirt-daemon-xen >= 4.0.0-9.32.1
  • libvirt-devel >= 4.0.0-9.32.1
  • libvirt-doc >= 4.0.0-9.32.1
  • libvirt-libs >= 4.0.0-9.32.1
  • libvirt-lock-sanlock >= 4.0.0-9.32.1
  • libvirt-nss >= 4.0.0-9.32.1
Patchnames:
SUSE-SLE-Product-SLES-15-2020-1250
SUSE Linux Enterprise Server for SAP Applications 15
  • libvirt >= 4.0.0-9.32.1
  • libvirt-admin >= 4.0.0-9.32.1
  • libvirt-client >= 4.0.0-9.32.1
  • libvirt-daemon >= 4.0.0-9.32.1
  • libvirt-daemon-config-network >= 4.0.0-9.32.1
  • libvirt-daemon-config-nwfilter >= 4.0.0-9.32.1
  • libvirt-daemon-driver-interface >= 4.0.0-9.32.1
  • libvirt-daemon-driver-libxl >= 4.0.0-9.32.1
  • libvirt-daemon-driver-lxc >= 4.0.0-9.32.1
  • libvirt-daemon-driver-network >= 4.0.0-9.32.1
  • libvirt-daemon-driver-nodedev >= 4.0.0-9.32.1
  • libvirt-daemon-driver-nwfilter >= 4.0.0-9.32.1
  • libvirt-daemon-driver-qemu >= 4.0.0-9.32.1
  • libvirt-daemon-driver-secret >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage-core >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage-disk >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage-iscsi >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage-logical >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage-mpath >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage-rbd >= 4.0.0-9.32.1
  • libvirt-daemon-driver-storage-scsi >= 4.0.0-9.32.1
  • libvirt-daemon-hooks >= 4.0.0-9.32.1
  • libvirt-daemon-lxc >= 4.0.0-9.32.1
  • libvirt-daemon-qemu >= 4.0.0-9.32.1
  • libvirt-daemon-xen >= 4.0.0-9.32.1
  • libvirt-devel >= 4.0.0-9.32.1
  • libvirt-doc >= 4.0.0-9.32.1
  • libvirt-libs >= 4.0.0-9.32.1
  • libvirt-lock-sanlock >= 4.0.0-9.32.1
  • libvirt-nss >= 4.0.0-9.32.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2020-1250
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libvirt >= 4.0.0-8.20.2
  • libvirt-devel >= 4.0.0-8.20.2
Patchnames:
SUSE-SLE-SDK-12-SP4-2020-1289
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libvirt >= 5.1.0-13.6.2
  • libvirt-devel >= 5.1.0-13.6.2
Patchnames:
SUSE-SLE-SDK-12-SP5-2020-1277


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise 15-SP1 Module for Basesystem libvirt Released
SUSE Linux Enterprise 15-SP1 Module for Server Applications libvirt Released
SUSE Linux Enterprise High Performance Computing 12 SP4 libvirt Released
SUSE Linux Enterprise High Performance Computing 12 SP5 libvirt Released
SUSE Linux Enterprise High Performance Computing 15 LTSS libvirt Released
SUSE Linux Enterprise Server 11 SP1 libvirt Not affected
SUSE Linux Enterprise Server 11 SP3 libvirt Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS libvirt Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS libvirt Not affected
SUSE Linux Enterprise Server 12 SP2 BCL libvirt Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS libvirt Not affected
SUSE Linux Enterprise Server 12 SP3 BCL libvirt Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS libvirt Not affected
SUSE Linux Enterprise Server 12 SP4 libvirt Released
SUSE Linux Enterprise Server 12 SP5 libvirt Released
SUSE Linux Enterprise Server 15 LTSS libvirt Released
SUSE Linux Enterprise Server ESPOS 15 libvirt Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libvirt Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libvirt Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libvirt Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libvirt Released
SUSE Linux Enterprise Software Development Kit 12 SP4 libvirt Released
SUSE Linux Enterprise Software Development Kit 12 SP5 libvirt Released