Upstream information

CVE-2020-10188 at MITRE

Description

utility.c in telnetd in netkit telnet through 0.17 allows remote attackers to execute arbitrary code via short writes or urgent data, because of a buffer overflow involving the netclear and nextitem functions.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 8.1
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1165787 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • krb5-appl >= 1.0.3-3.3.1
  • krb5-appl-clients >= 1.0.3-3.3.1
  • krb5-appl-servers >= 1.0.3-3.3.1
Patchnames:
HPE-Helion-OpenStack-8-2020-1533
SUSE Enterprise Storage 5
  • krb5-appl >= 1.0.3-3.3.1
  • krb5-appl-clients >= 1.0.3-3.3.1
  • krb5-appl-servers >= 1.0.3-3.3.1
Patchnames:
SUSE-Storage-5-2020-1533
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • krb5-appl >= 1.0.3-3.3.1
  • krb5-appl-clients >= 1.0.3-3.3.1
  • krb5-appl-servers >= 1.0.3-3.3.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2020-1533
SUSE Linux Enterprise Server 12 SP2-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • krb5-appl >= 1.0.3-3.3.1
  • krb5-appl-clients >= 1.0.3-3.3.1
  • krb5-appl-servers >= 1.0.3-3.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2020-1533
SUSE Linux Enterprise Server 12 SP2-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • krb5-appl >= 1.0.3-3.3.1
  • krb5-appl-clients >= 1.0.3-3.3.1
  • krb5-appl-servers >= 1.0.3-3.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2020-1533
SUSE Linux Enterprise Server 12 SP2-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • krb5-appl >= 1.0.3-3.3.1
  • krb5-appl-clients >= 1.0.3-3.3.1
  • krb5-appl-servers >= 1.0.3-3.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2020-1533
SUSE Linux Enterprise Server 12 SP3-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • krb5-appl >= 1.0.3-3.3.1
  • krb5-appl-clients >= 1.0.3-3.3.1
  • krb5-appl-servers >= 1.0.3-3.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2020-1533
SUSE Linux Enterprise Server 12 SP3-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • krb5-appl >= 1.0.3-3.3.1
  • krb5-appl-clients >= 1.0.3-3.3.1
  • krb5-appl-servers >= 1.0.3-3.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2020-1533
SUSE Linux Enterprise Server 12 SP3-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • krb5-appl >= 1.0.3-3.3.1
  • krb5-appl-clients >= 1.0.3-3.3.1
  • krb5-appl-servers >= 1.0.3-3.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2020-1533
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • krb5-appl >= 1.0.3-3.3.1
  • krb5-appl-clients >= 1.0.3-3.3.1
  • krb5-appl-servers >= 1.0.3-3.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2020-1533
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • krb5-appl >= 1.0.3-3.3.1
  • krb5-appl-clients >= 1.0.3-3.3.1
  • krb5-appl-servers >= 1.0.3-3.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2020-1533
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • krb5-appl >= 1.0.3-3.3.1
  • krb5-appl-clients >= 1.0.3-3.3.1
  • krb5-appl-servers >= 1.0.3-3.3.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2020-1533
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • krb5-appl >= 1.0.3-3.3.1
  • krb5-appl-clients >= 1.0.3-3.3.1
  • krb5-appl-servers >= 1.0.3-3.3.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2020-1533
SUSE OpenStack Cloud 7
  • krb5-appl >= 1.0.3-3.3.1
  • krb5-appl-clients >= 1.0.3-3.3.1
  • krb5-appl-servers >= 1.0.3-3.3.1
Patchnames:
SUSE-OpenStack-Cloud-7-2020-1533
SUSE OpenStack Cloud 8
  • krb5-appl >= 1.0.3-3.3.1
  • krb5-appl-clients >= 1.0.3-3.3.1
  • krb5-appl-servers >= 1.0.3-3.3.1
Patchnames:
SUSE-OpenStack-Cloud-8-2020-1533
SUSE OpenStack Cloud Crowbar 8
  • krb5-appl >= 1.0.3-3.3.1
  • krb5-appl-clients >= 1.0.3-3.3.1
  • krb5-appl-servers >= 1.0.3-3.3.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2020-1533


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise 15 Module for Basesystem telnet Not affected
SUSE Linux Enterprise 15 Module for Legacy telnet Not affected
SUSE Linux Enterprise 15-SP1 Module for Basesystem telnet Not affected
SUSE Linux Enterprise 15-SP1 Module for Legacy telnet Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 krb5-appl Released
SUSE Linux Enterprise High Performance Computing 12 SP4 telnet Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 krb5-appl Released
SUSE Linux Enterprise High Performance Computing 12 SP5 telnet Not affected
SUSE Linux Enterprise Server 11 SP1 telnet Not affected
SUSE Linux Enterprise Server 11 SP3 telnet Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS telnet Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS krb5-appl Affected
SUSE Linux Enterprise Server 12 SP1 LTSS telnet Not affected
SUSE Linux Enterprise Server 12 SP2 BCL krb5-appl Released
SUSE Linux Enterprise Server 12 SP2 BCL telnet Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS krb5-appl Released
SUSE Linux Enterprise Server 12 SP2 LTSS telnet Not affected
SUSE Linux Enterprise Server 12 SP3 BCL krb5-appl Released
SUSE Linux Enterprise Server 12 SP3 BCL telnet Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS krb5-appl Released
SUSE Linux Enterprise Server 12 SP3 LTSS telnet Not affected
SUSE Linux Enterprise Server 12 SP4 krb5-appl Released
SUSE Linux Enterprise Server 12 SP4 telnet Not affected
SUSE Linux Enterprise Server 12 SP5 krb5-appl Released
SUSE Linux Enterprise Server 12 SP5 telnet Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 krb5-appl Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 telnet Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 krb5-appl Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 telnet Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 krb5-appl Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 telnet Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 krb5-appl Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 telnet Not affected