Upstream information

CVE-2020-0452 at MITRE

Description

In exif_entry_get_value of exif-entry.c, there is a possible out of bounds write due to an integer overflow. This could lead to remote code execution if a third party app used this library to process remote image data with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android-8.1 Android-9 Android-10 Android-11 Android-8.0Android ID: A-159625731

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1178479 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 libexif Affected
SUSE Enterprise Storage 5 libexif Unsupported
SUSE Linux Enterprise High Performance Computing 12 SP5 libexif Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 libexif Unsupported
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 libexif Affected
SUSE Linux Enterprise Point of Service 11 SP3 libexif Affected
SUSE Linux Enterprise Point of Service Image Server 12 libexif Unsupported
SUSE Linux Enterprise Server 11 SP4 LTSS libexif Affected
SUSE Linux Enterprise Server 12 SP2 BCL libexif Affected
SUSE Linux Enterprise Server 12 SP2 ESPOS libexif Unsupported
SUSE Linux Enterprise Server 12 SP2 LTSS libexif Affected
SUSE Linux Enterprise Server 12 SP3 BCL libexif Affected
SUSE Linux Enterprise Server 12 SP3 ESPOS libexif Affected
SUSE Linux Enterprise Server 12 SP3 LTSS libexif Affected
SUSE Linux Enterprise Server 12 SP4 ESPOS libexif Affected
SUSE Linux Enterprise Server 12 SP4 LTSS libexif Affected
SUSE Linux Enterprise Server 12 SP5 libexif Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libexif Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libexif Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libexif Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libexif Affected
SUSE OpenStack Cloud 7 libexif Affected
SUSE OpenStack Cloud 8 libexif Affected
SUSE OpenStack Cloud 9 libexif Affected
SUSE OpenStack Cloud Crowbar 8 libexif Affected
SUSE OpenStack Cloud Crowbar 9 libexif Affected