Upstream information

CVE-2019-9917 at MITRE

Description

ZNC before 1.7.3-rc1 allows an existing remote user to cause a Denial of Service (crash) via invalid encoding.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4
Vector AV:N/AC:L/Au:S/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 1130360 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub for SUSE Linux Enterprise 12
  • znc >= 1.7.2-23.1
  • znc-debuginfo >= 1.7.2-lp150.25.1
  • znc-debugsource >= 1.7.2-lp150.25.1
  • znc-devel >= 1.7.2-23.1
  • znc-lang >= 1.7.2-23.1
  • znc-perl >= 1.7.2-23.1
  • znc-perl-debuginfo >= 1.7.2-lp150.25.1
  • znc-python3 >= 1.7.2-23.1
  • znc-python3-debuginfo >= 1.7.2-lp150.25.1
  • znc-tcl >= 1.7.2-23.1
  • znc-tcl-debuginfo >= 1.7.2-lp150.25.1
Patchnames:
openSUSE-2019-1166
SUSE Package Hub for SUSE Linux Enterprise 12 SP2
  • znc >= 1.7.2-25.1
  • znc-debuginfo >= 1.7.2-lp150.25.1
  • znc-debugsource >= 1.7.2-lp150.25.1
  • znc-devel >= 1.7.2-25.1
  • znc-lang >= 1.7.2-25.1
  • znc-perl >= 1.7.2-25.1
  • znc-perl-debuginfo >= 1.7.2-lp150.25.1
  • znc-python3 >= 1.7.2-25.1
  • znc-python3-debuginfo >= 1.7.2-lp150.25.1
  • znc-tcl >= 1.7.2-25.1
  • znc-tcl-debuginfo >= 1.7.2-lp150.25.1
Patchnames:
openSUSE-2019-1166
openSUSE Leap 15.0
  • znc >= 1.7.4-lp150.28.1
  • znc-debuginfo >= 1.7.4-lp150.28.1
  • znc-debugsource >= 1.7.4-lp150.28.1
  • znc-devel >= 1.7.4-lp150.28.1
  • znc-lang >= 1.7.4-lp150.28.1
  • znc-perl >= 1.7.4-lp150.28.1
  • znc-perl-debuginfo >= 1.7.4-lp150.28.1
  • znc-python3 >= 1.7.4-lp150.28.1
  • znc-python3-debuginfo >= 1.7.4-lp150.28.1
  • znc-tcl >= 1.7.4-lp150.28.1
  • znc-tcl-debuginfo >= 1.7.4-lp150.28.1
Patchnames:
openSUSE-2019-1166
openSUSE-2019-1775
openSUSE Leap 15.1
  • znc >= 1.7.4-lp151.2.3.1
  • znc-debuginfo >= 1.7.4-lp151.2.3.1
  • znc-debugsource >= 1.7.4-lp151.2.3.1
  • znc-devel >= 1.7.4-lp151.2.3.1
  • znc-lang >= 1.7.4-lp151.2.3.1
  • znc-perl >= 1.7.4-lp151.2.3.1
  • znc-perl-debuginfo >= 1.7.4-lp151.2.3.1
  • znc-python3 >= 1.7.4-lp151.2.3.1
  • znc-python3-debuginfo >= 1.7.4-lp151.2.3.1
  • znc-tcl >= 1.7.4-lp151.2.3.1
  • znc-tcl-debuginfo >= 1.7.4-lp151.2.3.1
Patchnames:
openSUSE-2019-1775
openSUSE Leap 42.3
  • znc >= 1.7.2-25.1
  • znc-debuginfo >= 1.7.2-25.1
  • znc-debugsource >= 1.7.2-25.1
  • znc-devel >= 1.7.2-25.1
  • znc-lang >= 1.7.2-25.1
  • znc-perl >= 1.7.2-25.1
  • znc-perl-debuginfo >= 1.7.2-25.1
  • znc-python3 >= 1.7.2-25.1
  • znc-python3-debuginfo >= 1.7.2-25.1
  • znc-tcl >= 1.7.2-25.1
  • znc-tcl-debuginfo >= 1.7.2-25.1
Patchnames:
openSUSE-2019-1166