Upstream information

CVE-2019-9893 at MITRE

Description

libseccomp before 2.4.0 did not correctly generate 64-bit syscall argument comparisons using the arithmetic operators (LT, GT, LE, GE), which might able to lead to bypassing seccomp filters and potential privilege escalations.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 5.1
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High None
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1128828 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container caasp/v4.5/cilium:1.7.6
Container caasp/v4.5/etcd:3.4.3
Container caasp/v4.5/grafana:7.0.3
Container caasp/v4.5/kube-controller-manager:v1.18.6
Container caasp/v4.5/kube-proxy:v1.18.6
Container caasp/v4.5/prometheus-alertmanager:0.16.2
Container caasp/v4.5/prometheus-node-exporter:0.18.1
Container caasp/v4.5/prometheus-pushgateway:0.6.0
Container caasp/v4.5/prometheus-server:2.18.0
Container caasp/v4.5/rsyslog:8.39.0
Container caasp/v4/389-ds:1.4.0
Container caasp/v4/cilium:1.6.6
Container caasp/v4/etcd:3.4.3
Container caasp/v4/grafana:6.2.5
Container caasp/v4/hyperkube:v1.17.4
Container caasp/v4/prometheus-alertmanager:0.16.2
Container caasp/v4/prometheus-node-exporter:0.17.0
Container caasp/v4/prometheus-pushgateway:0.6.0
Container caasp/v4/prometheus-server:2.7.1
Image SLES15-EC2-CHOST-HVM-BYOS
Image SLES15-SP1-CHOST-BYOS-Ali
Image SLES15-SP1-CHOST-BYOS-Azure
Image SLES15-SP1-CHOST-BYOS-EC2
Image SLES15-SP1-CHOST-BYOS-GCE
Image SLES15-SP1-CHOST-BYOS-OpenStack
Image SLES15-SP2-CHOST-BYOS-Ali
Image SLES15-SP2-CHOST-BYOS-Azure
Image SLES15-SP2-CHOST-BYOS-EC2
Image SLES15-SP2-CHOST-BYOS-GCE
Image SLES15-SP2-CHOST-BYOS-OpenStack
Image caasp4/caasp-cilium-image
Image caasp4/caasp-etcd-image
Image caasp4/caasp-grafana-image
Image caasp4/caasp-hyperkube-image
Image caasp4/caasp-prometheus-alertmanager-image
Image caasp4/caasp-prometheus-node-exporter-image
Image caasp4/caasp-prometheus-pushgateway-image
Image caasp4/caasp-prometheus-server-image
Image caasp4/caasp-rsyslog-image
Image caasp45/caasp-cilium-image
Image caasp45/caasp-etcd-image
Image caasp45/caasp-grafana-image
Image caasp45/caasp-kube-controller-manager-image
Image caasp45/caasp-kube-proxy-image
Image caasp45/caasp-prometheus-alertmanager-image
Image caasp45/caasp-prometheus-node-exporter-image
Image caasp45/caasp-prometheus-pushgateway-image
Image caasp45/caasp-prometheus-server-image
Image caasp45/caasp-rsyslog-image
  • libseccomp2 >= 2.4.1-3.3.1
HPE Helion Openstack 8
  • libseccomp >= 2.4.1-11.3.2
  • libseccomp2 >= 2.4.1-11.3.2
  • libseccomp2-32bit >= 2.4.1-11.3.2
Patchnames:
HPE-Helion-OpenStack-8-2019-2941
SUSE CaaS Platform 3.0
  • libseccomp >= 2.4.1-11.3.2
  • libseccomp2 >= 2.4.1-11.3.2
Patchnames:
SUSE-CAASP-3.0-2019-2941
SUSE Enterprise Storage 5
  • libseccomp >= 2.4.1-11.3.2
  • libseccomp2 >= 2.4.1-11.3.2
  • libseccomp2-32bit >= 2.4.1-11.3.2
Patchnames:
SUSE-Storage-5-2019-2941
SUSE Linux Enterprise Desktop 12 SP4
  • libseccomp >= 2.4.1-11.3.2
  • libseccomp2 >= 2.4.1-11.3.2
  • libseccomp2-32bit >= 2.4.1-11.3.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-2941
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libseccomp >= 2.4.1-3.3.1
  • libseccomp-devel >= 2.4.1-3.3.1
  • libseccomp2 >= 2.4.1-3.3.1
  • libseccomp2-32bit >= 2.4.1-3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-2517
SUSE Linux Enterprise Module for Basesystem 15
  • libseccomp >= 2.4.1-3.3.1
  • libseccomp-devel >= 2.4.1-3.3.1
  • libseccomp2 >= 2.4.1-3.3.1
  • libseccomp2-32bit >= 2.4.1-3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-2517
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • libseccomp >= 2.4.1-3.3.1
  • libseccomp-tools >= 2.4.1-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2517
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • libseccomp >= 2.4.1-3.3.1
  • libseccomp-tools >= 2.4.1-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-2517
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • libseccomp >= 2.4.1-11.3.2
  • libseccomp2 >= 2.4.1-11.3.2
  • libseccomp2-32bit >= 2.4.1-11.3.2
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-2941
SUSE Linux Enterprise Server 12 SP2-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • libseccomp >= 2.4.1-11.3.2
  • libseccomp2 >= 2.4.1-11.3.2
  • libseccomp2-32bit >= 2.4.1-11.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-2941
SUSE Linux Enterprise Server 12 SP2-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • libseccomp >= 2.4.1-11.3.2
  • libseccomp2 >= 2.4.1-11.3.2
  • libseccomp2-32bit >= 2.4.1-11.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-2941
SUSE Linux Enterprise Server 12 SP2-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • libseccomp >= 2.4.1-11.3.2
  • libseccomp2 >= 2.4.1-11.3.2
  • libseccomp2-32bit >= 2.4.1-11.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-2941
SUSE Linux Enterprise Server 12 SP3-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • libseccomp >= 2.4.1-11.3.2
  • libseccomp2 >= 2.4.1-11.3.2
  • libseccomp2-32bit >= 2.4.1-11.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-2941
SUSE Linux Enterprise Server 12 SP3-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • libseccomp >= 2.4.1-11.3.2
  • libseccomp2 >= 2.4.1-11.3.2
  • libseccomp2-32bit >= 2.4.1-11.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-2941
SUSE Linux Enterprise Server 12 SP3-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • libseccomp >= 2.4.1-11.3.2
  • libseccomp2 >= 2.4.1-11.3.2
  • libseccomp2-32bit >= 2.4.1-11.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-2941
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libseccomp >= 2.4.1-11.3.2
  • libseccomp2 >= 2.4.1-11.3.2
  • libseccomp2-32bit >= 2.4.1-11.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-2941
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libseccomp >= 2.4.1-11.3.2
  • libseccomp2 >= 2.4.1-11.3.2
  • libseccomp2-32bit >= 2.4.1-11.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP5-2019-2941
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libseccomp >= 2.4.1-11.3.2
  • libseccomp2 >= 2.4.1-11.3.2
  • libseccomp2-32bit >= 2.4.1-11.3.2
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-2941
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libseccomp >= 2.4.1-11.3.2
  • libseccomp2 >= 2.4.1-11.3.2
  • libseccomp2-32bit >= 2.4.1-11.3.2
Patchnames:
SUSE-SLE-SAP-12-SP3-2019-2941
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libseccomp >= 2.4.1-11.3.2
  • libseccomp-devel >= 2.4.1-11.3.2
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-2941
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libseccomp >= 2.4.1-11.3.2
  • libseccomp-devel >= 2.4.1-11.3.2
Patchnames:
SUSE-SLE-SDK-12-SP5-2019-2941
SUSE OpenStack Cloud 7
  • libseccomp >= 2.4.1-11.3.2
  • libseccomp2 >= 2.4.1-11.3.2
  • libseccomp2-32bit >= 2.4.1-11.3.2
Patchnames:
SUSE-OpenStack-Cloud-7-2019-2941
SUSE OpenStack Cloud 8
  • libseccomp >= 2.4.1-11.3.2
  • libseccomp2 >= 2.4.1-11.3.2
  • libseccomp2-32bit >= 2.4.1-11.3.2
Patchnames:
SUSE-OpenStack-Cloud-8-2019-2941
SUSE OpenStack Cloud Crowbar 8
  • libseccomp >= 2.4.1-11.3.2
  • libseccomp2 >= 2.4.1-11.3.2
  • libseccomp2-32bit >= 2.4.1-11.3.2
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-2941
openSUSE Leap 15.0
  • libseccomp >= 2.4.1-lp150.2.3.1
  • libseccomp-debugsource >= 2.4.1-lp150.2.3.1
  • libseccomp-devel >= 2.4.1-lp150.2.3.1
  • libseccomp-tools >= 2.4.1-lp150.2.3.1
  • libseccomp-tools-debuginfo >= 2.4.1-lp150.2.3.1
  • libseccomp2 >= 2.4.1-lp150.2.3.1
  • libseccomp2-32bit >= 2.4.1-lp150.2.3.1
  • libseccomp2-32bit-debuginfo >= 2.4.1-lp150.2.3.1
  • libseccomp2-debuginfo >= 2.4.1-lp150.2.3.1
Patchnames:
openSUSE-2019-2280
openSUSE Leap 15.1
  • libseccomp >= 2.4.1-lp151.3.3.1
  • libseccomp-debugsource >= 2.4.1-lp151.3.3.1
  • libseccomp-devel >= 2.4.1-lp151.3.3.1
  • libseccomp-tools >= 2.4.1-lp151.3.3.1
  • libseccomp-tools-debuginfo >= 2.4.1-lp151.3.3.1
  • libseccomp2 >= 2.4.1-lp151.3.3.1
  • libseccomp2-32bit >= 2.4.1-lp151.3.3.1
  • libseccomp2-32bit-debuginfo >= 2.4.1-lp151.3.3.1
  • libseccomp2-debuginfo >= 2.4.1-lp151.3.3.1
Patchnames:
openSUSE-2019-2283


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
Magnum Orchestration libseccomp Affected
SLES for SAP Applications libseccomp Affected
SUSE CaaS Platform 3.0 libseccomp Released
SUSE Container as a Service Platform 1.0 libseccomp Affected
SUSE Container as a Service Platform 2.0 libseccomp Affected
SUSE Linux Enterprise 15 Module for Basesystem libseccomp Released
SUSE Linux Enterprise 15-SP1 Module for Basesystem libseccomp Released
SUSE Linux Enterprise Desktop 12 SP3 libseccomp Affected
SUSE Linux Enterprise Desktop 12 SP4 libseccomp Released
SUSE Linux Enterprise High Performance Computing 12 SP4 libseccomp Released
SUSE Linux Enterprise High Performance Computing 12 SP5 libseccomp Released
SUSE Linux Enterprise Server 11 SP3 libseccomp Affected
SUSE Linux Enterprise Server 11 SP3 LTSS libseccomp Affected
SUSE Linux Enterprise Server 11 SP4 libseccomp Affected
SUSE Linux Enterprise Server 12 LTSS libseccomp Affected
SUSE Linux Enterprise Server 12 SP1 LTSS libseccomp Affected
SUSE Linux Enterprise Server 12 SP2 LTSS libseccomp Released
SUSE Linux Enterprise Server 12 SP3 libseccomp Affected
SUSE Linux Enterprise Server 12 SP3 LTSS libseccomp Released
SUSE Linux Enterprise Server 12 SP4 libseccomp Released
SUSE Linux Enterprise Server 12 SP5 libseccomp Released
SUSE Linux Enterprise Server for SAP Applications 12 libseccomp Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libseccomp Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libseccomp Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libseccomp Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libseccomp Released
SUSE Linux Enterprise Software Development Kit 11 SP4 libseccomp Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 libseccomp Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 libseccomp Released