Upstream information

CVE-2019-9704 at MITRE

Description

Vixie Cron before the 3.0pl1-133 Debian package allows local users to cause a denial of service (daemon crash) via a large crontab file because the calloc return value is not checked.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:N/I:N/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 3.3
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High Low
SUSE Bugzilla entry: 1128937 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform 3.0
  • cron >= 4.2-59.10.1
  • cronie >= 1.4.11-59.10.1
Patchnames:
SUSE-CAASP-3.0-2019-1990
SUSE Linux Enterprise Desktop 12 SP4
  • cron >= 4.2-59.10.1
  • cronie >= 1.4.11-59.10.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-1990
SUSE Linux Enterprise Module for Basesystem 15
  • cron >= 4.2-6.7.1
  • cronie >= 1.5.1-6.7.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-1389
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • cron >= 4.2-6.7.1
  • cronie >= 1.5.1-6.7.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-1389
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • cronie >= 1.5.1-6.7.1
  • cronie-anacron >= 1.5.1-6.7.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-1389
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • cronie >= 1.5.1-6.7.1
  • cronie-anacron >= 1.5.1-6.7.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-1389
SUSE Linux Enterprise Server 12 SP4
  • cron >= 4.2-59.10.1
  • cronie >= 1.4.11-59.10.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1990
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • cron >= 4.2-59.10.1
  • cronie >= 1.4.11-59.10.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1990
openSUSE Leap 15.0
  • cron >= 4.2-lp150.3.3.1
  • cronie >= 1.5.1-lp150.3.3.1
  • cronie-anacron >= 1.5.1-lp150.3.3.1
  • cronie-anacron-debuginfo >= 1.5.1-lp150.3.3.1
  • cronie-debuginfo >= 1.5.1-lp150.3.3.1
  • cronie-debugsource >= 1.5.1-lp150.3.3.1
Patchnames:
openSUSE-2019-1520
openSUSE Leap 15.1
  • cron >= 4.2-lp151.4.3.1
  • cronie >= 1.5.1-lp151.4.3.1
  • cronie-anacron >= 1.5.1-lp151.4.3.1
  • cronie-anacron-debuginfo >= 1.5.1-lp151.4.3.1
  • cronie-debuginfo >= 1.5.1-lp151.4.3.1
  • cronie-debugsource >= 1.5.1-lp151.4.3.1
Patchnames:
openSUSE-2019-1520


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 cronie In progress
CaaS Platform 3.0 cronie Released
OpenStack Cloud Magnum Orchestration 7.0 cronie In progress
SUSE Linux Enterprise Desktop 12 SP3 cronie In progress
SUSE Linux Enterprise Desktop 12 SP4 cronie Released
SUSE Linux Enterprise High Performance Computing 12 cronie Released
SUSE Linux Enterprise Module for Basesystem 15 GA cronie Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 cronie Released
SUSE Linux Enterprise Server 11 SP3 LTSS cron Affected
SUSE Linux Enterprise Server 11 SP4 cron In progress
SUSE Linux Enterprise Server 12 GA LTSS cronie Affected
SUSE Linux Enterprise Server 12 SP1 LTSS cronie Affected
SUSE Linux Enterprise Server 12 SP2 LTSS cronie Affected
SUSE Linux Enterprise Server 12 SP3 cronie In progress
SUSE Linux Enterprise Server 12 SP4 cronie Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 cron Affected
SUSE Linux Enterprise Server for SAP Applications 12 GA cronie Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 cronie Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 cronie Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 cronie Released