Upstream information

CVE-2019-9495 at MITRE

Description

The implementations of EAP-PWD in hostapd and wpa_supplicant are vulnerable to side-channel attacks as a result of cache access patterns. All versions of hostapd and wpa_supplicant with EAP-PWD support are vulnerable. The ability to install and execute applications is necessary for a successful attack. Memory access patterns are visible in a shared cache. Weak passwords may be cracked. Versions of hostapd/wpa_supplicant 2.7 and newer, are not vulnerable to the timing attack described in CVE-2019-9494. Both hostapd with EAP-pwd support and wpa_supplicant with EAP-pwd support prior to and including version 2.7 are affected.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 3.7 5.9
Vector AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N
Access Vector Network Adjacent Network
Access Complexity High High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact Low High
Integrity Impact None Low
Availability Impact None None
SUSE Bugzilla entries: 1131291 [IN_PROGRESS], 1131870 [NEW]

SUSE Security Advisories:
  • TID7023818, published Fri Apr 12 11:38:05 CEST 2019


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 wpa_supplicant Affected
SUSE Linux Enterprise Desktop 12 SP4 wpa_supplicant Affected
SUSE Linux Enterprise High Performance Computing 12 wpa_supplicant Affected
SUSE Linux Enterprise Module for Basesystem 15 GA wpa_supplicant Affected
SUSE Linux Enterprise Server 11 SP3 LTSS wpa_supplicant Not affected
SUSE Linux Enterprise Server 11 SP4 wpa_supplicant Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS wpa_supplicant Not affected
SUSE Linux Enterprise Server 12 GA LTSS wpa_supplicant Affected
SUSE Linux Enterprise Server 12 SP1 LTSS wpa_supplicant Affected
SUSE Linux Enterprise Server 12 SP2 LTSS wpa_supplicant Affected
SUSE Linux Enterprise Server 12 SP3 wpa_supplicant Affected
SUSE Linux Enterprise Server 12 SP4 wpa_supplicant Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 wpa_supplicant Not affected
SUSE Linux Enterprise Server for SAP Applications 12 GA wpa_supplicant Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 wpa_supplicant Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 wpa_supplicant Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 wpa_supplicant Affected