Upstream information

CVE-2019-9200 at MITRE

Description

A heap-based buffer underwrite exists in ImageStream::getLine() located at Stream.cc in Poppler 0.74.0 that can (for example) be triggered by sending a crafted PDF file to the pdfimages binary. It allows an attacker to cause Denial of Service (Segmentation fault) or possibly have unspecified other impact.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 7.8
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
SUSE Bugzilla entry: 1127329 [NEW]

No SUSE Security Announcements cross referenced.

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Module for Basesystem 15
  • libpoppler-cpp0 >= 0.62.0-4.3.3
  • libpoppler-cpp0-debuginfo >= 0.62.0-4.3.3
  • libpoppler-devel >= 0.62.0-4.3.3
  • libpoppler-glib-devel >= 0.62.0-4.3.3
  • libpoppler-glib8 >= 0.62.0-4.3.3
  • libpoppler-glib8-debuginfo >= 0.62.0-4.3.3
  • libpoppler73 >= 0.62.0-4.3.3
  • libpoppler73-debuginfo >= 0.62.0-4.3.3
  • poppler >= 0.62.0-4.3.3
  • poppler-debugsource >= 0.62.0-4.3.3
  • poppler-tools >= 0.62.0-4.3.3
  • poppler-tools-debuginfo >= 0.62.0-4.3.3
  • typelib-1_0-Poppler-0_18 >= 0.62.0-4.3.3
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libpoppler-cpp0 >= 0.62.0-4.3.3
  • libpoppler-cpp0-debuginfo >= 0.62.0-4.3.3
  • libpoppler-devel >= 0.62.0-4.3.3
  • libpoppler-glib-devel >= 0.62.0-4.3.3
  • libpoppler-glib8 >= 0.62.0-4.3.3
  • libpoppler-glib8-debuginfo >= 0.62.0-4.3.3
  • libpoppler73 >= 0.62.0-4.3.3
  • libpoppler73-debuginfo >= 0.62.0-4.3.3
  • poppler >= 0.62.0-4.3.3
  • poppler-debugsource >= 0.62.0-4.3.3
  • poppler-tools >= 0.62.0-4.3.3
  • poppler-tools-debuginfo >= 0.62.0-4.3.3
  • typelib-1_0-Poppler-0_18 >= 0.62.0-4.3.3
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • libpoppler-qt5-1 >= 0.62.0-4.3.3
  • libpoppler-qt5-1-debuginfo >= 0.62.0-4.3.3
  • libpoppler-qt5-devel >= 0.62.0-4.3.3
  • poppler-qt5 >= 0.62.0-4.3.3
  • poppler-qt5-debugsource >= 0.62.0-4.3.3
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • libpoppler-cpp0-32bit >= 0.62.0-4.3.2
  • libpoppler-cpp0-32bit-debuginfo >= 0.62.0-4.3.2
  • libpoppler-glib8-32bit >= 0.62.0-4.3.2
  • libpoppler-glib8-32bit-debuginfo >= 0.62.0-4.3.2
  • libpoppler-qt5-1 >= 0.62.0-4.3.3
  • libpoppler-qt5-1-32bit >= 0.62.0-4.3.2
  • libpoppler-qt5-1-32bit-debuginfo >= 0.62.0-4.3.2
  • libpoppler-qt5-1-debuginfo >= 0.62.0-4.3.3
  • libpoppler-qt5-devel >= 0.62.0-4.3.3
  • libpoppler73-32bit >= 0.62.0-4.3.2
  • libpoppler73-32bit-debuginfo >= 0.62.0-4.3.2
  • poppler >= 0.62.0-4.3.3
  • poppler-debugsource >= 0.62.0-4.3.3
  • poppler-qt5 >= 0.62.0-4.3.3
  • poppler-qt5-debugsource >= 0.62.0-4.3.3


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise BSK 12 SP3 poppler Not affected
SUSE Linux Enterprise BSK 12 SP4 poppler Not affected
SUSE Linux Enterprise Desktop 12 SP3 poppler Not affected
SUSE Linux Enterprise Desktop 12 SP4 poppler Not affected
SUSE Linux Enterprise High Performance Computing 12 poppler Not affected
SUSE Linux Enterprise Module for Basesystem 15 GA poppler In progress
SUSE Linux Enterprise Module for Basesystem 15 SP1 poppler In progress
SUSE Linux Enterprise SDK 11 SP4 poppler Not affected
SUSE Linux Enterprise SDK 12 SP3 poppler Not affected
SUSE Linux Enterprise SDK 12 SP4 poppler Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS poppler Not affected
SUSE Linux Enterprise Server 11 SP4 poppler Not affected
SUSE Linux Enterprise Server 12 GA LTSS poppler Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS poppler Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS poppler Not affected
SUSE Linux Enterprise Server 12 SP3 poppler Not affected
SUSE Linux Enterprise Server 12 SP4 poppler Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 poppler Not affected
SUSE Linux Enterprise Server for SAP Applications 12 GA poppler Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 poppler Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 poppler Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 poppler Not affected