Upstream information

CVE-2019-8674 at MITRE

Description

A logic issue was addressed with improved state management. This issue is fixed in iOS 13, Safari 13. Processing maliciously crafted web content may lead to universal cross site scripting.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.1
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Changed
Confidentiality Impact Low
Integrity Impact Low
Availability Impact None
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1155321 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libjavascriptcoregtk-4_0-18 >= 2.26.2-3.34.3
  • libwebkit2gtk-4_0-37 >= 2.26.2-3.34.3
  • libwebkit2gtk3-lang >= 2.26.2-3.34.3
  • webkit2gtk-4_0-injected-bundles >= 2.26.2-3.34.3
  • webkit2gtk3 >= 2.26.2-3.34.3
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-3044
SUSE Linux Enterprise Module for Basesystem 15
  • libjavascriptcoregtk-4_0-18 >= 2.26.2-3.34.3
  • libwebkit2gtk-4_0-37 >= 2.26.2-3.34.3
  • libwebkit2gtk3-lang >= 2.26.2-3.34.3
  • webkit2gtk-4_0-injected-bundles >= 2.26.2-3.34.3
  • webkit2gtk3 >= 2.26.2-3.34.3
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-3044
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.26.2-3.34.3
  • typelib-1_0-WebKit2-4_0 >= 2.26.2-3.34.3
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.26.2-3.34.3
  • webkit2gtk3 >= 2.26.2-3.34.3
  • webkit2gtk3-devel >= 2.26.2-3.34.3
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP1-2019-3044
SUSE Linux Enterprise Module for Desktop Applications 15
  • typelib-1_0-JavaScriptCore-4_0 >= 2.26.2-3.34.3
  • typelib-1_0-WebKit2-4_0 >= 2.26.2-3.34.3
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.26.2-3.34.3
  • webkit2gtk3 >= 2.26.2-3.34.3
  • webkit2gtk3-devel >= 2.26.2-3.34.3
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2019-3044
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • libjavascriptcoregtk-4_0-18-32bit >= 2.26.2-3.34.3
  • libwebkit2gtk-4_0-37-32bit >= 2.26.2-3.34.3
  • webkit-jsc-4 >= 2.26.2-3.34.3
  • webkit2gtk3 >= 2.26.2-3.34.3
  • webkit2gtk3-minibrowser >= 2.26.2-3.34.3
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-3044
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • webkit-jsc-4 >= 2.26.2-3.34.3
  • webkit2gtk3 >= 2.26.2-3.34.3
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-3044
openSUSE Leap 15.0
  • libjavascriptcoregtk-4_0-18 >= 2.26.2-lp150.2.28.1
  • libjavascriptcoregtk-4_0-18-32bit >= 2.26.2-lp150.2.28.1
  • libjavascriptcoregtk-4_0-18-32bit-debuginfo >= 2.26.2-lp150.2.28.1
  • libjavascriptcoregtk-4_0-18-debuginfo >= 2.26.2-lp150.2.28.1
  • libwebkit2gtk-4_0-37 >= 2.26.2-lp150.2.28.1
  • libwebkit2gtk-4_0-37-32bit >= 2.26.2-lp150.2.28.1
  • libwebkit2gtk-4_0-37-32bit-debuginfo >= 2.26.2-lp150.2.28.1
  • libwebkit2gtk-4_0-37-debuginfo >= 2.26.2-lp150.2.28.1
  • libwebkit2gtk3-lang >= 2.26.2-lp150.2.28.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.26.2-lp150.2.28.1
  • typelib-1_0-WebKit2-4_0 >= 2.26.2-lp150.2.28.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.26.2-lp150.2.28.1
  • webkit-jsc-4 >= 2.26.2-lp150.2.28.1
  • webkit-jsc-4-debuginfo >= 2.26.2-lp150.2.28.1
  • webkit2gtk-4_0-injected-bundles >= 2.26.2-lp150.2.28.1
  • webkit2gtk-4_0-injected-bundles-debuginfo >= 2.26.2-lp150.2.28.1
  • webkit2gtk3 >= 2.26.2-lp150.2.28.1
  • webkit2gtk3-debugsource >= 2.26.2-lp150.2.28.1
  • webkit2gtk3-devel >= 2.26.2-lp150.2.28.1
  • webkit2gtk3-minibrowser >= 2.26.2-lp150.2.28.1
  • webkit2gtk3-minibrowser-debuginfo >= 2.26.2-lp150.2.28.1
Patchnames:
openSUSE-2019-2587
openSUSE Leap 15.1
  • libjavascriptcoregtk-4_0-18 >= 2.26.2-lp151.2.9.1
  • libjavascriptcoregtk-4_0-18-32bit >= 2.26.2-lp151.2.9.1
  • libjavascriptcoregtk-4_0-18-32bit-debuginfo >= 2.26.2-lp151.2.9.1
  • libjavascriptcoregtk-4_0-18-debuginfo >= 2.26.2-lp151.2.9.1
  • libwebkit2gtk-4_0-37 >= 2.26.2-lp151.2.9.1
  • libwebkit2gtk-4_0-37-32bit >= 2.26.2-lp151.2.9.1
  • libwebkit2gtk-4_0-37-32bit-debuginfo >= 2.26.2-lp151.2.9.1
  • libwebkit2gtk-4_0-37-debuginfo >= 2.26.2-lp151.2.9.1
  • libwebkit2gtk3-lang >= 2.26.2-lp151.2.9.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.26.2-lp151.2.9.1
  • typelib-1_0-WebKit2-4_0 >= 2.26.2-lp151.2.9.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.26.2-lp151.2.9.1
  • webkit-jsc-4 >= 2.26.2-lp151.2.9.1
  • webkit-jsc-4-debuginfo >= 2.26.2-lp151.2.9.1
  • webkit2gtk-4_0-injected-bundles >= 2.26.2-lp151.2.9.1
  • webkit2gtk-4_0-injected-bundles-debuginfo >= 2.26.2-lp151.2.9.1
  • webkit2gtk3 >= 2.26.2-lp151.2.9.1
  • webkit2gtk3-debugsource >= 2.26.2-lp151.2.9.1
  • webkit2gtk3-devel >= 2.26.2-lp151.2.9.1
  • webkit2gtk3-minibrowser >= 2.26.2-lp151.2.9.1
  • webkit2gtk3-minibrowser-debuginfo >= 2.26.2-lp151.2.9.1
Patchnames:
openSUSE-2019-2591


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Business Critical Linux 12 SP2 webkit2gtk3 Released
SUSE Business Critical Linux 12 SP3 webkit2gtk3 Released
SUSE Linux Enterprise Desktop 12 SP4 webkit2gtk3 Affected
SUSE Linux Enterprise High Performance Computing 12 webkit2gtk3 Released
SUSE Linux Enterprise Module for Basesystem 15 GA webkit2gtk3 Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 webkit2gtk3 Released
SUSE Linux Enterprise Module for Desktop Applications 15 GA webkit2gtk3 Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 webkit2gtk3 Released
SUSE Linux Enterprise SDK 12 SP4 webkit2gtk3 Released
SUSE Linux Enterprise SDK 12 SP5 webkit2gtk3 Released
SUSE Linux Enterprise Server 12 SP2 LTSS webkit2gtk3 Released
SUSE Linux Enterprise Server 12 SP3 LTSS webkit2gtk3 Released
SUSE Linux Enterprise Server 12 SP4 webkit2gtk3 Released
SUSE Linux Enterprise Server 12 SP5 webkit2gtk3 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 webkit2gtk3 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 webkit2gtk3 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 webkit2gtk3 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 webkit2gtk3 Released
SUSE Linux Enterprise Workstation Extension 12 SP4 webkit2gtk3 Released