Upstream information

CVE-2019-6471 at MITRE

Description

A race condition which may occur when discarding malformed packets can result in BIND exiting due to a REQUIRE assertion failure in dispatch.c. Versions affected: BIND 9.11.0 -> 9.11.7, 9.12.0 -> 9.12.4-P1, 9.14.0 -> 9.14.2. Also all releases of the BIND 9.13 development branch and version 9.15.0 of the BIND 9.15 development branch and BIND Supported Preview Edition versions 9.11.3-S1 -> 9.11.7-S1.

SUSE information

Overall state of this security issue: Revisit

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  SUSE
Base Score 5.9
Vector AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 1138687 [REOPENED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP4
  • bind >= 9.11.2-3.10.1
  • bind-utils >= 9.11.2-3.10.1
  • libbind9-160 >= 9.11.2-3.10.1
  • libdns169 >= 9.11.2-3.10.1
  • libirs160 >= 9.11.2-3.10.1
  • libisc166 >= 9.11.2-3.10.1
  • libisc166-32bit >= 9.11.2-3.10.1
  • libisccc160 >= 9.11.2-3.10.1
  • libisccfg160 >= 9.11.2-3.10.1
  • liblwres160 >= 9.11.2-3.10.1
  • python-bind >= 9.11.2-3.10.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-2502
SUSE Linux Enterprise Module for Basesystem 15
  • bind >= 9.11.2-12.13.2
  • bind-devel >= 9.11.2-12.13.2
  • bind-utils >= 9.11.2-12.13.2
  • libbind9-160 >= 9.11.2-12.13.2
  • libdns169 >= 9.11.2-12.13.2
  • libirs-devel >= 9.11.2-12.13.2
  • libirs160 >= 9.11.2-12.13.2
  • libisc166 >= 9.11.2-12.13.2
  • libisccc160 >= 9.11.2-12.13.2
  • libisccfg160 >= 9.11.2-12.13.2
  • liblwres160 >= 9.11.2-12.13.2
  • python3-bind >= 9.11.2-12.13.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-2550
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • bind >= 9.11.2-12.13.2
  • bind-devel >= 9.11.2-12.13.2
  • bind-utils >= 9.11.2-12.13.2
  • libbind9-160 >= 9.11.2-12.13.2
  • libdns169 >= 9.11.2-12.13.2
  • libirs-devel >= 9.11.2-12.13.2
  • libirs160 >= 9.11.2-12.13.2
  • libisc166 >= 9.11.2-12.13.2
  • libisccc160 >= 9.11.2-12.13.2
  • libisccfg160 >= 9.11.2-12.13.2
  • liblwres160 >= 9.11.2-12.13.2
  • python3-bind >= 9.11.2-12.13.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-2550
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • bind >= 9.11.2-12.13.2
  • bind-lwresd >= 9.11.2-12.13.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-2550
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • bind >= 9.11.2-12.13.2
  • bind-devel-32bit >= 9.11.2-12.13.2
  • bind-lwresd >= 9.11.2-12.13.2
  • libbind9-160-32bit >= 9.11.2-12.13.2
  • libdns169-32bit >= 9.11.2-12.13.2
  • libirs160-32bit >= 9.11.2-12.13.2
  • libisc166-32bit >= 9.11.2-12.13.2
  • libisccc160-32bit >= 9.11.2-12.13.2
  • libisccfg160-32bit >= 9.11.2-12.13.2
  • liblwres160-32bit >= 9.11.2-12.13.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2550
SUSE Linux Enterprise Module for Server Applications 15
  • bind >= 9.11.2-12.13.2
  • bind-chrootenv >= 9.11.2-12.13.2
  • bind-doc >= 9.11.2-12.13.2
Patchnames:
SUSE-SLE-Module-Server-Applications-15-2019-2550
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • bind >= 9.11.2-12.13.2
  • bind-chrootenv >= 9.11.2-12.13.2
  • bind-doc >= 9.11.2-12.13.2
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP1-2019-2550
SUSE Linux Enterprise Server 12 SP4
  • bind >= 9.11.2-3.10.1
  • bind-chrootenv >= 9.11.2-3.10.1
  • bind-doc >= 9.11.2-3.10.1
  • bind-utils >= 9.11.2-3.10.1
  • libbind9-160 >= 9.11.2-3.10.1
  • libdns169 >= 9.11.2-3.10.1
  • libirs160 >= 9.11.2-3.10.1
  • libisc166 >= 9.11.2-3.10.1
  • libisc166-32bit >= 9.11.2-3.10.1
  • libisccc160 >= 9.11.2-3.10.1
  • libisccfg160 >= 9.11.2-3.10.1
  • liblwres160 >= 9.11.2-3.10.1
  • python-bind >= 9.11.2-3.10.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-2502
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • bind >= 9.11.2-3.10.1
  • bind-chrootenv >= 9.11.2-3.10.1
  • bind-doc >= 9.11.2-3.10.1
  • bind-utils >= 9.11.2-3.10.1
  • libbind9-160 >= 9.11.2-3.10.1
  • libdns169 >= 9.11.2-3.10.1
  • libirs160 >= 9.11.2-3.10.1
  • libisc166 >= 9.11.2-3.10.1
  • libisc166-32bit >= 9.11.2-3.10.1
  • libisccc160 >= 9.11.2-3.10.1
  • libisccfg160 >= 9.11.2-3.10.1
  • liblwres160 >= 9.11.2-3.10.1
  • python-bind >= 9.11.2-3.10.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-2502
SUSE Linux Enterprise Software Development Kit 12 SP4
  • bind >= 9.11.2-3.10.1
  • bind-devel >= 9.11.2-3.10.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-2502
openSUSE Leap 15.0
  • bind >= 9.11.2-lp150.8.16.1
  • bind-chrootenv >= 9.11.2-lp150.8.16.1
  • bind-debuginfo >= 9.11.2-lp150.8.16.1
  • bind-debugsource >= 9.11.2-lp150.8.16.1
  • bind-devel >= 9.11.2-lp150.8.16.1
  • bind-devel-32bit >= 9.11.2-lp150.8.16.1
  • bind-doc >= 9.11.2-lp150.8.16.1
  • bind-lwresd >= 9.11.2-lp150.8.16.1
  • bind-lwresd-debuginfo >= 9.11.2-lp150.8.16.1
  • bind-utils >= 9.11.2-lp150.8.16.1
  • bind-utils-debuginfo >= 9.11.2-lp150.8.16.1
  • libbind9-160 >= 9.11.2-lp150.8.16.1
  • libbind9-160-32bit >= 9.11.2-lp150.8.16.1
  • libbind9-160-32bit-debuginfo >= 9.11.2-lp150.8.16.1
  • libbind9-160-debuginfo >= 9.11.2-lp150.8.16.1
  • libdns169 >= 9.11.2-lp150.8.16.1
  • libdns169-32bit >= 9.11.2-lp150.8.16.1
  • libdns169-32bit-debuginfo >= 9.11.2-lp150.8.16.1
  • libdns169-debuginfo >= 9.11.2-lp150.8.16.1
  • libirs-devel >= 9.11.2-lp150.8.16.1
  • libirs160 >= 9.11.2-lp150.8.16.1
  • libirs160-32bit >= 9.11.2-lp150.8.16.1
  • libirs160-32bit-debuginfo >= 9.11.2-lp150.8.16.1
  • libirs160-debuginfo >= 9.11.2-lp150.8.16.1
  • libisc166 >= 9.11.2-lp150.8.16.1
  • libisc166-32bit >= 9.11.2-lp150.8.16.1
  • libisc166-32bit-debuginfo >= 9.11.2-lp150.8.16.1
  • libisc166-debuginfo >= 9.11.2-lp150.8.16.1
  • libisccc160 >= 9.11.2-lp150.8.16.1
  • libisccc160-32bit >= 9.11.2-lp150.8.16.1
  • libisccc160-32bit-debuginfo >= 9.11.2-lp150.8.16.1
  • libisccc160-debuginfo >= 9.11.2-lp150.8.16.1
  • libisccfg160 >= 9.11.2-lp150.8.16.1
  • libisccfg160-32bit >= 9.11.2-lp150.8.16.1
  • libisccfg160-32bit-debuginfo >= 9.11.2-lp150.8.16.1
  • libisccfg160-debuginfo >= 9.11.2-lp150.8.16.1
  • liblwres160 >= 9.11.2-lp150.8.16.1
  • liblwres160-32bit >= 9.11.2-lp150.8.16.1
  • liblwres160-32bit-debuginfo >= 9.11.2-lp150.8.16.1
  • liblwres160-debuginfo >= 9.11.2-lp150.8.16.1
  • python3-bind >= 9.11.2-lp150.8.16.1
Patchnames:
openSUSE-2019-2263
openSUSE Leap 15.1
  • bind >= 9.11.2-lp151.11.6.1
  • bind-chrootenv >= 9.11.2-lp151.11.6.1
  • bind-debuginfo >= 9.11.2-lp151.11.6.1
  • bind-debugsource >= 9.11.2-lp151.11.6.1
  • bind-devel >= 9.11.2-lp151.11.6.1
  • bind-devel-32bit >= 9.11.2-lp151.11.6.1
  • bind-doc >= 9.11.2-lp151.11.6.1
  • bind-lwresd >= 9.11.2-lp151.11.6.1
  • bind-lwresd-debuginfo >= 9.11.2-lp151.11.6.1
  • bind-utils >= 9.11.2-lp151.11.6.1
  • bind-utils-debuginfo >= 9.11.2-lp151.11.6.1
  • libbind9-160 >= 9.11.2-lp151.11.6.1
  • libbind9-160-32bit >= 9.11.2-lp151.11.6.1
  • libbind9-160-32bit-debuginfo >= 9.11.2-lp151.11.6.1
  • libbind9-160-debuginfo >= 9.11.2-lp151.11.6.1
  • libdns169 >= 9.11.2-lp151.11.6.1
  • libdns169-32bit >= 9.11.2-lp151.11.6.1
  • libdns169-32bit-debuginfo >= 9.11.2-lp151.11.6.1
  • libdns169-debuginfo >= 9.11.2-lp151.11.6.1
  • libirs-devel >= 9.11.2-lp151.11.6.1
  • libirs160 >= 9.11.2-lp151.11.6.1
  • libirs160-32bit >= 9.11.2-lp151.11.6.1
  • libirs160-32bit-debuginfo >= 9.11.2-lp151.11.6.1
  • libirs160-debuginfo >= 9.11.2-lp151.11.6.1
  • libisc166 >= 9.11.2-lp151.11.6.1
  • libisc166-32bit >= 9.11.2-lp151.11.6.1
  • libisc166-32bit-debuginfo >= 9.11.2-lp151.11.6.1
  • libisc166-debuginfo >= 9.11.2-lp151.11.6.1
  • libisccc160 >= 9.11.2-lp151.11.6.1
  • libisccc160-32bit >= 9.11.2-lp151.11.6.1
  • libisccc160-32bit-debuginfo >= 9.11.2-lp151.11.6.1
  • libisccc160-debuginfo >= 9.11.2-lp151.11.6.1
  • libisccfg160 >= 9.11.2-lp151.11.6.1
  • libisccfg160-32bit >= 9.11.2-lp151.11.6.1
  • libisccfg160-32bit-debuginfo >= 9.11.2-lp151.11.6.1
  • libisccfg160-debuginfo >= 9.11.2-lp151.11.6.1
  • liblwres160 >= 9.11.2-lp151.11.6.1
  • liblwres160-32bit >= 9.11.2-lp151.11.6.1
  • liblwres160-32bit-debuginfo >= 9.11.2-lp151.11.6.1
  • liblwres160-debuginfo >= 9.11.2-lp151.11.6.1
  • python3-bind >= 9.11.2-lp151.11.6.1
Patchnames:
openSUSE-2019-2265


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 3.0 bind Not affected
SUSE Linux Enterprise Desktop 12 SP3 bind Not affected
SUSE Linux Enterprise Desktop 12 SP4 bind Released
SUSE Linux Enterprise High Performance Computing 12 bind Released
SUSE Linux Enterprise Module for Basesystem 15 GA bind In progress
SUSE Linux Enterprise Module for Basesystem 15 SP1 bind In progress
SUSE Linux Enterprise Module for Server Applications 15 GA bind In progress
SUSE Linux Enterprise Module for Server Applications 15 SP1 bind In progress
SUSE Linux Enterprise SDK 12 SP3 bind Not affected
SUSE Linux Enterprise SDK 12 SP4 bind Released
SUSE Linux Enterprise Server 11 SP3 LTSS bind Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS bind Not affected
SUSE Linux Enterprise Server 12 GA LTSS bind Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS bind Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS bind Not affected
SUSE Linux Enterprise Server 12 SP3 bind Not affected
SUSE Linux Enterprise Server 12 SP4 bind Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 bind Not affected
SUSE Linux Enterprise Server for SAP Applications 12 GA bind Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 bind Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 bind Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 bind Released